PDA

View Full Version : Installing mods?


Wheelman56
09-23-2010, 06:52 AM
I was trying to install the True starting locations earth map from the mod browser, but after downloading it never showed up in the "installed mods" tab. It just shows "NO MODS INSTALLED". I tried multiple times with several different mods, same result. I even downloaded the mod manually from a website and put it in the mods folder as instructed and no luck. A friend of mine seems to be having the same issue aswell.

Anyone know a workaround?

Davudu
09-23-2010, 07:01 AM
Im having the same problem. Not with that specific mod but with any. I downloaded the Example Clock mod, the Queen of the Iceni mod and.. something else I dont even remember now but none of the 3 mods I downloaded showed up in installed mods section. They do show up in the Downloads section as complete though.

LtChambers
09-23-2010, 07:36 PM
Ditto.

Cronjob
09-23-2010, 08:07 PM
Glad to know I wasn't the only one. I tried to install the clock. Nothing appeared.

starbuck
09-24-2010, 12:28 AM
Same here, anybody any solution?

Wheelman56
09-24-2010, 02:15 AM
Well I just had something new happen, tried installing the True Earth and Clock mods again and I went to the install tab and a new "Install Mods" button was at the bottom right... clicked it and... you guessed it... nothing.

Veshta
09-24-2010, 04:56 AM
I get a connection error when trying to get mods, so presume it is a network coding issue that has to be patched. Or maybe they just neglected to tell us that you can only access mods if connecting from a US IP . .who knows :)

LtChambers
09-24-2010, 06:06 AM
Apparently this is due to having the game installed on a drive other than C:. However, if all you want is modded maps you can extract the .civ5mod files manually (they're just zips). For TSL, it's:
Documents\My Games\Sid Meier's Civilization 5\MODS\3544a5d0-1c36-410b-9dc8-c3687a74cb05-1.civ5mod

Hack Scudder
09-24-2010, 06:48 AM
I tried to install several mods and get the same problem. The clock mod does show up as installed and I clicked the button to enable it, but it doesn't seem to work in the game. My game is installed on my C drive, too.

XantaKlawz
09-24-2010, 11:56 AM
Ditto on this problem. It says that I've d/l the clock, but I can't seem to install it. My game is installed on my D drive so that could be the problem. Although it shouldn't be, developers shouldn't expect games to be installed on the C drive's Program Files directory.

Anyone know a manual way to install a mod?

lumat83
09-24-2010, 11:58 AM
Same problem here.

Even I unzip the files in "My Documents" manually, the game don't see the mods and I can't install them.

My game is not installed on "C".

Hope a fix soon ...