PDA

View Full Version : Main Menu Issue


serieus1
09-28-2010, 01:21 AM
Let me know if anyone else is having an issue with this.

I can choose a game to play and start turning the knobs no problem. But once my game is over, I ran out of droplitz, if I hit replay, then no problem, but if I hit Menu, then it just sits there loading forever, never moving.

I've tried restarting the game and then hitting ESC and then quitting to main menu, but I still get the same loading screen that just sits there.

I'm just looking to see if this is an isolated issue or not.

nholmes
09-28-2010, 10:02 AM
hmm - this could be an issue when the game is attempting to save your progress - are you running on a machine where you don't have administrator rights when running the game?

step_ladder
12-01-2010, 05:54 PM
Yep, I also have this issue. Windows XP, running as a user with admin powers.

The progress does get saved, in the sense that it's still there after killing the process and restarting. If that screen (with the spinning X-piece, after choosing Main Menu) is just there during a save, then it's like it is missing a 'Saved' message and a 'Continue' button.

step_ladder
12-10-2010, 04:48 AM
Any word on this?

In short:
* Progress does get saved
* Replay works fine
* Main menu gets stuck on the loading screen with the spinning X-piece. It also has a scrolltext of my stats.


Related: When I tab out to kill the task, it 'sometimes' crashes anyway (this is why everything should have windowed mode nowadays :p). I'll definitely try to screen-cap that one next time.

magelore
12-10-2010, 12:06 PM
I am also encountering this issue attempting to return to the main menu. It is especially frustrating today as I wanted to get the treasure hunt objective as part of the steam challenge. My score is good enough, but it doesn't seem to count. I have admin rights on this computer, also windows xp.

magelore
12-10-2010, 12:39 PM
Just wanted to chime in here that I'm still waiting for droplitz to return to the main menu. To be fair to the game I've checked the forums here for people with the same problem/solutions, browsed the internet and then come back but it is over 30 minutes now. :(

TubeSockWarrior
12-10-2010, 01:29 PM
And here, too. Same as the others - game works fine but hangs after selecting Main Menu and never moves, have to kill the process manually.

serieus1
12-10-2010, 01:56 PM
I tried turning off my firewall in case that this was an issue of me never allowing my firewall to submit my score to the leaderboards, but even after that I'm still hung up on the loading main menu screen. It said, saved progress, but I think this was only a local save rather than a leaderboard saved progress. The weird thing is that Steam achievements have worked for this game, so you'd think that leaderboards and achievement would be connected somehow, so I don't think it's a firewall issue.

I'm also running on XP and with admin rights.

Because of this my score for the treasure hunt is not being accepted. I just score over 500,000 points just messing around for the second time and both times my score was not recorded in the leaderboards.

Can someone who isn't having this problem and has XP place a comment so I know if it's my computer (or the others as well) or if it's a game issue?

Urd
12-10-2010, 02:10 PM
Having the same problem with a 188k score, Windows xp sp3 with admin rights, droplitz has a firewall exception.

serieus1
12-10-2010, 02:31 PM
Hey guys, in game I can't look at the leaderboards, anyone else having this issue. I think there may be a correlation.

For a seccond there I saw the leaderboards in game, but it was only my friends and I, even though it was filtered for overall. I tried again, then it said check connection to steam. Then I tried it again and found the overall leaderboards.,...... finally.

So that seems to be part of the issue.

Then I play, hit 90k and just let the droplitz run out and frozen again on the re-entry to the main menu, and no leaderboard update with my score.

Oh hairy monkey nuts.......... I finally got to the main menu when alt-tabbing around while I waited. Checked the leaderboards again, in steam not in game, and there's my 90k score. I go back to the game, and I see the screen go to the main menu. My treasure hunt achievement is now unlocked. Yeah!!!

So devs, it looks like there's an issue with connecting to the leaderboards on some computers (not all it would seem), as my connection is constant here to the internet. I doubt too that it would take minutes to upload that kind of information.

TubeSockWarrior
12-10-2010, 02:59 PM
I can't even RANK on the leaderboards. I have over 300k points on the level I'm supposed to for the treasure hunt requirement and it will NOT post my score! In combination with the menu problem this is getting very frustrating now...

BaSeBallDuDeR
12-10-2010, 03:07 PM
Maddening!! I tried and tried to get this fixed but am having the same dang problem as everyone is describing. I have xp with admin stuff good and free. If it helps to know dev team that im running on a single core AMD 3000+ and 2 gigs of ram. I have a gtx 275 in my system and this game should work just fine, it does the loading thing over and over with me. I really would like my scores to be posted. This was one reason i stopped playing this game a while back because it just kept freezing, i would really like to beat and fully play this game without the fear of it pausing and not loading between games, do you think you guys could fix this before the treasure hunt is over?

Dreadjaws
12-10-2010, 03:10 PM
Having the same problem with a 188k score, Windows xp sp3 with admin rights, droplitz has a firewall exception.

That's what I have too and I haven't had a problem with the game. Perhaps it's an Antivirus software problem?

Urd
12-10-2010, 03:42 PM
That's what I have too and I haven't had a problem with the game. Perhaps it's an Antivirus software problem?

Same problem even with AV and firewall disabled and DMZed on router.

TubeSockWarrior
12-10-2010, 06:40 PM
Maybe the problem isn't with the menu hanging, maybe the "continue" button simply doesn't appear! Pay attention to the spot where it appears when you go to start a new game. See how it takes a second or two to appear? Well after your game is over and you click the go back to main menu button give the game a few seconds and click the spot you normally would have to. I just did and returned to menu no problem! I'd test it again, but I'm not taking any chances until after the treasure hunt event is over.

serieus1
12-10-2010, 08:45 PM
I don't think you click continue when you go back to the main menu.

step_ladder
12-11-2010, 03:42 AM
Indeed, it looks similar enough to the initial loading screen such that the most reasonable guess is no button, straight to menu.

Also, bloody typical that it breaks the treasure hunt objective D:

step_ladder
12-11-2010, 04:58 AM
THIS

http://forums.steampowered.com/forums/showthread.php?t=1644117

TubeSockWarrior
12-11-2010, 06:01 PM
See? That's what I said, the button IS invisible! :D

nholmes
12-13-2010, 03:57 AM
There appears to be two things that are causing this, under different circumstances.

The first is a setting in the catalyst control center that prevents some elements in the game from rendering correctly. Please see this post: http://forums.steampowered.com/forums/showpost.php?p=19364314&postcount=8

from this thread: http://forums.steampowered.com/forums/showthread.php?t=1643137

Alternatively you might like to try this work around: http://forums.steampowered.com/forums/showthread.php?t=1644117

The other appears to be a problem caused by certain firewall software. The game is getting blocked from posting to the leaderboards and so seems to get stuck. Simply add cascade.exe to your list of exceptions in your firewall. For more details see here: http://forums.steampowered.com/forums/showthread.php?t=1644117

and here (specifically if you are using zone alarm): http://forums.steampowered.com/forums/showthread.php?t=974132

serieus1
12-14-2010, 12:47 AM
nholmes:
You're on my list of great devs, I thoroughly enjoy devs who support their fans rather than just see them as consumers. Thanks for the help on this issue, I will see if one of the work arounds resolves my problem.

Thanks again and make more good puzzle games such as this.