PDA

View Full Version : Sacred 2 Win 7 crashes


Tribly0
10-03-2010, 03:33 AM
So I just bought Sacred 2 and I am having problems with stability. The game crashes usually during the opening cinematic or the opening cut scene for you character. I've tried running as admin and running in vista XP SP3 and still have crashes. Can anyone suggest any other options? Much appreciated.

clok1966
10-08-2010, 01:25 PM
same here, wow.. either this game is buggy as heck or somthing is very wrong with my machine... 100+ games on steam, this is the firt one to give me fits.. I cant keep it running ofr more thena minute or two.. When it runs for a couple minutes i get HORRIBLE slowdown, it clears up, but then happens again. FRUSTRATION! looks like a pretty cool game... if i could play it


The other threads about using compatibility mode workd for me too. Run as admin and in XP SP3 compatability fixed min it appears.

twister03
10-10-2010, 10:07 AM
To fix that slowdown go to:
C:\Program Files (x86)\Steam\steamapps\common\sacred 2\system\

The (x86) is only for 64 bit users!

Right click Sacred2.exe and properties. Click the compatibility tab and put it in XP SP3 compatibility mode. Also check the boxes to disable visual themes and disable desktop composition. Check the box to run as admin also. Apply > OK.

Now in the same folder right click s2gs file and set that to run as admin and XP SP3 compatibility. You don't need to worry about anything else with this file. Apply > OK.

This is how I fixed my game on Win7 x64. It also fixes it for x32 though.

One problem I did have was the game crashed when I changed my graphic settings. I have an Intel Q6600 @ 3.0GHz, Nvidia GTX470, and 4GB RAM. The crashing has nothing to do with my system setup at all. What I did to fix this was set the game in window mode, then I was able to change the settings without crashing. After the settings were all maxed I put it back into full screen mode and the game works as well as it would on any other OS that is supported.

Hope this helps.

Freakster2k4
10-16-2010, 11:51 AM
Well I got no issues with my game, after the game was installed I just installed the latest physx driver from nvidia ran the game, and presto it worked.. Didn't have to edit anything nor make shortcuts... It just worked.

Sehnsucht
10-19-2010, 05:40 PM
I am trying so very hard to like this game, but every time I do - it crashes. In some funky way, this game has done it all. It's locked up completely, and then on rare occasions - it unfreezes and resumes like nothing happened.

What it likes to do the most, is to crash right after I've spent 10 minutes killing a hard boss.

Sometimes it'll crap in my face by crashing right before I reach a rez stone.

Or it'll crash when I save and exit - or it'll simply fade to black and exit at the MP screen. Or it'll start lagging for no apparent reason (my system is capable of handling the game on elite gfx and everything else at max).

Or..

I need say no more.

It's a damn shame that such a gem is bug-ridden to the point where you need insect spray just to look at the desktop icon.

I'm considering partitioning my hdd and installing Vista JUST to be able to play this game successfully.

Hell, I already bought the game twice. Might as well go full circle.

Sehnsucht
11-01-2010, 09:54 PM
Concerning my previous post and installing Vista - I did. Twice.

First had to make a small partition just for Sacred because I recently acquired an extra external drive and so I decided to toss out 2 of my internal drives to clear some space in the cabinet. Having done that, I installed Vista 64 Ultimate on it, and the bare minimum to get it working with multimedia apps. Only extra I installed was the cpu and gpu monitor apps since they're both heavily OC'ed (all temps are more than fine, but I like to be sure).

On to the end result: Pretty much no difference whatsoever. Upon force-disabling PhysX in the Nvidia control panel and lowering the rendering setting to high instead of highest (everything else seems to work fine at max) I got it running alright, but still crashing fairly often.

So I thought perhaps the issue is the 64-bit OS. So I formatted the partition and installed Vista 32 Home Premium, again with only the bare minimum needed (and I skipped some more optional stuff just to eliminate any and all possible causes).

Result was the exact same. I reset the gfx oc as well, still no difference.

I have tried pretty much everything but I did find out that much of the reason it crashes might have something to do with virtual memory being utilized incorrectly or possibly a substantial memory leak. So I found an executable which effectively raises / removes the virtual memory limit on certain "older" games. I went back to playing it in Win 7 and depending on which class I play, it seems to crash less. Don't have the link in my head or browser, but search for "Sacred 2 virtual memory leak / problem" and you should find it quite easily.

ChaosCoyote
11-03-2010, 10:35 AM
I've also had trouble with Sacred 2 on Win 7. I've tried running as Admin, and running in compatible mode. I've tried installing the latest PhysX drivers.

The problem I have is that it shuts my whole laptop down. Completely off. I can play for about 5 minutes or so. It looks good during that time, but then my laptop shuts off.

I have a Toshiba X205-SLi5, running Windows 7 Ultimate (32-bit).
Intel Core2 Duo, T8300 @ 2.40 GHz
RAM: 4G (3G usable)
NVIDIA GeForce 8600M GT

I'm open to any suggestions, and will post more info if needed.

Menshai
11-20-2010, 04:12 AM
Hi all,
I don't know if this will help or not, but here goes...

Sadly, the fact that Steam automatically updates games to the latest available patch is a detrement in this case. While Sacred 2 ran perfectly on Windows 7 up to version 2.40, the 2.43 patch (which when downloaded manually only amounts to a few Mb I believe) ruins Sacred 2 in Windows 7 and I believe causes some issues in Vista as well. The game developers offical response has always been 'we don't support windows 7', which seems ridiculous, given that everything was working fine up to the 2.40 version. Mysteriously though, if you buy the add-on pack, the patch for that then fixes everything...
All that said, normally setting the game to run in Windows XP SP3 compatibility mode should fix the problem :/ It seems some of you have tried that but with no success... Here is a link to the official thread on the Sacred 2 forums...
http://forum.sacred2.com/showthread.php?t=65482
I hope it is of some use... There are a myriad of fixes that people have attempted; perhaps working through them might yield some success.

Edit: On the first post of that thread, there is a link to further fixes. Usefully, that link does not work anymore! :P After searching through the thread, I found an updated link, which I post below...
http://forum.sacred2.com/showpost.php?p=631951&postcount=70

And here's another link to more links for fixes. Like I said, people have tried a lot of different things :p
http://forum.sacred2.com/showpost.php?p=650663&postcount=2

EloquentRaven
12-01-2010, 12:46 PM
The game is just like that unfourtunatley. ive owned it for over a year and its no longetr being patched and was never supported for windows 7 64bit.

regi123
12-10-2010, 05:59 AM
I bought sacred 2 a few days ago. I have W7 64bit and had nothing but trouble trying to run the game. I had constant crashes, when I entered a new area that required a load it would turn the screen black but with sound and UI still there. I tried all the compatible exe methods and various other things I found around the web. Nothing worked. The game was unplayable.

I tried one last thing, it is mentioned above, I uninstalled anything related to physx drivers and downloaded the latest physx drivers. Installed them and guess what, game runs great. I still get that silly invisible map bug now and then that requires a re start to fix but as yet not a single crash or black screen.

Try it.

verkinix
03-21-2011, 10:28 PM
I had issues getting S2 to run, but here are things I tried. Putting -skipopenal -nocpubinding in the target lines of the shortcut helped the game to actually load. Updating PhysX to the latest of nvidia helped the game to not crash. Turning off PhysX in options once in the game helped the game to run smoothly. Compatibility mode XP SP2 is a necessity. Run in Admin mode if things aren't working.

I now have a game that runs smoothly, seems stable (a few minor glitches that refresh with alt-tab), and is generally fun. I hope those "fixes" help others.

I should probably add my system specs: Win 7 64bit, Xfire ATI 2x5770, i5 2.8Ghz, 8GB RAM, Latest drivers as of 3/1/11.

JK_DC
04-27-2011, 02:13 PM
2.43 will crash unless you set sacred2.exe to XP compatibility. The expansion had a W7 patch after release. It still crashed for me and I found out it is the AA in my case so I use 2xAA and it is okay for well over an hour. I used to crash in 5-10 minutes.

Edit: Wasn't the AA but the PhysX and the fact Sacred 2 crashes when it uses 1.5GB of RAM. I turned down the memory size allocations and can run it with the elite textures without crashing. Nice. I also modded the camera for a closer view of the action, installed the community patch and now it is enjoyable. I may try reinstalling PhysX to try to get it working. It appears to be a memory leak when PhysX is enabled.

Trillian08
05-05-2011, 08:39 AM
I'm working on fixing my game crashes too. Could you explain how to allocate less memory to the program, if that's really the issue?

Runkelkrug
12-21-2011, 08:07 AM
The steam version is installing the AGEIA Version of PhysX. The release of the game was before Nvidia bought Ageia. Installing nvidias physx drivers will fix some problems

playthegame
12-21-2011, 11:44 AM
These 2 things fixed the crashes to me (on Win7 64bit):

-FIRST THING-
source: http://www.mokonamodoki.com/sacred-2-on-windows-7
1.Create a shortcut to the Sacred 2 executable. You’ll find it in the game directory, in another directory called ‘system’. For me, it is: D:\Games\Steam\SteamApps\Common\Sacred 2\System\Sacred2.exe
2.Put the shortcut on your desktop, or somewhere handy.
3.Right click the shortcut and select properties
4.Click the Shortcut tab
5.In the Target field, you need to add the following: -skipopenal -nocpubinding. The contents of my Target field look like this: "D:\Games\Steam\SteamApps\common\sacred 2\system\sacred2.exe" -skipopenal -nocpubinding
6.Click Apply and Click OK.
7.Double click the shortcut and play Sacred 2.

-SECOND THING-
source: http://forum.sacred2.com/showpost.php?p=612938&postcount=1
For those with Patch 2.43 crashes using Windows 7
If you are experiencing crashing/stuttering using the 2.43 patch on Windows 7 can you please try the following:

Right click the Sacred 2 shortcut on your desktop and click 'properties'. In the windows that opens click the 'compatability' tab and check the 'run this program in compatibility for' box, selecting Windows XP(service pack 3) from the drop down menu. Also check the 'run this program as an administrator' box. Click apply/ok and then run the game, this should stop the crashing/stuttering.

Runkelkrug
12-21-2011, 02:03 PM
EU Version server login (http://darkmatters.org/forums/index.php?/topic/9533-how-to-log-into-sacred-2-eu-servers-with-steam/)
just found that, but didn't tried it. Maybe that will fix the server problems for some people

Specious71
12-22-2011, 12:36 PM
Got 3 copies of this game for 3 of my PCs - uninstalled physics and installed the latest version - did NOT work for my machines BUT - after changing to run in compatibility mode for SP3 XP - it works fine on all 3 machines.

-GS-
12-25-2011, 09:59 AM
after changing to run in compatibility mode for SP3 XP - it works fine on all 3 machines.

I tried compatibility mode for SP3 XP to no avail. Then I tried SP2 mode and that seems to have solved all of my problems. I have been playing 30+ minutes now: without the SP2 compatibility trick, the game would quit to the desktop (no crashes, no freezes, no error messages - simply quit) in less than one minute. I didn't even have to update/delete/reinstall my drivers: just set "sacred2.exe" to SP2 compatibility mode.
System: i950 3GHz, 6GB RAM, GTX470 x2 (SLI), Win7 64-bit.

AngryNerd br
01-01-2012, 12:57 PM
worked for me thanks

Sirin
02-02-2012, 04:44 PM
After hours of trying different solutions, the game still does not work for me.
I'm trying to play on my vaio laptop which uses a Geforce GT 330M.
I have tried:
XP SP2 Mode,
XP SP3 Mode,
skipopenal and nocpubinding as a start parameter,
deinstalling and reinstalling the physx and openal-drivers,
windowed mode,
renaming LaptopGaming_vista.dll and xp.dll,
and so on...
I'm really in despair. 3 friends of mine own the game too and play it on win7 without any crashes. This is just so unfair.