PDA

View Full Version : Client Timed Out


aktor
10-17-2010, 07:10 PM
I keep getting a client timed out disconnect error while playing the last few days. Haven't ever seen it before. I've usually been playing for 15 minutes or so when it happens. Any ideas? Thanks!

iNDYCZ
10-18-2010, 06:55 AM
Me too and if i try retry command, i see only "steam validation rejected" error.

MeetYourMaker
10-21-2010, 04:07 PM
Ok, before I start I would like to say that THIS WORKED FOR ME, it doesnt mean it will work for you with this specific problem but hey, its not like youve got anything else to try have you?

Another thing i want you all to understand is that STEP 1 and STEP 2 are only there because this is EXACTLY what I did before STEP 3 without testing until the end.

I honestly dont believe that step 1 or step 2 contribute towards the solution, but as I dont know as I havnt tested them, I recommend you simply do all 4. (I believe that step 3 followed by step 4 is the solution).

-----------------------------------------------------------------

STEP 1

LOG OUT of steam (NOTE - THIS IS NOT THE SAME AS CLOSING AND THEN RELAUNCHING STEAM)

Open the steam window,
left click steam,
click settings.
Go to the account tab,
click log in as another user,
log back into steam with your username and password.

-----------------------------------------------------------------

STEP 2

Go into My Computer, and browse to your 'Steam' folder (where ever you installed steam to),
go into the Steam folder by double clicking it,
look for a file in there called 'clientregistry.blob',
r-click it and delete it.

-----------------------------------------------------------------

STEP 3 (VISTA and above)

In your STEAM folder, find the file called steam. (its an application, or the people who know what they are doing its your steam exe) ....
R-click it and go to properties,
click the compatibility tab,
check the box that says 'run as an administrator' and apply it.
At this point, you may get a message telling you that it is not reccomended that you run steam in compatibility mode, ignore this and do it anyways, I think you have to click cancel to do this, or somthing like that).

Now, in your steam folder is another folder called 'SteamApps' ...
go into Steam Apps,
now you should see your steam account name (most likely your email address),
go into this folder and you should see a folder called 'team fortress 2, go into it.
You should see an application called hl2.
R-click this and do the same thing (go to properties, then the compatibility tab) .......
check the box that says 'run this program as an administrator.
Appy it.

-----------------------------------------------------------------

STEP 4

Now launch Steam and it will update.

IMPORTANT ...

When you get back into steam click Steam > Settings > Downloads + Cloud.
Set your connection speed to whatever connection speed you have (or close)
for 'download region' select your region or the region that is the closest to you.

Now test and good luck.

-----------------------------------------------------------------

If this works for you then \o/ HURAAAY! If not then Im srry but at least you tried.

PLS PLS REPORT WHAT HAPPENS FOR YOU PERSONALLY BACK HERE, FAIL OR SUCCESS.

Good luck guys and I have my fingers crossed for each and every one of you.

Yours, trying to help,

MeetYourMaker.

aktor
10-23-2010, 08:34 PM
Thanks man I'll give it a shot.

Mr_Newpants
10-27-2010, 01:01 AM
Just turn off your steam cloud from options/multiplayer/advanced no fancy playing around with client registry or anything like that.
Deleting the client registry file only gives you a temporary fix (for me, not even that)
Turning off the syncing with steam cloud fixed my problem straight away.
(Going offline mode in the friends list will never help, that's just pointless).

I doubt anyone ever uses steam cloud anyway.

Cheers!

SayIDo
12-04-2010, 01:40 PM
Thanks man =)

I tested '3.'

The only thing i did was putting steam.exe in 'Run as administrator mode' and i havent been disconnected since =)

GDavidF
12-31-2010, 10:51 PM
Deleted clentregistry.blob AND set Steam.exe to run as admin

Fixed my TF2 client timed out disconnects and allowed ingame shop to work correctly.

douge
01-22-2011, 12:49 PM
Okay, I feel like an idiot noob, but I'm on a mac and for the life of me, can't find ANY options or preferences menus for Steam. In TF2, I get the client timed out error every 20 seconds of play and it boots me. I'm running OS10.6.6 on a brand new macpro laptop on a 20MPS network and don't seem to be having lag or other connectivity issues. I get an error msg every time I start TF2 saying, "Steam was unable to sync your files for TF2 with the Steam cloud" so I think that's probably the problem. Any mac users out there?

Kytis
03-27-2011, 06:14 PM
I have fighted this problem for over a year.
Tried EVERYTHING that has been suggested on the forum.
Then one day when I tried to do some fixing again, I founded an solution.

Just change your directx level to 9.
In launch options, add -dxlevel 95 and start game once, after that you can take it off. And if you already have dxlevel 9, set it to something else.

This tweak removed my client timed out-error and 2 of my friends whom had the same problem, did it too and their problem disappeared too.