PDA

View Full Version : Titan Quest and Titan Quest: Immortal Throne Start up Issues (Please Make Sticky)


Noxgene
10-30-2010, 10:17 AM
Recently I'v seen some posts running around the Issue of whenever you press "Play" for either TQ or TQ:IT that game shows a Black Screen, then starts to flicker back and forth.

You can't do anything but press Alt+Ctrl+Del and End Task, and this isnt easy either, because the game just flickers between windows making it almost impossible to press the End Task Button.

I'v run this Game no problem before, and my play time even states 4 hours play while I used the Mod by SoulSeeker.

This system I'v been running it on:

OS Version: Microsoft® Windows Vista™ Home Premium , Service Pack 2, 32 bit
Processor: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz, x64 Family 6 Model 15 Stepping 11
Processor Count: 4
RAM: 3070 Mb
Graphics Card: NVIDIA GeForce 8600 GT , 512 Mb
Motherboard: ASUSTeK Computer INC., Benicia, 1.01, MS1C7CR81905648

Before I upgraded the drives for my graphic's card, I had no problem playing this game, that I am sure of, everything is up to date on my PC, what I don't get is why this is an Issue.

If you have anything happening to you around this Issue, please post it here, I find this problem very annoying when I know the game should and can just run no problem on a system and configuration like this, and I would hope this helps any people in the future who buy this Amazing Game.

Noxgene
10-30-2010, 10:40 AM
There have also been some people with Graphic's card Issues.

I would say first check out if you can Run the Game;

http://cyri.systemrequirementslab.com/CYRI/

and Secondly I'v found post's suggesting that some Systems are unable to run the game at all, and this means you'v wasted your money, sorry.

I Can't Run Titan Quest Because Couldn't Initialize Graphics Engine (http://www.titanquest.net/tq-forum/threads/22633-I-Can-t-Run-Titan-Quest-Because-Couldn-t-Initialize-Graphics-Engine)