PDA

View Full Version : ATI video card settings for BGE on Win 7 x64


haste
11-21-2010, 05:52 AM
Using 10.10 Catalyst with the 10.10e hotfix applied. This game runs flawlessly for me other than a slight aspect ratio issue(known).

First you will need to apply this registry setting:

Something that improves the game for widescreen users is to add this registrykey:
key = "HKEY_CURRENT_USER\Software\Ubisoft\Beyond Good & Evil\SettingsApplication.INI\Basic video\NoBands", type = DWORD, value = 1

Then go to the catalyst control center and change these settings:

You will want to enable GPU Scaling(i am using widescreen lcd @ 1920x1080). I am not sure how this setting will affect 16:9 or 4:3 displays...

GPU Scaling (http://haste.4saken.org/bge_ati/gpu_scaling.jpg)

Then go to 3d settings and change them around to look like this:

3d Setting 1 (http://haste.4saken.org/bge_ati/3dsetting1.jpg)

3d Setting 2 (http://haste.4saken.org/bge_ati/3dsetting2.jpg)

You will want your Beyond Good & Evil settings application to look similar to this (resolution will be dependent on users computer/monitor specs).

BG&E Setting 1 (http://haste.4saken.org/bge_ati/bge_setting.jpg)

BG&E Setting 2 (http://haste.4saken.org/bge_ati/bge_setting2.jpg)

I also disable the steam overlay, not sure if it makes a difference or not, but it cant hurt!

Unfortunately I can't post images in the post but I have a folder on my webspace of gameplay with these settings:

Pics of BG&E (http://haste.4saken.org/bge_ati/game_ss/)

evuurrll
12-09-2010, 03:33 AM
Thanks for posting that. I had given up on trying to get this to run in Win7 but these settings work for me too!

I tried loads of stuff suggested in the other threads but this definately works for me.

Windows 7 x64 Ultimate, ATI 4850, 4gig ram, Core2Duo E8400

TagoWill
12-11-2010, 11:47 AM
Hi,

I can not get the game running on mine. The sound is always more advanced than the game. and the game very slow in some parts. :o

I have Windows 7 x64 , ATI mobility Radeon HD 2400 , 3GB ram.

What can I do?

TheDark12
12-17-2010, 07:28 AM
@TagoWill

The sound issue is a problem with some multi core systems where the sound updates faster than the game. To fix it you need to:

1. Ctrl+Alt+Del and go to the Processes tab.

2. Right-click on BGE.exe and select 'Set Affinity'

3. De-select cores until only one CPU is left selected.

Good luck and have fun!

TagoWill
12-21-2010, 06:09 AM
I will try. Thanks:D

TagoWill
12-22-2010, 05:57 AM
The game is still slow!:eek:
What can I do more?
I already have done the configuration that are on this topic and nothing! :(

haste
12-23-2010, 09:24 AM
these settings are for fairly high end systems. im running an ati 5870.

try changing the Anti-aliasing and Anisotropic filtering to low or default levels and see if that helps with performance.

Here are 2 pictures showing what I mean:


3d setting 3 (http://haste.4saken.org/bge_ati/3dsetting3.jpg)

3d Setting 4 (http://haste.4saken.org/bge_ati/3dsetting4.jpg)

Moe45673
12-29-2010, 07:47 PM
Thanks for this thread. I've wanted this game for a while but wasn't sure if I could use it with Win7x64. I'm bookmarking this thread and am purchasing the game soon (wait for a possible daily deal)

*edit* Nvmd :) I just found out they're releasing it on the Xbox Live Arcade. I think I'll enjoy it on that platform, assuming that the port (with slightly tweaked graphics and soundtrack) is glitch free. It was a real headscratcher as to why they never made this backwards compatible.... now I see.