PDA

View Full Version : The Complete Guide to Fixing KoToR for Windows 7


trevorx3
11-29-2010, 03:56 PM
Three separate fixes have been popularly told and none of them worked individually for me so I decided to put them all in one thread.

The following fixes got the game to work on my Windows 7 Professional 64-bit laptop with an ATI Mobility Radeon HD 5450 graphics card. (ATI is sometimes said to cause problems with this game)

First, disable In-Game Steam Overlay for KoToR. This can be done by heading to your Steam Library and right clicking KoToR and selecting Properties.

Second, navigate in Windows Explorer program files or program files 86 (this depends if you're running 32-bit or 64-bit windows) > steam > steamapps > common > swkotor > and then run swconfig.exe which should be found in the swkotor folder.

Third, after this applet is up, uncheck the "Use Hardware Mouse" and check the "Disable Movies" (this just disables the intro movies, to my knowledge).

Also, if you're still having problems I've heard some people suggest running it in windowed mode.

Mooman
11-29-2010, 07:57 PM
Excellent, thank you very much for this information, very helpfull indeed. it has fixed my problem now, i am useing a ATI HD 5770, windows 7 ultimate 64bit, and the latest drivers at the moment. after following these steps it runs like a charm :D much appriciated thank you :)

trevorx3
11-29-2010, 10:22 PM
No worries.

Don't be afraid to give me a rep if I helped you out, I sure need it. haha

Good luck guys, I was so frustrated when KoToR wouldn't run at first.

hermitmaster
11-30-2010, 09:18 AM
Thanks! Fixed it for me too.

trevorx3
11-30-2010, 10:30 AM
You're welcome!

If this thread has helped anyone else, please post!

Lurkers (people who read threads without posting), that means you! =P

Neon Kitten
11-30-2010, 11:33 AM
Nice comprehensive but easy guide to let people get this game working in 60 seconds rather than the several hours it took me when I bought it last time it was on sale :)

I had to re-find tips on running the game after upgrading to a new 6870 card, and your post got me up and running instantly.

+rep for you! :)

trevorx3
11-30-2010, 12:09 PM
Thanks!

I also spent quite a lot of time browsing around looking for ways to get this game to work and didn't want anyone else to have to go through those inconveniences.

Nomolo2k8
11-30-2010, 01:03 PM
Nice post. Directions were easy to understand. I hate to reveal my ignorance with this question though, but how do I run this in windowed mode? Is it in the "properties" section?

So far, nothing has helped with my problem. I can click the application from the directory, or click play from Steam library, and I get the "Star Wars Knights of the Old Republic has stopped working" dialogue box. I describe what I've tried to do to fix it in "What the heck happened?"

Thanks

cagoBHuK
11-30-2010, 01:40 PM
Hm thx for the tip, but it helped me only when i started the game first. On my 2nd try to launch it, it automatically minimize itself. -.-

lzb2811
11-30-2010, 07:01 PM
It doesn't work for me.

1)I've tried what the OP suggest

2)window mode

3)download a new mss32.dll

4)download atioglxx.dll

5)compatible mode

nothing works. It simply crash right after I start the game, no logo no music, nothing. Waste my 2 pounds, should have spend them in Macdonald

wrothmor
11-30-2010, 09:00 PM
Do you know anything about the mouse not working propperly(cursoe there but wont click?)

trevorx3
11-30-2010, 09:06 PM
I too have been unable to find the setting to run this game in windowed mode although I've seen more than one person suggest it.

Difficult.

Wrothmor, that problem was solved (at least it solved my problem) by turning the hardware mouse off which is detailed in the first post.

In addition, other people have suggested making sure all of your graphics card drivers are up to date. If that combined with all the above doesn't work, I'm stumped.

Alex2000
11-30-2010, 09:40 PM
This worked great for me! Thanks a lot.

What I am running:

Windows 7 - 64 bit
Core i7 860
ATI 5970


The only issue I had was the screen would go all black. the game would not hang, it would just go all black. But alt-tabing out, then clicking back into the game, fixed the issue, and I could carry on.

trevorx3
12-01-2010, 09:05 AM
Good to know another person was able to play!

LATTEH
12-01-2010, 11:59 AM
Nice fix mate!

i hope this works for some people! :D

McKampela
12-02-2010, 03:46 AM
I don't want to be a lurker so I say this made me remember what to do to get KOTOR working.

Oh, and it works.

maul_inc01
12-02-2010, 05:21 AM
Great to hear that it works for most people, but can somebody confirm that disabling movies, only disables startup logos etc. and NOT the ingame movies?

LATTEH
12-02-2010, 08:25 AM
Great to hear that it works for most people, but can somebody confirm that disabling movies, only disables startup logos etc. and NOT the ingame movies?

from what i know it disables both. ya i know it sucks

AllenSugar
12-02-2010, 07:09 PM
how do you run the game windowed?

Askio
12-03-2010, 06:04 PM
I only had to do the first one for it to work on my laptop. Still can't figure why people need to disable movies.

Zephkiel
12-03-2010, 07:00 PM
how do you run the game windowed?

If it's the same as the CD-version, open up your swkotor.ini file, go to full-screen and change it to 0.

I've also got it running fine showing movies. Heard bumping up your settings higher makes it run smoother.

FadingCeiling
12-04-2010, 07:41 AM
Running kotor fine with just the executable set to Win XP SP3 compatibility mode. Hardware mouse is on and the mouse cursor is accurate. Movies aren't disabled and they work perfectly.

Win 7 64bit Prof updated
ATI Radeon HD 5770 10.11 + CCC

wembleyford
12-05-2010, 06:23 AM
Had all sorts of problems with this - mostly movies not playing, but others also. Sometimes it works, sometimes it didn't.

I have found a fix that makes my copy workable though - and appears to be good.

Once launched, immediately alt-tab back to the desktop and get the taskmanager running. Change the affinity of the swkotor.exe process so that it only uses a single CPU core, rather than automatic.

Once done so, mine plays movies rock-solidly, and doesn't crash.

Haven't found a way to make this change persistent as yet - a command lijne using 'START' will do it, but not from a .bat script. But still - it's a start. This certainly works for me.

happypaladin
12-06-2010, 06:09 PM
This fix didn't work for me.

My personal issue is that when I run it I get about a second or two of 'thinking' black screen and then windows pops up with "the program has stopped working"

I've:
disabled movies,
unchecked "use hardware mouse",
gone into the .ini file and set fullscreen to =0,
gone into the game's steam properties and unchecked "Enable Steam community In-Game" (which I assume is the same thing as the "In-Game Steam Overlay" that the OP was talking about)
and I've downloaded the file atioglxx.dll and placed it in the steam/steamapps/common/swkotor folder.

I'm running an Asus F3Eseries with:
Windows 7 Ultimate,
Intel(R) Core(TM) Duo CPU T7500 @ 2.20GHz 2.20GHz
2GB of RAM (instead of the standard 1GB)
32-bit OS
aaaaaaand apparenty no graphics card. Although I can manage to play games like Blood Bowl, Star Wars Battlefront, Torchlight and Oblivion so I'm guessing that's not the issue. (guessing does tend to get me into trouble though...)

Can someone help me sort this out? I'd hate to think that I paid steam $10AU for a program that doesn't work.

Nomolo2k8
12-07-2010, 10:34 AM
happypaladin,
"the program has stopped working," "windows is checking for a solution to this problem," right? Is that the message you're getting?

wembleyford
12-08-2010, 03:57 PM
This fix didn't work for me.
I'm running an Asus F3Eseries with:
Intel(R) Core(TM) Duo CPU T7500 @ 2.20GHz 2.20GHz

Can someone help me sort this out? I'd hate to think that I paid steam $10AU for a program that doesn't work.

Can you try changing the affinity of the swkotor.exe process after it's started? Try starting the s/w from a cmd prompt in the steamapps folder with

start swkotor.exe /affinity 0

and see if it helps. It certainly fixed my issues with it.

Diesel757
12-09-2010, 02:07 PM
I too have been unable to find the setting to run this game in windowed mode although I've seen more than one person suggest it.

Difficult.

Wrothmor, that problem was solved (at least it solved my problem) by turning the hardware mouse off which is detailed in the first post.

In addition, other people have suggested making sure all of your graphics card drivers are up to date. If that combined with all the above doesn't work, I'm stumped.
How do you turn it off if you can't click to open the options menu? I'm having the same issue...making to the load game menu, but mouse will not click.

Diesel757
12-09-2010, 03:46 PM
actually, setting the affinity to 0 and 1 worked for me...running SP2 comp mode with movies on and maxed settings...so far so good also unchecked the steam overlay in properties as suggested.

Thanks OP for the thread and to wembly for the affinity advice.

perfect_general
12-10-2010, 05:24 PM
Thanks for the fix!

Lord Akela
12-23-2010, 05:31 AM
Sigh, nothing worked for me.

AthlonX2 5000+
Palit 9600GT Sonic DDR3 512MB
Kingston 2GB DDR800
Windows 7 64-bit.

- Windowed
- Running under compatibility mode for XP+SP2 or SP3
- Set affinity to just one CPU
- Disabled Steam overlay
- Ran as administrator

The game boots into the menu fine even before I did any of the above, but when I start loading New Game it just crashes (twice).

Hardware scan failed for video, "outdated drivers" LOL.

biker_gamer
12-23-2010, 06:33 PM
Like many people i also downloaded kotor during the holiday sale. My monitor is a sony hd tv, i tried widescreen patches and the bottom was still cut off so running it in windowed mode is the only thing that worked for me even after the hd patches got the correct resolution for my tv to show up.

to get to run in windowes mode you have to modify the swkotor.ini file, i found instructions on line.

Add AllowWindowedMode=1 to the Graphics section and set full screen setting to 0.

Hope this helps someone having similar problems.

NickUS
12-25-2010, 05:00 PM
very good post thanks a bunch

Xorq
12-26-2010, 06:05 AM
Disabling hardware mouse and disabling movies did it for me. Thank you ! :D

Wilcroft
12-26-2010, 04:43 PM
Here's another fix that some people might find helpful. I didn't want to disable the movies, and I had problems with disabling the hardware mouse (the mouse didn't line up with the screen icons) so I ran the swupdate application (steam/steamapps/common/swkotor/swupdate). After running, it said nothing was installed, but the game now runs fine.
I do have community disabled, but both movies and hardware mouse are still enabled. The game did not work before I did this.

LuckyGrenade
12-28-2010, 10:19 AM
Thanks for this! I can finally start playing :D.

ItsYourDaddy
12-28-2010, 10:35 AM
None of these work anyone help plz?

17th Knight
12-28-2010, 01:58 PM
Thanks for the excellent thread, fixed my game perfectly. Kudos!

Cube1701
12-29-2010, 07:29 AM
Unfortunately none of those methods work for me. The game won't even launch (the swkotor.exe is visible in task manager for a few seconds) - no blank screen or anything. It just asks me if I want to make changes to my computer (I've tried turning UAC off but it makes no difference) I click Yes and that box vanishes then...nothing.

My laptop has:
- Intel Core i5-430M 2.27GHz
- 4MB DDR3 RAM
- ATI Mobility Radeon HD 5470 512MB

Oddly, I tried the swupdate...I had an update to v1.03. It hasn't made any difference, though.

LLAndy
12-30-2010, 03:27 PM
worked for me with Vista.. Although I didn't have to disable the movies, just the steam interface (and I think they changed the wording on it now, it just says "enable steam community" or something like that on the properties screen). It was either that or the hardware mouse that made it work for me. It was crashing right after the first movie with the battle outside the ship.

petercrab5
12-30-2010, 05:13 PM
disabling steam overlay helped I think

Pensador
01-02-2011, 01:26 PM
I disabled the Steam overlay; it fixed mouse problems I was having. Thanks a lot!

ExUberance
01-05-2011, 05:16 PM
Fix is working for me too, even after re-enabling movies. The cutscenes, which are admittedly more plot-important, are still intact when you disable them, but seeing the movies is nice too, if you can get away with it.

Chaoticwhizz
01-05-2011, 07:23 PM
Is it only people with ATI cards having issues? I have Win 7 64 bit with icore 5 and Nvidia 460 and have no problems at all.

Count_D
01-06-2011, 03:17 AM
Me too. Win 7 32 bit GeForce 8600, no problembs at all.

Cube1701
01-06-2011, 03:32 AM
Is it only people with ATI cards having issues? I have Win 7 64 bit with icore 5 and Nvidia 460 and have no problems at all.

I've just added "ATI" to my Google search. Found a couple of possible fixes so I'll try them out and let people know if they work.

Edit:

Tried loads of stuff. Eventually I came across this which finally worked:

"In the swkotor.ini , change the settings to this:
FullScreen=0
Anti Aliasing=1

Then add the line....
AllowWindowedMode=1

Change the resolution to 1024x768 (for now)

I've experimented with the resolution, but no matter what I put it's always 800x600. Still, it works.

If you have to move this method, the window will load in the top left. If you alt-tab out then you will be able to maximise the window - you'll get the 800x600 image with a black fullscreen border. It's not ideal, but it's better than nothing.

CimaJackal
01-30-2011, 06:26 PM
Still doesn't work for me, the game doesn't even begin to start, it just makes the mouse cursor tell me it's loading then stops loading.

CimaJackal
01-30-2011, 06:36 PM
Unfortunately none of those methods work for me. The game won't even launch (the swkotor.exe is visible in task manager for a few seconds) - no blank screen or anything. It just asks me if I want to make changes to my computer (I've tried turning UAC off but it makes no difference) I click Yes and that box vanishes then...nothing.

My laptop has:
- Intel Core i5-430M 2.27GHz
- 4MB DDR3 RAM
- ATI Mobility Radeon HD 5470 512MB

Oddly, I tried the swupdate...I had an update to v1.03. It hasn't made any difference, though.

I have the same problem, I have an ATI too

CimaJackal
02-21-2011, 08:14 PM
I did all those 3 things and it still won't start.

bennsmith7
02-26-2011, 06:24 AM
i have brought swkotor at £5.99 and it crashes as soon as i run it i need help because i cannot use the properties on steam it has updates, languages,local files and general and i cannot use the set launch options because it says that these options are for advanced users only so i cant use windowed, turn off cinematics or the mouse and i used a can u run it engine so i am stumped.
using a dell inspiron mini 10 with windows 7 starter 32bit

kemj25
03-06-2011, 02:05 PM
I've tried everything so far and my game still wont even launch. I click to run the program and a notification will pop up saying that it'll start. Then it never starts...

CimaJackal
03-13-2011, 06:54 PM
Why can't they just fix this game for Windows 7

maghnusplus
03-15-2011, 09:50 PM
Why can't they just fix this game for Windows 7

Because it's a seven year old game that the developer now considers a legacy product. Not to mention the last patch was from at least four years ago if not much more.

Correction. You asked why can't they. I answered why they won't. My mistake.

CimaJackal
03-16-2011, 06:52 PM
Because it's a seven year old game that the developer now considers a legacy product. Not to mention the last patch was from at least four years ago if not much more.

Correction. You asked why can't they. I answered why they won't. My mistake.

Doom 2 is much older and it works just fine

billywask
03-19-2011, 08:13 PM
this helped to fix most of the problems, except after my first in-game melee battle my character always freezes up, and is never able to move. Please! help! any suggestions?

Cyonin
03-21-2011, 06:23 AM
I also have an issue whereby my FPS drops to around 1 and becomes unplayable. Seems to occur when changing the resolution to what is meant to be, widescreen. Smaller resolutions like 800x600 appear to work, but still its a tiny box and I dont wanna play it that way.

Anyone else have this issue? I have KOTOR II aswell, not from steam however and it has a similar problem.

Im on Windows 7.

Also where is this SWTOR.INI file to change it to windowed mode? Searched through the swtor files in steamapps but cant see it anywhere.

Cheers.

sootherz
04-03-2011, 04:39 AM
Thanks only needed the first suggestion and it started working.

Thanks heaps

Sweetz
04-04-2011, 12:20 AM
Why can't they just fix this game for Windows 7
Getting back up to speed on code that's been mothballed a long time is a much, MUCH harder task than one might expect. I say this as a programmer and having experience with trying to fix up a legacy product. My experience is with business software. I imagine with games, which often have rather lax internal documentation, it would be doubly difficult to go through the old code to make fixes.

The time and money they'd have to put into the game at this point would not be returned by the few trickle sales the game still gets. Besides you can run it on Win7, it just often takes a lot of troubleshooting.

Doom 2 is much older and it works just fine
Not really a valid comparison. If you're playing Doom 2 then you're either running it through DosBox DOS emulator, or you're playing something like ZDoom. Neither of those was written or maintained by id. Definitely not the same thing as expecting the original developer to patch an 8 year old game.

If Kotor was open source like id's old games then I'm sure the community would have all kinds of improvements for it. "Open source" isn't in Lucasarts vocabulary though. They don't even like to allow mods for their games because of how protective they are of the Star Wars IP. I'm quite certain that the existence of nude mods for Kotor would really chaff George's britches if he knew about them.

Kiddcade
04-06-2011, 07:35 AM
oopswrong tab

Chihuahua
04-16-2011, 04:32 PM
Thanks for this thread. It should be stickied. :D

najma_ez
05-26-2011, 01:01 AM
This worked for me THANKS!

Skorge
06-05-2011, 05:39 PM
Still nothing works. I believe that I deserve my money back if the game can't run. If it is offered on Steam, it should be able to run, no if ands or buts.

SaltSlasher
06-05-2011, 11:12 PM
Mine worked first try when using steam.

It would not work with an old disc from way back in the day.

However the graphics of the bodys and faces were kinda of bad, but thats probably cause I have been playing LA Noire which is the latest in graphical technology.

Even though it worked, I found this before I bought it, but I will do what you suggested to see if I get an increase in graphics!


Thanks anyways!

SaltSlasher
06-05-2011, 11:32 PM
Oh I figured out why the graphics suck, I put it at the highest resolution at 60fps.

Make sure you change your settings for best optical performance!
I personally wouldn't disable movies, unless absolutely necessary.

I don't know about refunds, I have downloaded tons of games that came out on XP and none has ever given me gruff.

I am running AMD 965BE, 8gb, ATI 5770, and Win 7 64bit!
Plus I tune ATI's CCC for optimal performance when playing games!

left2die
06-05-2011, 11:59 PM
I don't know if it's been posted in this thread (and if it has I apologise for posting it again) but there's a way to fix the issue over at the SW:TOR forums that doesn't involve disabling the movies.

Link: http://www.swtor.com/community/showthread.php?t=71929

Contents:

I can confirm this works for KOTOR II for Windows Vista 64-bit and Windows 7 64-bit, so it should definitely work for 32-bit and for KOTOR I.

Make sure your GPU drivers and DirectX are up to date. Microsoft.com has a DirectX dxwebsetup.exe that installs all SDK updates that you may be missing.

1) Pop in your KOTOR 1/2 disc
2) Open My Computer, open the drive that contains the disk
3) Right click "setup.exe", go to Properties. Go to Compatibility tab and make sure both "Run this program in compatibility mode for Windows XP Service Pack 3" and "Run as Administrator" are checked then hit OK.
4) Run setup.exe to install the game properly.
5) Install the latest patch for the game (use the Update utility from the launcher)
6) Open the installation directory
7) Rename the file "mss32.dll" (if you have it) to "mss32.BAK" to back it up
8) Download the Vista/7 Crash Fixing mss32.dll and place it here (link below)
9) Repeat step #3 for "swkotor.exe" or "swkotor2.exe"
10) (Optional) If the above still doesn't solve most of your problems, append the line "Disable Vertex Buffer Objects=1" without quotes at the end of your swtor.ini file.

The game should run flawlessly assuming you are keeping drivers up to date and not alt-tabbing and what not. In-game cinematics also don't take 2 minutes to load.

This should fix the game for 90% of people on Vista/7, but for the rest of you it will most likely be a specific hardware/software issue with your computer and not directly related to your choice of Vista/7 over XP.

Links:

MSS32.dll for both KOTOR I & II to fix Crashing in Vista and 7

This is one of the three sites I referenced when typing up my guide.
http://www.lucasforums.com/showthread.php?t=194296

Enjoy your 25% off KOTOR 1 on Vista and Windows 7! And BioWare, enjoy your increased sales now that people know how to get the game working on the new operating systems.


__________________________________________________ __________________________________________________ ___________

The above worked perfectly for me with Windows 7 64 bit. A few things though for the Steam version. Instead of popping in the disks, which you don't have, go: C-drive>program files*>Steam>steamapps>common>swkotor. Right click on swconfig instead of setup.exe.

I was not involved in creating this fix at all. I merely saw it on the TOR forums and thought it should also be posted here.

*(x86) if you have it.

legocrazy98
06-11-2011, 12:20 AM
Can anyone confirm this works for integrated nvidia gfx cards?
I want to get pc KOTOR, but dont want to waste money if it wont work.

nesmoth
06-18-2011, 05:16 PM
hey bro, thanks for the tips, been played kotor for a long time and the other when i installed back it wont work with windows 7, but with these changues run very good and without any bug.

Randommer
06-21-2011, 06:47 AM
http://i55.tinypic.com/a2l2h.jpg

I am having this issue with it, the lines are there constantly on Dantooine, I had similiar issues in the Undercity at Taris.

Tried the suggestions in the OP but they didn't work, anyone else got other ideas?

Intel Core i3 processor (2.26ghz)
Intel HD Graphics (up to 1275MB DVMT)
3GB RAM.

onlinesquid
07-01-2011, 03:09 PM
I have
ATI 6490 m HD
2nd gen i5
windows 7 64 bit

and it crashes once i start it up
any suggestions?

Starkiller59760
07-01-2011, 08:04 PM
I have tried everything this thread has suggested and nothing has worked. I double click on the game and it says "Prepairing to Launch" and then it seems to automatically cancel. I just bought it a few days ago, and i dont understand why it will not work. Anyone have any other suggestions or patches or something that will work to resolve this problem?

Not sure if this is what i need to put here but
My graphics Chipset is an ATI Radeon HD 5700 Series
Intel(R) Core(TM)i7-2600 CPU@3.40Ghz, 3401 Mhz

If there is any other information needed i have no idea where to find it, im not exactly the most computer savey person around.

Hugini
07-02-2011, 05:36 AM
Has anyone else had problems with character textures? My textures are just white.. Haven't experienced any other problems though! (Windows 7 64bit)

Flubious
07-02-2011, 06:46 PM
I'm running Windows 7 64 SP1 with an i7 860 and ATI 5770. After reading every page on this thread and trying every single method, I get nothing. Double click>crash. The end.

Anyone else with a similar processor and GPU get this to work?

Hypernite
07-03-2011, 07:48 AM
Nice post man rly works for me tyvm!.

Tigershot22
07-03-2011, 09:11 PM
I have tried everything this thread has suggested and nothing has worked. I double click on the game and it says "Prepairing to Launch" and then it seems to automatically cancel. I just bought it a few days ago, and i dont understand why it will not work. Anyone have any other suggestions or patches or something that will work to resolve this problem?

Not sure if this is what i need to put here but
My graphics Chipset is an ATI Radeon HD 5700 Series
Intel(R) Core(TM)i7-2600 CPU@3.40Ghz, 3401 Mhz

If there is any other information needed i have no idea where to find it, im not exactly the most computer savey person around.

^This....I'm running an ATI radeon HD 5870 mobile, I7, and Win7 64bit. I have the EXACT same problem and non of the suggestions on this thread have worked.

Phish285
07-04-2011, 12:39 PM
Works great, thanks

RedSVO
07-04-2011, 07:25 PM
Can anyone confirm this works for integrated nvidia gfx cards?
I want to get pc KOTOR, but dont want to waste money if it wont work.I have an HP notebook (dv7-1285dx) with integrated Nvidia GeForce 9600M GT graphics on the pci bus. PC KOTOR works fine on my system, and at the games highest resolution settings. Hope this helps.

greylady
07-05-2011, 03:26 PM
:D A million thanks for taking the time to create this post. I had about given up on KoToR and Steam in general.

I did all of the above, plus am running KoToR in compatibility mode (Windows 2000). Enabled v-sync as well.

The game is running beautifully now. It hasn't crashed or had any problems loading since this fix.

I have a 64 bit system and fairly new computer. KoToR is a blast and I'm so happy that I can know play without pulling out my hair.

Thanks again,

Greylady

maxbuu
07-05-2011, 07:57 PM
I tried everything but none worked...

I'm using a Netbook Asus 1201n eeePC
GPU: nvidia ION
CPU: Atom 1.8
Windows 7 32bits

Ceadderman
07-06-2011, 05:30 AM
Utterly useless trash. No offense meant of course, but...

1) No overlay feature in Properties. You mean "Steam Community in game"? Did that.

2) Found it right where you said.

3) Failed Unchecked Hardware Mouse and disabled movies.

End result? Same shiz different day. This game is totally and completely trash taking up room on my RAID array. I've played it before on my XP system and it had the same problems there that it does here. Unfortunately I cannot remember how in the hell to get it to work right.

Sadly this isn't it. :(

~Ceadder:cool:

captainqwark143
07-09-2011, 07:52 PM
how do you get it into window mode???

Talligan
07-10-2011, 12:26 PM
I fixed it!

I recently upgraded my computer to:
Windows 7 x64 from Vista x64
i5 2500
New motherboard
And kept my old Radeon 5770 (that upgrade is for next year)
All my drivers are new and up to date.

And KOTOR magically stopped working. It would crash right after the LucasArts and Bioware intro movies.

1) I followed the suggestions in the initial post of this thread and it would but up but a) I didn't want to lose my movies because this is my first play through and b) the gameplay was stuttery and c) the game was stretched across my screen

2) I enabled GPU scaling in AMD's CCC (Digital Flat Panel -> Properties). This brought it down to 1024x768 and looked square on my monitor (which is 1360x768)

3) Changed my .ini to Disable Vertex Buffer Objects=0 This actually went a long ways to reducing stuttering for some reason

4) I then went into the movies folder and moved biologo.bik, leclogo.bik and legal.bik to a folder I created called 'intro movies' The game now skips the intro movies and just boots straight into the menu-screen without crashing.

5) I re-enabled cutscenes in the config tool and it loads up perfectly! I have no idea if the game will crash next time I come to a story-cutscene but it works well so far :)

6) Oh! I disabled soft shadows. Don't know what it did but it also went a long ways towards stopping the stuttering as well.

Cheers!
Talligan

NebonRevurg
07-14-2011, 07:25 PM
It looks like there's a lot of confusion and voodoo tricks here muddying the waters, so I did a little investigation to see if I couldn't isolate the different issues that I've personally seen.

Edit: Please note that if these solutions work, all movies should be intact. My own experiments have shown the best results on the Issue 1 fix, such that I was able to fully use whatever settings in the INI I wanted.
To enable Windowed mode:
Make the following edits to the swkotor.ini file:
Under [Graphics Options]
add: AllowWindowedMode=1
change FullScreen=1 to FullScreen=0
I don't personally endorse Windowed mode, as it introduced some awkward GUI issues for me.


Issue 1: The three intro movies seem to hang and crash when starting up the game.

Issue 2: Seemingly random crashes to desktop and program hangs, especially during cutscene transitions.

Issue 3: Mouse pointer does not match with GUI elements

Issue 4: Movies can minimize the game out of full screen. (And possibly windowed mode, occasionally crashing.

Issue 5: Widescreen resolutions not supported

But fear not! I have solutions! Please keep in mind that these assume you are running from a clean default executable. If you need to reset to a default executable, there should be a "Check cache integrity" option in the steam launcher. Be sure to delete the contents of the override folder if you've done the Widescreen fixes.

Issue 1 and Issue 4:
Following up on a lead posted earlier in the thread, I realized that what we have is likely a common issue with older games, CPU Affinity issues with multicore CPUS. The workaround for this is to create a shortcut that forces the game to run on a single CPU.

The Workaround (you may need to be on an administrator account):
1. In Windows Explorer, navigate to your steam swkotor directory:
Windows 7 64 bit:
C:\Program Files (x86)\Steam\steamapps\common\swkotor
2. Right click on the swkotor.exe file and select "Send to: Desktop (create shortcut)"
3. Right click on the newly created swkotor.exe shortcut on the desktop and select "properties"
4. On the shortcut tab, add the following line to the beginning of the target box. Do not overwrite any existing text, simply add the text to the beginning of this box, then hit apply:
C:\Windows\System32\cmd.exe /C START "Star Wars - Knights of the Old Republic" /high /affinity 1
5. Run the game only using this shortcut. This should work for both widescreen and non-widescreen versions, as well as non-steam versions (Although you'll need to locate your install directory)
**note: This appears to work for any logical CPU, as long as it's a single Core set**

Issue 2 (and some of issue 4): Crashes to desktop appear to be related to two possible causes, one is a set of bad or outdated DLLs (the Steam version appears to fix this) or an issue with the compatibility mode, or bad data after attempting to revert the widescreen fixes.

Workarounds:
**Non-Steam versions only**
If running a non-steam version of KoToR, find the repaired Mss32.dll (usually called the kotor 2 vista fix).

**Both Steam and Non-steam versions**
If you're running a Steam version, or still getting crashes after applying the fix, and running the above "affinity fix", open a command prompt (Start menu and type cmd in the search box) and enter the following text: (this requires an administrator account)
REG.EXE ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers" /v "C:\Program Files (x86)\Steam\steamapps\common\swkotor\swkotor.exe" /t REG_SZ /d "WINXPSP2" /f
This forces Windows XP SP2 compatibility mode for all users.
If that doesn't work, try deleting all contents out of the override folder, undoing any widescreen fixes, and verifying the integrity of the cache through the steam launcher

Issue 3: This appears to be caused by issues with non-standard resolutions run in Windowed mode. Try running in full screen, with hardware mouse enabled, at a standard resolution or a properly patched widescreen resolution

Issue 4: If you're still getting movies randomly minimizing after running in single core affinity mode, try applying Windows XP SP2 compatibility mode, as outlined above in the workaround for issue 2.

Issue 5: This game is not designed with modern widescreen monitors in mind. Applying the widescreen fix linked to earlier in this thread may work to enable widescreen modes, but can introduce new issues, so apply it at your own risk.

real4xor
07-14-2011, 09:14 PM
A sidenote for issue 2.
Whenever the game "crashes" (but is still running) on video cutscenes like travelling to other planets, you can just click on the game in the taskbar to get it back in focus and alt+enter to windowed mode.
(needs AllowWindowedMode=1 under [Graphics Options] in the ini)

Somehow that fixed a few persistent crashes for me. The game or cutscene would just continue in windowed mode. The mouse has a few offset problems in windowed, but I only use it to get past those crashy parts. You can always get back on the fullscreen mode after you land or the cutscenes have ended.

This is ofcourse, when it throws you to desktop but the program is still reponsive (accoarding to windows taskmanager). If it`s not "running", Windows will just crash it tho. :/

Also had issues with the game starting in a black screen. The game would work, but nothing would be visible. Alt-tabbing out and back in seems to fix that.

I actually had fairly little trouble getting it to work. Only the video cutscenes were a bit messed up.

synx
07-15-2011, 05:51 PM
Most of the "fixes" listed are complete bull♥♥♥♥ (The OP is just as bad, claiming his "guide" is "complete"), and are just anecdotal crap posted by people who don't know what they're talking about. A great example of this would be the kids saying that KoTOR doesn't run properly on multi-core systems, or that you need to disable movies to get the game running. You don't need to set KoTOR to one core, it works just fine with modern CPUs; and you don't need to disable movies to fix crashing.

The list I've posted here (http://forums.steampowered.com/forums/showpost.php?p=23456929&postcount=4) fixes every crash caused by the game itself. I've been playing KoTOR for nearly seven years now, across many different setups; and haven't had ANY problems.

NebonRevurg
07-15-2011, 09:53 PM
One thing I have noticed recently with my previous suggestions is that when I change to a different window, my keyboard stops responding until I load any save. I'm still investigating this, but it's only mildly inconvenient for me.

I won't bother defending my multicore hypothesis, as there seems to be several potential causes here, but what I do know is that other fixes did not work for me personally when followed *exactly* as described (including ones posted and linked elsewhere), but setting my affinity did. Once again, it worked for me personally, but other users may have variable mileage.

If someone has a new suggestion, I'm more than happy to take a look. :)

Mantarrochen
07-16-2011, 01:16 PM
I just wanted to say thank you, Nebon, for your post was very helpful. +Rep from me!

neema_t
07-27-2011, 05:50 PM
Worked for me, thanks. I seem to have weird misaligned detection boxes for clicking stuff, but so far I haven't seen any situations where you need to be quick so whatever.

I'm running:
7 Ultimate 64bit
2.66gHz quad core Xeon nehalem
ATI 4870

harshvaria
07-27-2011, 09:03 PM
Thanks for all the info everyone. Changing the process affinity worked for me. I can now play this game with movies enabled.

I did the following two things:
Turned the steam in game community off
Whenever the game launches I alt+tab to task manager and set the process to only use one processor.

Others may observe different results but this one worked for me. Did not want to play the game with movies disabled.

TcoNL
07-30-2011, 05:19 AM
I now have the game crashing during quick-saving/loading (mainly/only loading?) It also flickers heavily during quick saving/loading.

W7 64 bit
Quad core.
Running with C:\Windows\System32\cmd.exe /C START "Star Wars - Knights of the Old Republic" /high /affinity 1 D:\Steam\steamapps\common\swkotor\swkotor.exe.
Enabled Hardware Mouse on
Disblabed Movies off

Game plays fine, movies play in very small box but still play fine.

What can be the cause of that?

edit; also succesfully running 1920X1200 now with widesceenmod and HUD.

melisgod
08-03-2011, 09:35 AM
Hm thx for the tip, but it helped me only when i started the game first. On my 2nd try to launch it, it automatically minimize itself. -.-

well i only have the minimizing. and i cant figure how to run the windowed mode. anyone help me please? or give me the crack for the windowed mode?

TcoNL
08-03-2011, 10:45 AM
Crashing not happening to often but the flickering is. Any one know what causes that?

zmally
08-03-2011, 05:25 PM
I think it's the screen refresh rate. Try using a different resolution in game, or maybe windowed mode if possible?

melisgod
08-03-2011, 10:40 PM
how do you get into windwoed mode? i am using the disk version fully updated

thesurfer99
08-04-2011, 05:55 AM
thank god for this post, was going postal (pun intended ;) )

Must admit it is becomming WAY to common for me to purchase a game on steam and then not have it work but have to tinker with settings drivers updates hacks or mods to get it to play, hell if this keeps up i figure i might as well DL a pirated copy, atleast they work.!

zmally
08-04-2011, 06:50 AM
how do you get into windwoed mode? i am using the disk version fully updated

Look and see if it's in the options menu under graphics.. without going on the game myself I can't tell you if it's there or not. If it's not, there's ways to get around it, a quick google turned up this fix:

Open the "swkotor.ini" file:

[Graphics Options]
AllowWindowedMode=1
V-Sync=0
Anisotropy=16
Frame Buffer=1
Anti Aliasing=6
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=1
Brightness=78
EnableHardwareMouse=1
FullScreen=0 Changed line
RefreshRate=85
Width=1024
Height=768
AllowSoftShadows=1
Disable Vertex Buffer Objects=0
AllowWindowedMode=1 - Added line

If it doesn't start up in windowed mode, hold ALT and tap RETURN. That should probably work :)

bblcreator8790
08-11-2011, 06:24 PM
Windowed mode seems to stop the game from crashing for me. It has to do with when the game switches from the game engine to the cutscenes, it causes some type of crash. Playing in windowed mode got rid of the crashes for me. Doesn't seem to work for everyone though.

drift543
08-14-2011, 01:55 PM
I've tried all of the above but nothing seems to work whenever I click the play button nothing happens a black screen wont even come up I am literally dumbstruck considering I'm running this on a alien ware computer

sfaxtis
08-17-2011, 10:07 AM
im sorry to say but most advices here are either not needed or wrong
especially disable movies and hardware mouse are completely wrong

so I made a recap of correct advices
http://forums.steampowered.com/forums/showpost.php?p=24277640&postcount=2

also as topic starter claims
(optional only if you still encounter problems after using my advice)

disable In-Game Steam Overlay for KoToR. This can be done by heading to your Steam Library and right clicking KoToR and selecting Properties.

aegisfate117
08-23-2011, 11:12 AM
This worked great.

Judo Boi
08-23-2011, 01:34 PM
I crash every time without fail, after trying all these fixes, right after I get done beating tie fighters from the Leviathan. Nothing is working!! Anyone else have this problem and fix it?

Its not like my comp can't run it...

AMD Phenom II X4 @ 2.8 GHz
6 GB RAM
1 GB SDDR3 w/ Radeon 5450

Running Windows 7 Prof 64 Bit

:(

TcoNL
08-23-2011, 10:48 PM
I have a rare occurence where I crash when I try to space travel. Rare but it happens.
Exiting the ship or traveling to a different planet works for me.

Always save before you travel to another planet.
And not just quicksaves.

XeroNecross
08-31-2011, 06:14 AM
HAHA! That worked for me! I jsut have a Windows 7 64x home edition.... well OEM or what ever... Bought it from NewEgg... it was cheaper being OEM :/

Anyways though it works again! IT'S ALIVE!!!! This is good now I don't have to never play the game again :D

XeroNecross
09-01-2011, 03:24 PM
As a follow up to my first post yesterday... Sadly I cannot see of the in-game movies now... So all the visions and all that... I dont knwo what they're talking about :/

I may already know the story line perfectly from reading the books and wookiepedia but I would still like to enjoy the in-game movies... But I can't if I do this method... Although I rather be able to play the game than not at all... If there can be some sort of a fix to this with out removing the in-game movie ability I hope we can all find it soon...

I love Windows 7 but its starting to suck more and more as alot of the great games I cannot play...

Actually all the games I cant play are Star Wars games :/
Dark Forces and Dark Forces 2 have complications and I can't play... mysteries of the sith I cant seem to even start that one right... atleast out cast and academy works... Republic Commando doesn't play either... Sad very sad :(

sfaxtis
09-01-2011, 03:48 PM
http://forums.steampowered.com/forums/showpost.php?p=24277640&postcount=2


and I posted that here just a few messages before yours

anyway
delete those two from the install directory-movies folder
biologo.bik,leclogo.bik
(I wouldnt suggest the common advice disable movies,
as this disabled all in game movies for me)

enable movies again
(if you dont delete those two game will crash,you may rename them if you dont want to delete them)

also Id recommend to make use of all of these advices or else you may have other issues as well

I bet that most of the people looking in this thread cant also see movies
and they dont understand it because its almost seamless

XeroNecross
09-02-2011, 11:18 AM
Yeah I saw that after I posted it yesterday and your advice worked for a while. But today now I can't even go between planets... The movies are causing problems I think. Yesterday there wasn't a issue, but then again... I was in the midst of the Kashyyk mission so I guess I didn't notice till I beat it all today.

I'll try that other piece you mentioned with the... settings and stuff... The complicated looking part that I avoided :/ I'm hoping it works.

EDIT: Still getting crashing during space flight even after I replaced the swkotor.ini file with the info you suggested... I think I may just have to go back to the whole disable movie thing... I rather play the game and not have in game vids than buying a $10 game i can't play...


If you come up with any other ideas please post I'll love to try some more options if you can find any if not then not a big deal I guess but I do appreciate all that you guys have done so far to help solve these problems. I just wish Bioware/LucasArts and Steam could work the issues out and fix them so people dont get mad... Cause I mean come on it's their game they should fix it!

sfaxtis
09-02-2011, 05:56 PM
Im sorry to hear
I tested it only for few hours in Taris and seemed to play fine

My advices above are a bit generic and applicable in most old games

update
I think that I may have found a solution to your problem
as NebonRevurg stated earlier
there is a problem with multicore cpus-strange but seems to create problems with movies
after changing affinity even the two initial movies I recommended deleting above run fine

fix

create a text file anywhere you like and copy the following




REM line below change disk letter if needed
c:
REM line below change install directory after {cd} command if needed
cd C:\mnt\Steam\steamapps\common\swkotor
REM leave lines below unchanged
c:\windows\system32\cmd.exe /C start /affinity 1 swkotor.exe
exit
REM change .txt extension to .bat and run Application from bat

fix the path in txt according to your installation and save

change .txt extension to .bat and always launch Application from bat
now kotor is set to run in the first cpu core only
-if you cant change the extension go here (http://windows.microsoft.com/en-US/windows-vista/Show-or-hide-file-name-extensions)-

ps I found a save game and multicore issue exists
fix works though, I traveled at about 10 planets
in the rare case a video hangs alt+tab also helps

wowcb21
09-05-2011, 03:53 PM
So as I am reading through this thread it seems that most people are having trouble actually starting up Kotor. My problem is that I can actually play the game for about 10mins then it crashes. Ive tried all these methods but nothing seems to work and it doesnt seem like that many people are experiencing the types of crashes I am experiencing. Wondering if anyone new any methods on fixing this? I sent a ticket in to lucasarts and steams support centers but my faith in them actually replying back to me are slim to none. lol. Any suggestions would most certainly be appriciated.

chiphiss
09-12-2011, 09:52 AM
Didn't work for me sadly =/..

Sam_killer_UA
09-16-2011, 10:55 AM
Is this game works with GeForce 8400M GS?

straceniec
09-16-2011, 06:31 PM
Is this game works with GeForce 8400M GS?

It should work ok.
On 9600M GS it works fine, but it has problems (low frame rate) in smokey places (which is abnormal, there's enough horsepower in my cpu/gpu to handle that).

Essedarius
09-16-2011, 06:49 PM
This game is not with the trouble or price.

Move along now.

Sam_killer_UA
09-17-2011, 03:14 AM
It should work ok.
On 9600M GS it works fine, but it has problems (low frame rate) in smokey places (which is abnormal, there's enough horsepower in my cpu/gpu to handle that).
Are you sure? 3$ is still some money ;)

straceniec
09-17-2011, 07:21 AM
Don't you dare! Don't even try to compare KOTOR's value to $3.
This is a giveaway, not a sale.


I haven't found a solution for this smoke frame drops, but other than that, it runs >30fps, all high settings with 4x AA.

victorelessar
09-17-2011, 08:33 AM
awesome it works now. i didnt have to disable videos tho
thank you very much

Reastar
09-19-2011, 02:46 AM
moved to new post
http://forums.steampowered.com/forums/showthread.php?t=2129262

kschang
09-23-2011, 09:18 PM
Got it working on GeForce 330M Win7 Home Prem x64. These are what I did

1) Applied the KOTOR_2_FIX MSS32.DLL replacement patch

2) Ran SWCONFIG, and set to max resolution (1024x768) If that res is not available, run the game in XP SP3 compatibility, then that choice should become available.

3) Set the game to XP SP3 compatibility (see above)

4) It should work now, no further mucking should be needed.

Zulrang
09-27-2011, 02:42 PM
Mine still crashes at start up. I've tried every single fix listed in this thread, as well as the "Windows 7 59hz" fix.

So much for a "complete" guide.

NovaWolfe22
10-07-2011, 03:40 PM
Hey, thanks for the guide. My mouse finally works now, keep up the good work!

Tdog3323
10-26-2011, 04:08 PM
I had problems with stating up kotor, I tryed every fix possible in this thread, but all I had to do to get it working was to update my ATI Radeon HD 6770m graphics driver, and it now works perfectly

LeviGratton
10-26-2011, 04:20 PM
When I boot the game, it loads to the start menu, but the upper left corner is the center, and about 30-40% of the screen is cut off. The screen has a large black border around it.

http://img.photobucket.com/albums/v497/Commando_Joe/KotorSS.png

I've tried changing the resolution for it, but all it does is change the image, leaving the border and all.

Vostok
11-18-2011, 09:07 PM
When I boot the game, it loads to the start menu, but the upper left corner is the center, and about 30-40% of the screen is cut off. The screen has a large black border around it.

This is the same issue I'm getting. I've tried every "fix" (most things are irrelevant but I did them anyway) but it still just runs with the upper left quarter of the screen.

:edit:

This fixed it for me:

http://www.howtogeek.com/howto/windows-vista/easily-disable-vistas-aero-before-running-an-application-such-as-a-video-game/

Appears to be a Windows Aero issue that you can disable on the executable file for the game.

Irishbrewed
11-23-2011, 05:12 PM
Look and see if it's in the options menu under graphics.. without going on the game myself I can't tell you if it's there or not. If it's not, there's ways to get around it, a quick google turned up this fix:

Open the "swkotor.ini" file:

[Graphics Options]
AllowWindowedMode=1
V-Sync=0
Anisotropy=16
Frame Buffer=1
Anti Aliasing=6
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=1
Brightness=78
EnableHardwareMouse=1
FullScreen=0 Changed line
RefreshRate=85
Width=1024
Height=768
AllowSoftShadows=1
Disable Vertex Buffer Objects=0
AllowWindowedMode=1 - Added line

If it doesn't start up in windowed mode, hold ALT and tap RETURN. That should probably work :)

I copy and pasted this into the file and the game run flawlessly in windowed mode, thanks a ton for taking the time to help.

BenReve
11-29-2011, 07:14 AM
Hey all, I'm using Alienware m15x and I bought the steam version and it couldn't work. Tried everything posted in this thread but nothing worked. ATI graphic card is the problem. If you want to read more about it go to this link:

http://forums.amd.com/game/messageview.cfm?catid=279&threadid=128067&enterthread=y

Anyway, my problem, similar to some of the guys who posted before me:
Started game on Steam -> 'Preparing to launch' -> Nothing happens.

BUT I found a solution to the problem. Hope this helps you guys who couldn't get pass the 'Preparing to launch' on Steam.


1) Download the 9.12 Catalyst Hotfix here:

http://downloads.guru3d.com/ATI-Catalyst--9.12-hotfix-Win-7-%7C-Vista-(32%7C64-bit)-download-2450.html

2) Start to run the installer but don't finish it. You just need the installer to extract the files to c:\amd\9.12 blah blah blah so you can actually find the file you need.

3) Search your computer or go to that folder and do a search for atioglxx.dl_

4) When you find that file copy and paste it to a simpler directory, I just pasted it to C:\

5) Open a command prompt as administrator by running cmd.exe AS ADMINISTRATOR.

6) Change your directory by typing into the command prompt: CD C:\

7) Expand the atioglxx.dl_ to it's uncompressed form of atioglxx.dll by typing this into the command prompt: EXPAND atioglxx.dl_ C:\atioglxx.dll

8) When the .dll file is uncompressed copy or cut paste it to your swkotor folder in steam apps and run the game.atioglxx.dl_atioglxx.dll".
remember to run command in admin

Note:

Remember to go to cmd in your start menu, right click and RUN AS ADMIN.

Also, make sure you have typed CD C:/ before the extract command.


Kudos to everyone who contributed in this thread. Cheers!

RuariWolf
12-05-2011, 03:51 PM
I'm a little cautious. The game was just crashing at launch for me, seems fixed now.

If all holds up, you are a saint my eyes dear dear OP.

Stiitch
12-07-2011, 12:55 PM
I had posted this on the SWTOR site as well. This is specific to the Asus G73jh laptop. There is definitely a driver issue for the ATI cards. The following describes the steps to take to bring this laptop up to the latest drivers without incurring horrible artifacts, low frame rates, stroboscopic effects, or GSODs.

And to the point, before this fix, KOTOR would not load with any of this forums suggestions; after this fix, it can be run as delivered with the graphics tuned all the way up. Only a slight issue with movies not showing (alt-tab, alt-tab back in to play correctly).

*** THIS IS AN "AT YOUR OWN RISK" PROCEDURE, WHILE I HAVE DONE THIS I AM NOT GUARANTEEING IT WILL WORK IN ALL CASES ***

Ok, legalize is over, for all you G73jh ers, I also have had issues with the laptops erratic behavior with respect to games and graphics (deus ex, kotor, swtor). The issue that I was having, was the latest drivers I could use were 0912 (After Asus branding/tweaking they are the latest 1001 drivers). If I attempted to use any drivers later than this, artifacts would plague the screen, or send me to a GSOD (gray screen of death).

Luckily, Republic of Gamers forums has a fix, updating the vBios on the video card. First, I upgraded the bios of the mother board to version 0211. This is a required update before updating the vBios, and fixes other problems that are minor annoyances. The updates page (after you enter the OS you use) will have all the necessary tools for a bios update.

http://support.asus.com/Download.asp...73Jh&p=3&s=252

Bios flash is simple, easy, and takes about 10 minutes, however, if it looks stuck, DO NOT TURN YOUR MACHINE OFF, it is still working, removing power during a bios update can "brick" your MoBo.

Then I followed the directions/video (link below) to assist in the vBios.

http://www.asusrog.com/forums/showth...D-Vbios-Update

After all this is said and done, I went to AMD/ATI, grabbed the latest drivers and wallah, I was finally using the graphics card to its fullest potential. Deus Ex, KOTOR,SWTOR, and a number of games became clean and free of "heat" artifacts. That said, cooling the card is still paramount, don't block the fan in the back, and try to make sure some air can go up through the bottom of the laptop.

I really hope this helps people shortcut to a solution.

kieran3448
12-16-2011, 05:41 AM
Thanks man 10 hours in and it stops working but ur fix did the job.

Layarion
12-17-2011, 10:06 PM
First time starting the game, my mouse didn't work, and the game would mimize or fail with intro movies or any movies. Without disabling the movies i found a way to get the game working perfectly. Toshiba Qosmio x775 Nvidia GTX 560m latest drivers.

First, disable in-game community because it doesn't work anyway so its useless.

Second, go to steamapps/commom/kotor and find the file that lets you change the settings found at the top of this thread and enable V-sync, that's the Only thign you should change. Leave the mouse and movies alone. Also you can change the resolution if you want.

Third, delete the desktop shortcut created by Steam and go back to steamapp/common/kotor and create a desktop shortcut of the .exe launch file. Then...

Right click, go to properties, Compatibility and enable windows compatibility for XP Service Pack 3

then check "disable visual themes, disable desktopcomposition, and disable display scaling on high DPI settings"

Last, but not least check "run this program as an administrator"
while im not sure it's neccisaay, I added that last one for good measure.

I no longer have any problems with the game so I'm happy.

Update* 12/18/2011

If your using Optimus with nvidia go and make sure Nvidia is set to preffered card under the global settings in the nvidia control panel. or make it application specific but this game does not seem to be supported by default.

JokingJames2
12-22-2011, 12:04 PM
I get the problem where I tell the game to run, then Steam says "Preparing to launch" and then nothing happens.
I've tried:
-Setting to windowed mode in the ini file
-Adding "Disable Vertex Buffer Objects=1" to the ini
-Adding "AllowWindowedMode=1" to the ini
-Using the fixed Mss32.dll file
-Renaming the intro movies (essentially disabling them)
-Disabling ALL movies
-Disabling hardware mouse
-Running in compatibility mode for Windows 7, Windows XP (SP3), and Windows XP (SP2)

None of these things helped in the slightest.


Specs:
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1
Processor: AMD Phenom(tm) II X6 1065T Processor (6 CPUs), ~2.9GHz
Memory: 6144MB RAM
Card name: ATI Radeon HD 4250 Graphics
Display Memory: 2940 MB
Dedicated Memory: 252 MB
Shared Memory: 2687 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)

The graphics card is integrated, but I don't know if that makes a difference for this game in particular.

JasonGreene
12-23-2011, 08:50 AM
well this ♥♥♥♥ing sucks i have windows7 and it didnt ♥♥♥♥in work i tried

Count_D
12-23-2011, 11:14 AM
It needs fixing? o_O Works flawlessly for me.

coolerdude
12-28-2011, 01:11 PM
nothing is working for me. Mine just crashes instantly at startup with the words: "swkotor.exe is not working properly"

I tried all the the above fixes including setting affinity, windowing, disabling movies, dl-ing updated drivers, reinstalling, setting compatibility, etc.

my comp stats are:
OS: Windows 7 Home Premium(64 bit)
Processor: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz, 2001Mhz, 4 Cores, 8 Logical Processors
RAM: 8 GB
Graphics: Intel® Processor Graphics 3000 (ATI Manufactured)

I ran a hardware scan through the swkotor configuration utility, here were the results:
[SWKotOR]
ReportDateTime=12/28/2011 12:08:15 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v1.03.514077
GameInstallLocation=c:\program files (x86)\games\steam\steamapps\common\swkotor\

[OS]
Name=Win9x
Version=Windows 9X v6.1 build 7601 Service Pack 1
Service Pack=None
Status=Fail

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=8
CPUSpeed=1995
CPUFamily=6
CPUModel=10
CPUStepping=7
CPUVendor=Intel
CPUName= Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz
Status=Pass

[Memory]
RAM=4096
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=241.75GB
D: (NTFS), UNICODE=1.58GB
G: (FAT32), UNICODE=85MB
K: (NTFS), UNICODE=74.70GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\,F:\,H:\,I:\,J:\
Drives=XMBAP VO5E30H 1.03

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=1024
Desktop Resolution=1920x1080x32
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=1.1.0
OpenGL Vendor=Microsoft Corporation
OpenGL Renderer=GDI Generic
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Fail
DX Status=Pass

[Audio]
Sound Card Name=Speakers and Headphones (IDT High Definition Audio CODEC)
Status=Pass


;Game Options from swkotor.ini

[Sound Options]
Sound Init=0
Music Volume=85
Voiceover Volume=85

But i KNOW that i have the comp stats to run this game as this is a brand new laptop

FMPhoenixHawk
12-28-2011, 04:55 PM
I've been trying to get the game to work on my desktop again. It worked when the system was running Win XP, now refuses to on Win 7 Home Premium. Tried running it in affinity mode, and fiddled with the settings, even did the patch. Nothing. Now, I got KotOR 2 to run on my Win 7 Pro laptop, and it has had only minor problems. Any ideas?

still39482
12-29-2011, 11:08 AM
I was bummed when KOTOR wouldn't work at first, but I had it up and running in a matter of minutes thanks to you!

coolerdude
01-02-2012, 01:28 PM
so no one is gonna help us at all?
whats the point of asking for our system specs when you're not even gonna do anything?

Snakethesniper
01-05-2012, 07:21 AM
nothing is working for me. Mine just crashes instantly at startup with the words: "swkotor.exe is not working properly"

I tried all the the above fixes including setting affinity, windowing, disabling movies, dl-ing updated drivers, reinstalling, setting compatibility, etc.



[Video]
Video Card Name=RDPDD Chained DD
Video Memory=1024
Desktop Resolution=1920x1080x32
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=1.1.0
OpenGL Vendor=Microsoft Corporation
OpenGL Renderer=GDI Generic
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Fail
DX Status=Pass


I've a laptop with an Ati too, and the swkotor config application doesn't recognize it and it gives me the Yellow dot. I think this is why I can't run it with vsync activated and such

Tomoj
01-05-2012, 05:55 PM
I've tried it and I just get a false start... :(

Yellowmellow94
01-11-2012, 12:46 AM
Have all my rep.

lemoi
03-23-2012, 12:20 PM
The fix below worked for me on Win 7 Ultimate 64-bit, Core i5-750, ATI HD5850. No other changes were necessary. Thanks OP, you've made me a very happy man :)


Had all sorts of problems with this - mostly movies not playing, but others also. Sometimes it works, sometimes it didn't.

I have found a fix that makes my copy workable though - and appears to be good.

Once launched, immediately alt-tab back to the desktop and get the taskmanager running. Change the affinity of the swkotor.exe process so that it only uses a single CPU core, rather than automatic.

Once done so, mine plays movies rock-solidly, and doesn't crash.

Haven't found a way to make this change persistent as yet - a command lijne using 'START' will do it, but not from a .bat script. But still - it's a start. This certainly works for me.

wRAR
04-08-2012, 04:01 PM
Windows 7 64bit, 4 cores, KotOR with the widescreen fix. Start movies work, the escape pod movie minimizes the game but after switching to the game works, the first dream movie right after that crashes the game. Disabling the overlay (though it works) doesn't help. The "Strange Dream" movie from the movies menu works. Setting CPU affinity to CPU0 doesn't change anything. Updating mss32.dll from "KotOR 2 Vista fix" doesn't help.

Sammy3
04-09-2012, 03:18 AM
Windows 7 64bit, 4 cores, KotOR with the widescreen fix. Start movies work, the escape pod movie minimizes the game but after switching to the game works, the first dream movie right after that crashes the game. Disabling the overlay (though it works) doesn't help. The "Strange Dream" movie from the movies menu works. Setting CPU affinity to CPU0 doesn't change anything. Updating mss32.dll from "KotOR 2 Vista fix" doesn't help.

Mine still minimises sometimes when cutscenes start and very rarely it causes a crash (this seems to occur when multiple cutscenes occur one after the other).

To get past this I switched to windowed mode, then after the cutscenes finished I saved then switched back to fullscreen.

To get it in windowed mode got to your swkotor installation directory and open swkotor.ini file. Scroll down to graphics options to
FullScreen=1
and change it to 0.

Of course you can also leave it in windowed mode for the rest of the game if it crashes a lot for you instead of keep switching in between like I did.

If you still have trouble setting it in windowed mode see this topic:
http://forums.steampowered.com/forums/showthread.php?t=1275279

wRAR
04-09-2012, 02:49 PM
Mine still minimises sometimes when cutscenes start and very rarely it causes a crash (this seems to occur when multiple cutscenes occur one after the other).

To get past this I switched to windowed mode, then after the cutscenes finished I saved then switched back to fullscreen.


Nope, it crashes anyway.

wRAR
04-09-2012, 03:14 PM
OK, found it. I've followed http://www.reddit.com/r/gaming/comments/chxq2/modding_guidestar_wars_knights_of_the_old_republic/ and my crash is even described there.

Sammy3
04-09-2012, 05:28 PM
OK, found it. I've followed http://www.reddit.com/r/gaming/comments/chxq2/modding_guidestar_wars_knights_of_the_old_republic/ and my crash is even described there.

Erm this page describes how installing some mods could cause crashes...

Have you installed any mods?

And did you try it in windowed mode?

GoranM
04-22-2012, 08:04 AM
Thank you, it worked great!

Aafrow
04-23-2012, 10:19 PM
Kay, so. i downloaded the game. thinking that oh my god. i cant wait. going to relive my childhood. then i open it once its done. about a second in. after i press launch. screen goes black. Star wars has stopped working for some reason. windows is trying to solve the problem. so it crashes. im like. okay. just some settings need to be fixed. so i go onto the forums. set up swconfig. (btw im on win7) so then i go and download the patch and all that good stuff. so then it finally goes to the launch menu thing. where you can press play. configure. update. etc. so i press play game. then it says i need to put in swkotor disk.....then. after that. so then i went in a tweaked it some more. got passed that. then it does the same thing. star wars has stopped working. we are trying to solve the problem. I NEED HELP PLEASE.

Kelranox
07-02-2012, 08:01 AM
Still doesn't work for me. Whenever I click 'play', the prompt pops up to indicate that it's trying to launch, but it blinks furiously and eventually goes away without actually launching the game. I turned my anti-virus software off and it still doesn't work, not to mention I did everything mentioned above. I also verified the integrity of my game cache, uninstalled and reinstalled it, and defragmented it. Still nothing.

dkJammin
07-05-2012, 02:33 PM
Works fine. Cutscenes minimize the game but you can get the game right back up by clicking it in the toolbar - cutscenes continue playing. No problems. I should also note this game worked right after installing. No changes needed.

Using WSGF Widescreen modifications - 1920x1080 with forced 32x antialiasing and AF.

Windows 7 64 bit
GTX 570
i7 2600k

I'm about 54 hours in. Best game ever.

A Dewdrop Nun
07-11-2012, 08:36 AM
Kotor seems to have an extreme dislike of intel graphics chips, I must have tried every 'fix' there is, and still nothing. disabled steam overlay, set affinity to 1, disabled movies and runin coompatibilty modes. nothing :(

YogiBear93
07-12-2012, 07:04 PM
I can't pull off the Set Affinity Trick. It crashes too quick for me to get the affinity menu up.

*sad*

darthcircuit
07-14-2012, 07:01 PM
you may try setting the affinity in the launch options in steam. try adding "/affinity 0" to the options line in kotor's properties sheet in steam.

TheVentilator
07-14-2012, 07:21 PM
Is it mainly NVIDIA users which have problems with this game?
I quitted using NVIDIA after all their bad drivers, and went with ATI which always works 100% with any game.

I just bought KOTOR and it runs perfect with Windows 7 64-Bit with ATI and AMD Quad-Core.
With Widescreen + hud fix it runs fine at 1920x1200 too.

Arctic_Wolf
07-15-2012, 12:22 AM
I am having a pretty huge problem with KotOR 1 on my Win7 computer here. It will always crash without exception right after you rescue Bastilla on Taris and try to leave your hideout. It doesn't matter whatever character I select or don't select it will immediately crash as soon as I hit "okay" when leaving the hideout. There is no pause or loading it just goes black and if I'm playing windowed the crash dialog box comes up in an instant.

I've done a search on the crash message but it's apparently pretty non-specific and as such I have tried the following with no success or even noticeable change:

Use Securom-fixed exe.
Used a 'no-CD' exe.
Used the mss32.dll replacement fix.
Tried running in compatibility mode and/or Administrator (interesting story the game runs better when not in compatibility mode).
Set core affinity to 1 core.
Disabled themes and run the game on several graphical settings.
Run the game windowed.
And every combination of the aforementioned 'fixes'.

Here's the thing I got so desperate I put my save file to flash drive and took it over my friend who own's the disc version but has a Vista system. He installed and took my save file and it crashed in the exact same way and then tried the same fiddling around tricks with the exact same fruitless result.

Is there any fix/ work around I haven't tried? I'll even use a save editor that just places me outside my freaking hideout if such a thing exists.

Edit: Just for clarification my system is-
Win7 64 bit
8 gigs of DDR3 RAM
GTX 560 Ti
6 Core Intel i7

Friend's computer is
Vista 64 bit
4 gigs of DDR2
GTX 9800
4 Core Intel Quadro

Again both produce the same result.

Edit #2:

We just tried from a new and earlier save on my friend's computer and got the exact same result: Crash as you leave the hideout after rescuing Bastilla. 6 hours well spent.

sobrator
07-17-2012, 03:43 AM
i was really frustrated because none of your fixes were working on any of my 2 PCs. I've expended more than 4 hours with that, and i was sad because this was the first game my girlfriend bought on steam. I tried EVERYTHING and no way i could launch the game.

Finally i've found the only solution for me, and i didn't read it here, so i want to share it with you.

The problem is for ATI graphics owners that can't start the game.

You need the file "atioglxx.dll", but not any atioglxx.dll, you need exactly the one in the Catalyst 9.12 drivers (hotfix for windows 7).

You can get it following the steps here:

http://www.overclock.net/t/712048/kotor-1-2-windows-7-64-fix-ati-cards

Simply put that dll in the game folder and you can play.

For your interest (if you want to check) the size of that atioglxx.dll is: 12,8 MB (13.487.616 bytes)

I would like to hug that guy.

Zane7
07-17-2012, 05:39 PM
Thanks the fix worked no more waiting at the desktop after the Lucasarts logo. Running this on windows 7 64bit.

Thanks again.

Gamblar
07-17-2012, 07:49 PM
Worked perfectly for me; I'm running Windows 7 64 bit with a 5770 GPU. Picked this game up for a pittance in the sale and couldn't get it to work, but thanks to these tips I'm now blasting my way through Sith scum. Thanks.

robot7819
07-20-2012, 09:51 AM
Great guide, It worked for me just to disable movies, didn't need to disable steam overlay. I'm using a nvidia gt630m.

TheBountyHunted
07-20-2012, 11:23 AM
I tried every fix for my computer, game, and graphics card on this thread that applies to my computer and none of it worked whatsoever. It opens, stays a black screen, then doesn't respond. I run a Windows 7 64 bit with Nvidia Geforce GT 650 M.

Zane7
07-20-2012, 11:07 PM
On the disable movie thing, it disabled all movies for me.

which sucks but I guess it can't be helped.

Turpauuni
07-22-2012, 02:53 PM
This is sad:
I did EVERYTHING and still, this game crasesh to desktop when I try to start the game. First I did get some erro code 80 and then when I tried to use XP mode I got P:000006543 error. Now I dont get eny errors. I dont know what am I doing wrong? I have all ini. files, movies blocked, mouse, etc etc done.

My specs:
Win 7 64 bit
AMD Athlon X4
Nvidia 315 512mb

And yes I have played this game on cd before and it worked when I used sinlge core option, but now I can´t acces that somehow.

Edit:
Hope this helps

Ongelmatapahtuman nimi: APPCRASH
Sovelluksen nimi: swkotor.exe
Sovelluksen versio: 1.0.3.0
Sovelluksen aikaleima: 402bc2d9
Vikamoduulin nimi: StackHash_be9b
Vikamoduulin versio: 0.0.0.0
Vikamoduulin aikaleima: 00000000
Poikkeuskoodi: c0000005
Poikkeuksen poikkeama: 00000000
Käyttöjärjestelmän versio: 6.1.7601.2.1.0.768.3
Aluekohtaisten asetusten tunnus: 1035
Lisätietoja 1: be9b
Lisätietoja 2: be9bf493184e8a1cc6dbc11c84c53984
Lisätietoja 3: a099
Lisätietoja 4: a0997196efb56d84f9f4ce5a43974546

prdude1234
07-23-2012, 10:42 AM
I found a simple fix that prevents the game from giving a black screen right before the opening logos.

1st. Go to /program files(Or x86)/steam/steamapps/common/swkotor/movies
2. Once you find that folder, scroll all the way down.
3. Most important! DELETE these 3 files, ONLY these 3
I. biologo.bik
II. leclogo.bik
III. legal.bik

After you delete these files, it will simply skip the 3 opening logos and it will prevent the black screen + you will be able to see the movies. You can also disable movies, but if you disable movies you wont see the cutscenes in the game (Like Malak talking to his admiral/the opening scene), this fixes the error while allowing you to see all the cutscenes without problems...

Another fix for: black screen after loading a game/changing settings
What I found out is that this is a common problem in monitors that arent running at 60Hz refresh rate (Correct me), the error consist in that when you load a game, or change the settings, when you go back to gameplay, it will be a black screen (You can still go back to menu/move around but not see) and you wont see.
The fix: Simply do alt + tab and you will be able to see again

gazztastic
08-16-2012, 05:24 PM
I had the same issue, the game would not work with movies until I came across a really weird "fix". I have no idea how or why this works and maybe it only works on my comp but here is what I do to get the game working. So far there have been no crashes.

Go to program files 86 > steam > steamapps > common > swkotor, then run the swconfig.exe file.

When here only uncheck the hardware mouse box, leave the disable movies box as it is.

When that is done close the swconfig.exe window.

Directly below the sxconfig there is the startup file for swkotor. Keep this window open.

Start the game normally (I have a steam desktop shortcut).

When it cuts out go to the startup file (mentioned above), right click and "Run as administrator".

Nothing should happen until you close the "program files 86 > steam > steamapps > common > swkotor" window.

For some reason when I do this the game just starts up.

I set the resolution to the highest possible so when I get to the the main menu the resolution is all messed up.

To fix that I just pressed ctrl alt del, once the screen changes to the help screen just close it straight away and the resolution has fixed itself.

This is badly explained and I only came across it by accident but it is working for me so far. If someone knows why this works and maybe has a less messy way of going about it please do tell.

I hope it helps.

winsause
08-19-2012, 05:34 PM
These fixes work very well, thank you for taking the time to post.

swedewolf
08-20-2012, 10:28 AM
Your help maked me run Kotor, I only bought it a month ago. Good to finally play it. Got a whole cluebook bought all the way back then, when it was new.
Kudos

LostAngel1000
08-23-2012, 05:55 PM
Okay I see nothing that says it can disable my ingame steam overlay in my Properties of Steam, I see Enable Steam Community In-game but nothing that says Disable ingame steam overlay. Is that something you do with the Set Launcher Options??

Also none of the Fixes seem to explain to to do if you get a Blackscreen and crash as soon as you hit play, no Logo or nothing showing up.

Can any one give me a Simple walkthrew with pictures for making KOTOR work on a Windows7 32bit home Premium OS?

Count_D
08-23-2012, 09:21 PM
Oh yeah, nice "guide to fixing". But you know, disabling the movies, which you NEED TO UNDERSTAND THE STORY, isn't what I'd call fixing.

panzerlied
08-25-2012, 11:25 AM
Ugh, nothing has worked for me, I don't understand it. I played this game a few months ago just fine, and then I re-installed it and nothing. My Steam profile border turns green for about 20 seconds, my screen flickers like the game is about to pop up, and nothing......

Tresob77
08-26-2012, 04:55 PM
I've been experimenting with these fixes for about three hours now and none of them seem to be working on my Win 7(64) system, ATI Radeon 5700. (And I'm really hoping none of the files described above had viruses...)

I'm about ready to give up, and just wanted to add a "Buyer Beware" warning to the thread.

I have no doubts that these fixes have worked for other users, but I've been unable to make them work for me (and I readily acknowledge it might be incompetence on my part).

EDIT: Strike that! I did some extra jerry rigging and managed to get the file from sobrator's link to work. No idea if the game will run without crashing, but I at least made it to the menu! Phew.

UPDATE: The game seems to be running okay so far as I can tell. Occasionally, the movement controls jam, but I might simply not be used to them yet. I'll let you all know if any crashes pop up and if any other tips seem to help them.

D3rk01
09-03-2012, 08:15 PM
Anyway of having vsync enabled and getting it to stay at 60fps? I can't force it externally and if I do it in game, it reduces the fps to 30.

Ashnazgul15
09-04-2012, 03:42 PM
This has also seemingly helped fix my problems. I will +rep you whenever I figure out how. Feels like every board does it differently and tries to hide it.

If you can figure out getting kotor II working, however, you'll also earn yourself a cookie :)

FMPhoenixHawk
09-05-2012, 02:36 PM
Actually, a direct install of KotOR 2 on a Win 7 Pro install works fine for me. (Running on a Toshiba Satellite L305D-S5934) It's KotOR 1 I can't get working.

real4xor
09-08-2012, 11:33 AM
hmz, all I did was install the TSLRCM mod. (http://www.moddb.com/mods/the-sith-lords-restored-content-mod-tslrcm)

Dialogues sometimes skip after the Steam overlay gets up, seems to be a common problem with a few older titles.
And movies seem to have an odd small size. But ah well, I can still see what`s going on.

I haven`t encountered anything gamebreaking yet.

stripysocks
10-09-2012, 03:11 AM
First, disable In-Game Steam Overlay for KoToR. This can be done by heading to your Steam Library and right clicking KoToR and selecting Properties.

Second, navigate in Windows Explorer program files or program files 86 (this depends if you're running 32-bit or 64-bit windows) > steam > steamapps > common > swkotor > and then run swconfig.exe which should be found in the swkotor folder.

Third, after this applet is up, uncheck the "Use Hardware Mouse" and check the "Disable Movies" (this just disables the intro movies, to my knowledge).



Thanks mate! It wasn't getting past the lucasarts logo on my system till i found your post.

Much appreciated!

paratech2008
10-19-2012, 10:04 PM
Thanks, +rep.

Carnagedude504
12-11-2012, 03:16 AM
Works for me, but it doesn't make a difference whether I check or uncheck the "hardware mouse" box.

Also, as for disabling movies, while it does allow you to play the game, it also disables all movies from playing within the game, not just the intro sequence. Is there any workaround for this?

ecksohh
12-23-2012, 08:15 AM
The fix in the original post didn't fix it for me, but it put me on the right path.

It was running fine but the issue I had was the game was displaying tiny, a few things I tried made it fullscreen but the the menu and the dialogue options in the game disappeared.

After trying a few things I have it running in XP SP3 compatibility mode with launch options set as -w800 -h600 and hardware mouse checked off in the swconfig exe in steamapps\common\swkotor.

GSamways
12-26-2012, 08:06 PM
When trying to install WinXP games on a Win 7 (or 8) system. You must cope with the security in "Program Files" as the game does not understand the use of "Program Data" for read-write files.
What I do is add an extra drive and either format FAT; or NTFS with security for the drive set to "everyone" and "System" both full control, then install the old game to the drive (steam or otherwise). This seems to overcome most software issues.

ColdFusion1000
07-03-2013, 05:32 PM
Hi, instead of checking "disable movies", which stops all in-game movies, making the story a lil bit confusing, leave it checked. Find where you KOTOR folder is (SteamApps/Common/Kotor, or MyGames/Kotor), and in the "movies" folder delete biologo.bik, legal.bik and leclogo.bik

So far, no problems, and all videos run in-game.

(You might want to make a backup of your Kotor folder in case I've actually destroyed the game, but no crashes/freezes so far.

(Also, if you're freezing after combat, enable VSync)

Savaralyn
07-22-2013, 12:18 AM
Doesnt work for me. still immediatly crashes on start up.

gzmeboy606
08-04-2013, 05:25 AM
Have tried all fixes. I really thought the expanding the atioglxx.dll thing would work as it was so techy, but hey.

I'm running W8 64-bit with a HD4870 (so I have the Windows WDDM v1.1 drivers).

When I run the swconfig.exe, and I click "Scan Hardware", it shows that I'm failing on 2 things:

OS: Windows 9X v 6.2 build 9200 OS required: Windows 98, ME, 2000 or XP - I am running in XP SP3 compatibility

OpenGL: Microsoft Corporation - 1.1.0
Required Non-Windows Generic OpenGL 1.4.0 drivers

It also weirdly states:

Video Warning: (null) 2048MB
Graphics Recommended ATI Radeon 9200 or better,
Nvidia GeForce4 Ti or better (128 MB VRAM)

So it looks as though it isn't seeing my GPU and maybe the WDDM drivers are causing a problem too? Any suggestions would be much appreciated.

nitrokitty
07-19-2014, 05:57 PM
I have another issue that I fixed on my own, and some people may encounter this.

KOTOR does not play nice with text scaling. I play on my TV, so I have my scaling turned up to 150%. This produced a weird graphical bug where the screen would only cover the top left portion of the game, making it look weird. The way to fix this problem is to go into Control Panel -> Display -> Set Custom Text Size (DPI). Then check the box labeled "Use Windows XP DPI Scaling". You'll have to restart Windows after this. After I did this, the problem was solved and the game played just fine. Good luck!