PDA

View Full Version : Sometimes freezes on quit


hexaae
12-07-2010, 01:41 PM
Does it happen to you too that sometimes, when quitting, the game hangs?
You can still hear the garage looping sounds but the game hanged and won't quit.
Happens randomly, let's say 1/10 times.

This has been reproduced on Vista and Win7.

Pavilion DV5, Win7 Ultimate x86, GeForce 9600M GT, 4GB RAM.

seseorang
12-08-2010, 02:38 PM
Could be your graphics card. It's a mobile version. I've played over 20 hours on this game and had no "hang on quit"

I'd try to verify cache files and see if that helps

hexaae
12-09-2010, 01:25 AM
Everything is ok. The video driver are stable and never had crashes or "stopped working" with a game.
It's just Grid that hangs on quit, and sound is still playing...

seseorang
12-12-2010, 06:05 AM
Have you verified the cache files?

hexaae
12-13-2010, 02:32 AM
Ok, let's clarify:
- yes, the cache is ok checked many times
- everything is ok, no sound problems, never had video/audio driver problems or crashes
- tried also defalut settings (backup)

It's just that sometimes randomly, when exiting after a quick race it simply hangs with garage sounds looping and won't close the game screen.
It did this on Vista and now on 7, it's rare but sometimes happens.

I'm surprised nobody else has seen this bug before...

seseorang
12-13-2010, 06:57 PM
I'm using Nvidia and the game runs, and closes perfectly fine. I'm running SLI as well (9600GT) Latest drivers - non beta at time of this post

hudson633
01-08-2011, 10:57 PM
I wonder if many other players get this problem, and simply don't post about it. For me it's not a big inconvenience really, if other players get this problem then maybe they feel the same way. It's the kinda small scale bug that a dev team might not bother patching, the kinda glitch they'd pass off as being a problem with your machine?

Sometimes mine jams when I try to exit, and sometimes I can then close the process from ctrl-alt-del when it hangs. Although sometimes when it jams, I have to restart. If the game doesn't hang like that, it will close and an error message is at the desktop.

Windows XP, ATI HD4850, 4GB RAM. I've recently installed a gamepad driver which has a file in the GRID directory, I worry if touching the steam options for GRID might remove that file, so I don't veryify the cache/try defragging.

I'm not too interested in a fix or finding out what the cause is, just nice to chat about a strange bug. There's so many out there...