PDA

View Full Version : Fallout 3: GOTY crashing


fire-holder
12-20-2010, 02:45 PM
Hello. I have been a huge fan of fallout and I recently got this computer so I can game on a PC instead of my PS3. When I saw the sale of fallout 3: GOTY edition for $20 I couldn't pass it up. Here is where the trouble came. I just downloaded it and when I press new and create new game it will load for a second then a message will appear saying the game has crashed(after looking for a problem). Now I did see a brief message about going into control panel and turning something on/off but forgot what it was, I was wondering what that might be, if it is causing the problems, if it isn't the cause what could I do to fix it.

System:
4 GB RAM
3.20 GHz processor
I don't know the video card I have but it isn't new or anything and my games do not seem to like it.

Could this also have been caused by a large amount of people buying it?

Thanks

Animositisomina
12-20-2010, 02:49 PM
To help narrow the possibilities down of what could be causing the crashes, first try installing the Unofficial Fallout 3 Patch (http://www.fallout3nexus.com/downloads/file.php?id=3808). It helps with many, many bug/glitch related issues the game has.

fire-holder
12-20-2010, 03:00 PM
Thanks it is downloading now. But it did mention something about turning on or off something in control panel, anyone know anything about that?

Animositisomina
12-20-2010, 03:03 PM
The error message from when the game crashed, you mean?

fire-holder
12-20-2010, 03:09 PM
it appears after. It is windows 7 checking for why it crashed. The patch didn't help either. Seems everyone who bought it has the problem so unless I can get this figured out now it will be fixed after the sale like they did on Halloween with overlord.

Animositisomina
12-20-2010, 03:12 PM
Strange that a sale could create a new problem. It's the same game it always is. I don't have Windows 7, so I can't help with that. I'm sure someone else can though.

Wasted
12-20-2010, 06:46 PM
I have the same problem.

I have Windows 7 64bit Home edition and the GOTY version crashes on desktop. Game used to work fine (aside from the common FO3 crashes) on my crappier PC running XP. Oblivion is crashing on start-up too so it might be an issue with the engine not liking my setup. I have tried the common fixes for this game like audio codecs, changing compatibility to XP, and updating drivers.

Current setup:
Windows 7 64bit Home
2x GTX 460's
6GB DDR3 RAM
3.06GHz Quad i7

For comparison, my old setup was:

Windows XP 32bit Home
8800 GT
3GB DDR2 RAM
2.66GHz Dual Core

Verwandlung
12-23-2010, 04:52 AM
Same problem here with FNV

Gigabyte GA-EX58-UD5
i7 920
6 GB Corsair DDR3 Triple-Channel
WD VelociRaptor HD
Ati 4890 (most recent drivers)
Vista 64



http://forums.steampowered.com/forums/showthread.php?t=1670685

52pickup
12-23-2010, 12:36 PM
Same problem.

You must use "Turn Windows features on or off" in the Control Panel to install or configure Microsoft.NET Framework 3.0 x86.

It said that, right? Go to Control Panel > Programs > Programs and Features. On the left column it should say "Turn Windows Features On or Off". Apparently in the window it opens there should be a check box, but mine's completely blank. :\

I wanna play! Dx

Xxbruthaman17xX
12-23-2010, 01:51 PM
Same problem.

You must use "Turn Windows features on or off" in the Control Panel to install or configure Microsoft.NET Framework 3.0 x86.

It said that, right? Go to Control Panel > Programs > Programs and Features. On the left column it should say "Turn Windows Features On or Off". Apparently in the window it opens there should be a check box, but mine's completely blank. :\

I wanna play! Dx

Dude, I've had the exact same problem, I've managed to get Fallout 3 GOTY edition working on my laptop, but on my desktop the game just blacks out after I hit "Play Game". Laptop running with a T9300 processor, dual core, Centrino, ~2.5Ghz, Nvidia 8600M GT graphics, 4gigs of ram, Windows Vista Ultimate. Running on medium settings but the game is glitching. I had to update my vid card drivers. As far as the Microsoft .Net Framwork thing, I went through the control panel and turned everything off, however, it caused some other issues with my other Dell applications. Turned it back on and the game ran. I shouted for joy. Got everyting running smooth. Was actually able to play through the first missions, and make it to the town Megaton.

As far as my desktop goes, I've been working on trying to fix the issue for about 12 hours now. I sent an intense email to Bethesda and they got the message. I did some troubleshooting, and actually got it to come up past the play game, the game actually loaded to the start menu, then crashed, lol. I'm quite aggrivated at the moment. On my last nerve.

blatant3
12-23-2010, 04:21 PM
I also had the same problem yesterday. Same crash, same errors. I found out from another thread that if you set the game to run on your monitors native resolution it would load up and play. This worked for me. Not sure if it will work for you but I figured I would run that by you.

52pickup
12-23-2010, 04:42 PM
I also had the same problem yesterday. Same crash, same errors. I found out from another thread that if you set the game to run on your monitors native resolution it would load up and play. This worked for me. Not sure if it will work for you but I figured I would run that by you.

How do we find our native resolution. Dx

Never mind, it's the highest resolution supported, right? Yeah, doesn't work. D:

Xxbruthaman17xX
12-23-2010, 07:13 PM
I also had the same problem yesterday. Same crash, same errors. I found out from another thread that if you set the game to run on your monitors native resolution it would load up and play. This worked for me. Not sure if it will work for you but I figured I would run that by you.

Yeah, I tried the native resolution. Didn't work.

DuckMaestro
12-23-2010, 11:43 PM
I am running into same problem. Just bought GOTY edition. I can load into the game's first menu fine, but once I click to start a new game, I see a brief loading screen then application crash.

Win7 64-bit. 6 GB RAM. nVidia GTX 470. I've tried disabling steam community overlay, as well as administrator mode, run as "vista SP1", and "disable desktop compositing". No luck. >.<

poo
12-24-2010, 04:40 AM
It crashes A LOT. New vegas crashes for me too.
Its a problem with many peoples pc, not much you can do apart form save regularly and get mad when it crashes

52pickup
12-24-2010, 09:16 AM
When I click "Play" on the little screen that pops up (the one where you can set your video options and load the add-ons) the screen turns black, but then it crashes to my desktop, with the given "Fallout 3 has stopped working we're trying to find a solution derp" message.

Smeikle
12-24-2010, 10:15 AM
Welcome to the world of Fallout...

Fallout 3 has been the most unstable game I have -ever- played, yet I still keep pushing through it because it is so fun.

52pickup
12-24-2010, 10:20 AM
Welcome to the world of Fallout...

Fallout 3 has been the most unstable game I have -ever- played, yet I still keep pushing through it because it is so fun.

At least you can play it. Dx

Fact: I'm posting to keep this alive to see if anyone knows a fix.

DuckMaestro
12-24-2010, 11:59 AM
It crashes A LOT. New vegas crashes for me too.
Its a problem with many peoples pc, not much you can do apart form save regularly and get mad when it crashes

This is not a random crash. This is happening for me and the OP every time we wish to start a new game.

FazeTwo
12-24-2010, 02:22 PM
When I first started the game I got pink-screen crashes.

Did some research into the problem, set the program to run in vista (sp2) compatibility mode, run as admin, disabled desktop composition, disabled FFDshow for the fallout3.exe app.

After doing all the above, I actually managed to create a character, get to do my G.O.A.T., and start the 'escape from vault 101' section of the game. But now I can't go 2 minutes without a crash....SOOOOOOOOOOOO frustrated.

Running on a Windows 7, quad-core 3.0 ghz amd cpu with 8 gigs of ram and an ATI 5670 1gb card.

Tried changing up resolutions, messing with individual graphics settings, and now I'm done- what a buggy POS.

Since this seems to be a widespread issue for Steam users buying the GOTY issue, I'm just hoping I can go back to this in the new year when the issue is resolved.

Till then, merry xmas all- I'm off to grab a couple hours of ME2 on Insanity with a big-♥♥♥ sniper rifle and no crashes.

cipher86
12-24-2010, 02:47 PM
Everyone that bought this is a sucker for a good deal. If you had done your research instead of doing an impulse buy, you would have seen that Fallout 3 GotY still has a pantload of unaddressed issues. Don't expect Bethesda to jump on this, and don't expect Steam to give you a refund.

Fool and his money. Lesson learned, I hope.

FazeTwo
12-24-2010, 03:01 PM
Everyone that bought this is a sucker for a good deal. If you had done your research instead of doing an impulse buy, you would have seen that Fallout 3 GotY still has a pantload of unaddressed issues. Don't expect Bethesda to jump on this, and don't expect Steam to give you a refund.

Fool and his money. Lesson learned, I hope.

Looks like the grinch got himself a Steam account.

Merry christmas to you too, pal.

cipher86
12-24-2010, 04:17 PM
Looks like the grinch got himself a Steam account.

Merry christmas to you too, pal.

I understand. You have no recourse with Steam or Bethesda, but you need to vent your frustration on someone. Better a stranger than someone you truly care about.

If you do need some sort of season's warmth from this stranger, I'd say to not let the frustration of throwing money away get in the way of your enjoyment of your friends and family today and this weekend. This shouldn't be a time about spending, or gaming, anyways.

52pickup
12-24-2010, 11:01 PM
When I first started the game I got pink-screen crashes.

Did some research into the problem, set the program to run in vista (sp2) compatibility mode, run as admin, disabled desktop composition, disabled FFDshow for the fallout3.exe app.

After doing all the above, I actually managed to create a character, get to do my G.O.A.T., and start the 'escape from vault 101' section of the game. But now I can't go 2 minutes without a crash....SOOOOOOOOOOOO frustrated.

Running on a Windows 7, quad-core 3.0 ghz amd cpu with 8 gigs of ram and an ATI 5670 1gb card.

Tried changing up resolutions, messing with individual graphics settings, and now I'm done- what a buggy POS.

Since this seems to be a widespread issue for Steam users buying the GOTY issue, I'm just hoping I can go back to this in the new year when the issue is resolved.

Till then, merry xmas all- I'm off to grab a couple hours of ME2 on Insanity with a big-♥♥♥ sniper rifle and no crashes.

But...by the new year school will almost be starting.

D:

Cronjob
01-28-2011, 04:54 AM
Someone mentioned that the response to the "...turn windows features on or off" error is to go into Control Panel and select the "turn windows features on or off" link on the left. Exactly where is this in Windows 7? I'm a unix guy; not a windows guy -- and I don't see anything similar anywhere.

Also, this is occurring after launching the game the first time after downloading/installing (just after it has installed DirectX garbage).

Dzogchen
01-28-2011, 08:23 AM
I've just spent the last 2 days (solid) looking for a solution to the Fallout 3 crash on new game. I've tried every single piece of advice I have come across. I wish I had the energy to name them all. I haven't even got past the menu screen yet. Just downloaded NV and it works like a dream even on high settings with a quad core which was warned about with Fallout 3. The only thing NV has got wrong is predicting my card is an Nvidia GeForce 7900 GS when it is actually an HD 5850 LOL.

Goodbye Fallout 3, hello NV. Although I would love to play Fallout 3 still.

pirox1
01-30-2011, 10:28 AM
holy ♥♥♥♥ guys i think i found a way to fix that ♥♥♥♥♥
http://www.youtube.com/watch?v=c47UXdfWA7s
download the file and put it on the folder where the launcher is (the root folder)
it worked for me so

PizzaSHARK!
01-30-2011, 09:13 PM
Everyone that bought this is a sucker for a good deal. If you had done your research instead of doing an impulse buy, you would have seen that Fallout 3 GotY still has a pantload of unaddressed issues. Don't expect Bethesda to jump on this, and don't expect Steam to give you a refund.

Fool and his money. Lesson learned, I hope.

This. Bethesda is probably the laziest, most inept developer I can think of, with Blizzard a distant second (and at least Blizzard has an excuse.) They have a proven track history of releasing games in partly-unfinished states and they basically let the players fix it all for them - that every single Bethesda game has an Unofficial Patch is a good example of this. When was the last time we saw an Unofficial Patch for Half-Life or Portal?

Bethesda also diluted Fallout gameplay horribly for FO3 (which is why I will never, ever touch NV), which basically demands modding for players wanting an actual Fallout game, not a lousy psuedo-shooter set in the Fallout universe. Modding, of course, makes things even LESS stable.

And yet, I still try to make FO3 work. I just love the Fallout universe :(

zbobg
02-01-2011, 12:55 PM
Someone mentioned that the response to the "...turn windows features on or off" error is to go into Control Panel and select the "turn windows features on or off" link on the left. Exactly where is this in Windows 7?
This works in Win 7 and probably in Vista:

Press the Start button.
Above the button you will see a text box (says: Search).
Type "windows features" in the box (without the quotes).
Look above in the window and you should see the "Turn Windows Features On or Off" link.
Click the link.

woolerland
02-02-2011, 12:51 AM
ig twin 7 64 bit and fallout 3.

i don't sufer crashes but some times when i hold the mouse button e.i. auto fire, it freezes until i release my finger on the mouse.
thing what i found to work is not to have any in game communicaters with it. i.e. steam or xfire. i bought disc version.

Dzogchen
02-03-2011, 04:41 AM
This works in Win 7 and probably in Vista:

Press the Start button.
Above the button you will see a text box (says: Search).
Type "windows features" in the box (without the quotes).
Look above in the window and you should see the "Turn Windows Features On or Off" link.
Click the link.

Tried that ages ago... doesn't work.