PDA

View Full Version : Forgotten Sands Won't Let Me Do ANYTHING


Korn1699
12-20-2010, 06:44 PM
I just bought the deluxe version and downloaded it. When I first ran it, it ran fine, but it looked like the video settings were off. I exited, changed the settings, and started it back up. Now all it does when I run is telling me I'm not connected to the internet after I click play now. I am connected to the internet, and AC2 seems to be working right now too. Any ideas?

Edit: Restarting steam seemed to fix it..

Rad-86
12-21-2010, 02:39 AM
downloaded the game and it tells me im not connected to the internet, wtf.. got my AC2 and Brotherhood for xbox, but with such a low price on steam i wanted to try a game with the idiotic drm, but it doesnt work at all, this is ridiculous, i wasnt expecting anything like that, paying any price for a non working game is not acceptable
..restarting steam didnt work

Korn1699
12-21-2010, 02:53 AM
Do you have AC2 on the PC or xbox? I know that the PC version has the same DRM, but I don't know about the xbox. If this is your first game you tried with that DRM for the PC, maybe the communication to their servers is getting blocked somewhere. I have 3 games that use that DRM, and that was the first issue I ever had with it.

Rad-86
12-21-2010, 04:24 AM
no, xbox versions dont use the drm just uplay.. yes, this is my first game with this drm, because i didnt want to risk exactly this situation for 60€
i got this game through a gift, so i guess refund is impossible, well at least i know that ubi games on pc wont bring us the future, i wont ever buy anything from them
-started working;)