PDA

View Full Version : Potential fixes for three Munch's Oddysee issues.


Bekefel
12-21-2010, 10:11 AM
Crashes: (Patched)

If you still have problems after the patch (such as the game hanging forever), try validating files a couple of times.


Old post:
I know this possible solution has been posted already, but I'll say it again anyway. After validating my files several times, it appears to be fixed. I haven't crashed since, so it's safe to assume this will work for others.

Possible alternate method:

If you get a crash in the Raisin's Cave, just turn on Compatibility Mode for Windows XP Service Pack 2, and Run as Administrator (on Windows 7)

Gamepad movement issues:

The other problem people have been experiencing is with the left stick on the gamepad. It appears as though you can't move with the joystick, only pivot on the spot. This problem was fixed for me when I went into the controls menu and enabled 'Default: Run'. I don't know why this worked, but now I can use the left stick on the controller no problems.

Options > Controls > Keyboard-Personalize > Default: Walk/Run

To enable right stick camera controls*:

Also, if you want to use the right stick on your 360 pad for camera controls, you have to go to "keyboard - personalize" in the control options and map your camera up / down / left / right controls to WASD (keyboard keys).
Yes, this makes absolutely no sense, but it works...

Confirmed that this works. Big thanks to Shpadoinkle.

*Controlling the camera using the right stick seems super important to me.

DPB
12-21-2010, 10:31 AM
Thanks for the controller fix, that did the trick for me. It never occurred me that I'd have to change settings in the keyboard menu to get the controller to work properly.

No luck with the other fix yet, I've validated a few times already (the files seem to need downloading after each crash) but it still crashes.

dsbig123
12-21-2010, 02:07 PM
I can confirm that the run fix works, and for crashes try the compatibly modes

Shpadoinkle
12-21-2010, 02:33 PM
Also, if you want to use the right stick on your 360 pad for camera controls, you have to go to "keyboard - personalize" in the control options and map your camera up / down / left / right controls to WASD (keyboard keys).
Yes, this makes absolutely no sense, but it works...

Frogacuda
12-21-2010, 03:14 PM
Also, if you want to use the right stick on your 360 pad for camera controls, you have to go to "keyboard - personalize" in the control options and map your camera up / down / left / right controls to WASD (keyboard keys).
Yes, this makes absolutely no sense, but it works...

Confirmed.

No luck with the crashes though. I can get out of the cave and past the next gate, but the crash always catches me in the end.

Shpadoinkle
12-21-2010, 03:41 PM
Confirmed.

No luck with the crashes though. I can get out of the cave and past the next gate, but the crash always catches me in the end.

Have you tried fiddling with the compatibility options? If you set munch.exe to Windows XP compatibility, disable visual designs and run as admin, it may help with the crashes. Certainly worked for me, game's running like a Mudokon on Expresso now.

michu
12-21-2010, 03:54 PM
do you play on vista ?

Frogacuda
12-21-2010, 03:55 PM
Well I'm running in Windows XP, so there is no XP compatibility mode. Tried some other compatibility modes and they cause it to freeze rather than crash which forces me to reset my computer, so it's not really an improvement.

But hopefully this helps the developers pinpoint the issue.

Bekefel
12-21-2010, 05:10 PM
Also, if you want to use the right stick on your 360 pad for camera controls, you have to go to "keyboard - personalize" in the control options and map your camera up / down / left / right controls to WASD (keyboard keys).
Yes, this makes absolutely no sense, but it works...

That's an awesome fix. Good find.

Chukkzter
12-21-2010, 05:25 PM
Awesome on the controller! I am not sure if it works as it should now as I never played the game and he seems to walk a bit fast, but at least it works at all. :) Should keep us good until the update.

Trojax2010
12-21-2010, 05:32 PM
Awesome on the controller! I am not sure if it works as it should now as I never played the game and he seems to walk a bit fast, but at least it works at all. :) Should keep us good until the update.

He sure jumps fast too... its a lot easier on strangers wrath with the double jump.

Cameron01
12-21-2010, 09:33 PM
The other problem people have been experiencing is with the left stick on the gamepad. It appears as though you can't move with the joystick, only pivot on the spot. This problem was fixed for me when I went into the controls menu and enabled 'Default: Run'. I don't know why this worked, but now I can use the left stick on the controller no problems.

Thank you for telling me this. It works!

I can confirm that the run fix works, and for crashes try the compatibly modes

You'd have to be more specific with that. I'd like to explain how I did it. The compatability mode I chose was "Windows XP (Service Pack 3)" and I also chose "Run as administrator". These worked for me. May not work for you, however, but that's because you may be using different stuff to me. I'll only share my OS.

My OS is Windows 7 Ultimate 64-bit.

ArmorArmadillo
12-21-2010, 10:49 PM
Controller fix works for me but the game still crashes after 2mins, gonna have to be a patch job for me.

murphen
12-21-2010, 11:00 PM
in regard to the third fix:

when I try to change any key in the key configuration it puts in a "w" as soon as I hit enter. so control customisation is impossible for me atm

Semtex_4
12-22-2010, 03:31 AM
Thnx for the heads up on the controller issue rep+1

michu
12-22-2010, 05:42 AM
so when the problem is only on the first level anybody could upload the sav file after the forest or something ?

Semtex_4
12-22-2010, 06:39 AM
Crashed for me even after leaving the cave....

SpAM_CAN
12-22-2010, 06:43 AM
If you get a crash in the Raisin's Cave, just turn on Compatibility Mode for Windows XP Service Pack 2, and Run as Administrator (on Windows 7)

Toastfarmer
12-22-2010, 06:46 AM
Does anybody have any suggestions as to what I could try to get the videos in Munch to play properly? The initial video that ends with the Gabbits being caught in the net works fine, but any videos beyond that give me audio only against a black screen. The menu option to skip shows up properly when you hit escape.

I also seem to be having an issue I haven't seen mentioned elsewhere - I've attempted to start new games a couple of times and have selected save icons. When I go to load those games, nothing shows up in the list of saved games, but when I go to start a new game, it shows those icons as taken, and warns me I'll be overwriting a save game if I use them.

RobbieNewton1
12-22-2010, 08:45 AM
I can't find an option to change the controller option to Default:Run. I mean, I am happy enough waiting for the patch, since I never properly got into the PC versions of Oddesey and Exoddus, so can play through those and others in the meantime. It's like when GTA: VC and 3 were updated on Steam, everyone had massive problems with them. I too had problems, but I just sat back and played something different whilst I waited.

Bekefel
12-22-2010, 09:10 AM
I can't find an option to change the controller option to Default:Run. I mean, I am happy enough waiting for the patch, since I never properly got into the PC versions of Oddesey and Exoddus, so can play through those and others in the meantime. It's like when GTA: VC and 3 were updated on Steam, everyone had massive problems with them. I too had problems, but I just sat back and played something different whilst I waited.

You need to go into Options > Controls > Keyboard-Personalize then you'll see the option for Default: Walk/Run on the bottom of your screen.

JackRyder
12-22-2010, 09:40 AM
in regard to the third fix:

when I try to change any key in the key configuration it puts in a "w" as soon as I hit enter. so control customisation is impossible for me atm

Unplug your controller, change the the keys and then plug it in again.

murphen
12-22-2010, 09:45 AM
Unplug your controller, change the the keys and then plug it in again.

worked!

Bekefel
12-22-2010, 07:21 PM
Updated original post.

LiqMat
12-22-2010, 07:28 PM
If you get a crash in the Raisin's Cave, just turn on Compatibility Mode for Windows XP Service Pack 2, and Run as Administrator (on Windows 7)

Does not work for me in Vista Ultimate Edition 32. Still crashes.

Bekefel
12-26-2010, 03:04 AM
Pushing this back up because I notice a few new people having these problems. Also, updated the original post.

Amathanio
12-26-2010, 10:20 AM
when I try to change any key in the key configuration it puts in a "w" as soon as I hit enter. so control customisation is impossible for me atm

Unplug your controller, change the the keys and then plug it in again.

I have the same problem. I don't use a controller. Ingame, Abe keeps running because the W is somewhere at all the time active. I use the Logitech G-series. By shutting down the key-profiler, the W wasn't activated anymore so I could configure the keyboard. For playing, i could turn the key-profiler back on.