PDA

View Full Version : this game is horrible - all kinds of display issues


ZioBrad
01-16-2011, 12:01 AM
I have a pretty beastly computer, including a ATI 5870 Eyefinity 6.

At this point it's just like Prince Of Persia the forgotten sands. It's impossible to get the game to go to full screen in any screen resolution including 1920X1080. Instead I always get some kind of warped half screen BS even after changing the settings. It's not even worth $5.00...

If anyone knows how to fix this BS let me know.:o

ArcAngel33
01-16-2011, 01:37 AM
Change the aspect ratio to normal.

basti51
01-16-2011, 05:40 AM
Dude, you spent that much on a "beastly" machine and you can't F**ckin operate it? Did you even build it yourself? Fast computer isn't going to handle every game without proper configuration.

BTW your issue is damn easy to resolve but you should learn how to ask questions.

undauntedspirit
01-16-2011, 07:18 AM
Ha! Major fail.

Beastly "store bought" computer lol

Psycho101
01-16-2011, 08:12 AM
If you're on a 16:9 monitor, choose the Normal setting. If you're on a 16:10 monitor, choose 16:10>16:9 to remove the black borders.

Riddick's aspect ratio choice is the most comprehensive I've ever seen in a game, just try out the settings until you get a correct image.

MADDOGGE
01-16-2011, 08:25 AM
At this point it's just like Prince Of Persia the forgotten sands. Hummmmm me thinks we have operator error here as these two games are not even published or developed by the same companies. PC gaming isn't always plug and play all the time like console gaming is. PC gaming many times requires work on the part of the gamer to get it running properly.

Asking for help instead of having a mini rage and trashing a game that runs for the majority of us just fine is a much more productive use of your time and effort.;)

teroteki
01-16-2011, 09:10 AM
Hmm, not sure if I'm having the same issue as you? The screen violently tears/warps around and it ONLY happens when 1920x1200 fullscreen with crossfire is enabled.
1920x1080 fullscreen w/ crossfire = fine
Windowed mode is fine too.
Tried vsync/refresh rates/ogl tripple buffer etc. and nothing helps
Made a quick recording of it http://www.youtube.com/watch?v=D_Lfp388tuE

Specs:
Win7 x64 /Dual Monitors
5970 @ 1920x1200/Fullscreen/Crossfire Enabled
Catalyst 10.10e - 10.12

EDIT:
Fixed my problem, for some reason Reduce DVI freq. was enabled in CCC :\
Unchecked it and problem solved! http://img51.imageshack.us/img51/2185/reducedvi.png

ArcAngel33
01-16-2011, 09:47 AM
Definitely crossfire related. You could try rolling back to a previous driver, but I'd just disable crossfire for that game. Your 5970 should max the FPS out.

Ghostwriter
01-16-2011, 11:38 AM
Dude, you spent that much on a "beastly" machine and you can't F**ckin operate it?

Nope, Mommy and Daddy spent some credit, and he can't friggn operate it.

titiung1986
01-16-2011, 03:58 PM
take the computer to geek squad at Best Buy, they have awesome technical support, and very affordable too!

I love geek squad!

pocketofskullz
01-16-2011, 06:14 PM
:oROFL! Really Geeksquad!

thelonesoldier
01-16-2011, 09:49 PM
Geeksquad is ♥♥♥♥. I can fix anyone's computer better for a tenth of the price.

titiung1986
01-16-2011, 10:04 PM
you do realize my post was full of sarcasm?

jdhas
01-17-2011, 08:48 AM
you do realize my post was full of sarcasm?

OMG!!1! Infantile sarcasm on teh interwebs! Wot will they think of next?!?!?!

thelonesoldier
01-17-2011, 03:11 PM
you do realize my post was full of sarcasm?

Not until after I posted it, but what I said still applies :P