PDA

View Full Version : Keeping 4.09?


Huesudo
01-19-2011, 05:33 AM
I have the Ultrapack modpack installed. It's great mod, I recommend it to everybody.
It works with version 4.08 or .09, but there isn't a build compatible with 4.10 yet, although UP developers are working on it.

The game version on steam is 4.09, but 4.10 might be released on steam before the 4.10-compatible Ultrapack is ready.
Right now I have 4.09 with the auto-updater disable. But if I have to reinstall the game for some reason, it will force 4.10 in.

Is there any way to choose which version you want to have installed? I suspect not, but it doesn't hurt to ask.

PS: this "version enforcement" is IMO one of the biggest weaknesses on Steam. Sometimes the latest patches have bugs or make savegames become corrupted or (as in this case) are incompatible with mods.
A version selector would be a great feature. I'm not talking about the entire patch history, if you're concerned about Steam fileservers space limitations. I'm talking about keepeng the three last versions available if the latest is problematic.

FA_Bong
01-19-2011, 09:25 AM
If you use JSGME you can put the update in it and switch between the different versions, the steam version of the game is slightly different than the disc version so I'm not sure if you can use an update outside of steam.

Fozzy the bear
01-19-2011, 10:05 AM
What does the Ultrapack do?

Huesudo
01-19-2011, 10:32 AM
What does the Ultrapack do?

Make ALL airplanes fliable, add a lot of new planes, new high-res textures, new maps, new countries, new missions and campaigns.
Those come with the basic ultrapack
Then there are enhanced effects, enhanced weather, enhanced mission builders, 6DOF support, new realistic engine management, new AAA logic...
Those can be enabled individually.

There are more things, but I don't remember them right now.

And finally, no matter what mods you have enabled, you can switch back to the vanilla game by clicking a button, and then going back to the modded version, without having to change any configs.

Huesudo
01-19-2011, 11:02 AM
If you use JSGME you can put the update in it and switch between the different versions, the steam version of the game is slightly different than the disc version so I'm not sure if you can use an update outside of steam.

Hm... changing version... I remember being able to switch between 4.08 and 4.09 on the JSGME menu... but now I can only see stock 4.09.

dannyoftheramc
02-05-2011, 09:58 AM
If you use JSGME you can put the update in it and switch between the different versions, the steam version of the game is slightly different than the disc version so I'm not sure if you can use an update outside of steam.

How did you get JSGME working with il2 sturmovik on steam?

thanks

Huesudo
02-05-2011, 03:03 PM
How did you get JSGME working with il2 sturmovik on steam?

thanks

I just installed the Ultrapack 2.0 from its installer and it just worked.
Wish I could help you a little more. Sorry :(

fearlessfrog
02-05-2011, 07:03 PM
How did you get JSGME working with il2 sturmovik on steam?

thanks

How does it go wrong for you? Can I help?

I run it as admin (win 7 x64) and pointed it at the directory with IL 2 in it (um, program files x86/steam/steamapps/common/IL 2 Stumthingy). Seems to work ok in that after installing ultra pack 2.1 I had lots of things to turn on with JSGME.