View Full Version : X-Com UFO is slow?

01-22-2011, 02:49 PM
I used to have the game on DOSbox separately, but recently bought the Steam Pack.

With Steam, not only is the game limited to a window, but its actually slower than it should be. I'm running Windows 7 and hardware is no issue. Anyone know what could be causing the slowness?

01-23-2011, 12:12 AM
I increased the speed of the game by editing the dosbox confg file. It was a while ago, so you might want to double check this, or wait for someone else do confirm or deny it.

Navigate to ".../steam/steamapps/common/xcom ufo defense" in that folder you will find two files named dosbox, one is an application and the other is a config file. Right click and open the config file with notepad.

You will see a lot of text, and actually it's pretty nice because it tells you what all the fields are for.

Look for a line that says fullscreen, and if it is false then make it true. That should fix the windowed issue.

For the speed scroll down to a line called cycles, and increase the value to increase the speed. Increasing it too much could cause problems though. I have mine set to 16000, and it works pretty well.

Here is and example.
cycles=auto limit 16000

I'm not an expert and I don't claim these settings are optimal, but they work for me. If you are hesitant about changing anything, just make sure you make a copy of the file and put it on your desktop before you change anything. That way if your game is worse after the change and you can't remember what the old values are, you have a copy of the original.

01-23-2011, 03:42 AM
Dosbox allows you to adjust the game cycles during run-time with Ctrl+F11 and Ctrl+F12. You can run the game and adjust them in the game until you find a setting that works well for you.

Once you've found it, note down this value and adjust your conf file accordingly.

If you regularly adjust the cycles in-game, one tip is to also adjust the cycledown=20 setting as well. I find it is easier to fine tune the cycles if it's equal to your cycleup= setting. With its default value of 20, it's dropping cycles down by a percentage, not 20 cycles.