PDA

View Full Version : Game Won't Launch


funkykafka
02-13-2011, 03:39 PM
Downloaded & installed, but won't launch. No pop-ups saying anything, just will not launch. When I tried to launch from my steamapps/common folder I got a pop up that syas I have to download PhysXLoader.dll. Thing is, I have that dowloaded in my steamapps/common files also. Am reinstalling the game now to see if that works. Any help would be appreciated. I would hate to not be able to play this after spending 50 bucks. I have:

i7 860 2.93 GHz, 8 Gigs RAM, ATI Radeon HD 5750 1GB GDDR5 PCI Express.

Pandor29
02-15-2011, 04:43 AM
reboot your pc and try again.

Sami69
02-15-2011, 05:14 AM
http://www.insidetwoworlds.com/showthread.php?t=32123

Colbey
02-18-2011, 09:44 PM
Mine is doing the same tried installing physx and restarting the comp did nothing still wont launch

Draco856
02-19-2011, 06:12 PM
Try updating the graphics driver. Download the latest ATI driver from their site and install it. It fixed mine.

Alinon
02-20-2011, 11:03 AM
I'm having the same issue with Two Worlds 2, although on a 2 week old iMac. I was able to play this last week. Now the icon bounces for a while, then just stops but never loads the game.

z0mbi3guit4rist
02-28-2011, 05:18 PM
Same thing here, I open the game and it just quickly closes. No title screen or anything