PDA

View Full Version : ini editor tweak thread


schism84
02-23-2011, 03:01 PM
As the title suggests, this is a thread for people to share tweak advice and results for various hardware by editing the ini files. Please don't waste space with ranting, there are already a bunch of threads about that.

I've switched mouse smoothing off, increased the FOV slightly to see if it feels better (but just slightly to avoid an awkward tunnelling effect) and I've also uncapped the FPS. I'll let you guys know which exact settings I used and what they changed after I play around with it a bit.

dozerking
02-23-2011, 03:07 PM
With the changes does it redeem itself in the slightest way?

I was just reading about it on Ars Tech and to think the community has to do this really ticks me off. Either way , if it helps get rid of the consolitus , that's great news.

THE Nakedgun
02-23-2011, 03:19 PM
How do you do it? I cant open them without aload of nonsense giberish symbols.

schism84
02-23-2011, 03:38 PM
Google bulletstorm ini editor. It'll open them but filter the giberish. No search function though so you'll have to find the proper lines on your own.

isolated1
02-23-2011, 03:47 PM
where is the storminput.ini file? Its nowhere in my game directory or hard drive.

sekhu
02-23-2011, 03:52 PM
yeah it would help if you let us know what files to edit to make the changes.

I don't have the game yet, wil get it friday, but i'd like to know what to do.

thanks for the help

THE Nakedgun
02-23-2011, 03:52 PM
I got the editor.exe thing, I jsut copied and pasted the text into notepad++ then saved it.
Although there is one file that still doesnt get decrypted.
where is the storminput.ini file? Its nowhere in my game directory or hard drive.

Try in documents
\Documents\My Games\BulletStorm\StormGame\Config

schism84
02-23-2011, 03:53 PM
Ok so, I'm still doing some tweaking with Catalyst, the game settings and the StormEngine.ini file to get the best performance. For me changing the smoothed framerate isn't really useful as I have a 75Hz screen and my computer isn't super powerful. I actually just put it back to default after messing with it a bit.

Mouse smoothing off really makes the game feel better. You can find that in the StormInput file, bEnableMouseSmoothing=true. Just change it to false, obviously. Tada, normal PC shooter mouse!

I also changed the FOV by adding 10 to the initial values for FOV and aiming FOV. They're originally set really low which gives the game a bit of a claustrophobic GoW feel. It's a design choice but I feel like increasing it slightly is more comfortable. You should just mess around with it on your own to find something that you like. It will vary from person to person. I find 95 to be a good compromise between the style they designed and what suits me, without distorting the image too noticeably. Btw, you can find this in StormCamera, you'll find a pragraph for FOV settings. It's a short file anyway.

Everyone should turn vsync off, it pretty much locks the game at 30 FPS, and I believe that's even with smoothed framerate off. The game really doesn't need it anyway, I haven't had any noticeable tearing. On my rig, the game runs fine in 16/10 format and switching it to 16/9 doesn't do anything for performance. For those with VERY low framerate problems (some Nvidia setups), you should try it though.

Personally I run the game on this config:

2.4Ghz DualCore CPU
HD5770 1GB GPU
3GB DDR3 RAM
Win 7 32bit

Nothing fancy but not the worst setup either. I have a pretty small screen (19") with a max resolution of 1440*900. The game ran pretty well but I lowered it to 1280*800 for smoother performance. Overall I get a satisfying and beautiful result with everything on High, no AA and no Vsync. Switching textures to Medium instead of High will give you a noticeable increase in performance if you need it and it doesn't look too bad.

The one thing I really haven't solved, as in nothing affects it, is the random stutters. The game just seems to struggle during prerendered/scripted events. I'm now 90% convinced that it's a coding issue and absolutely unrelated to graphics, possibly even an i7 or Phenom wouldn't fix it on the CPU side.

Hope those few things were helpful and feel free to post your own attempts, successes and failures. Btw, it's already been posted several time in other threads, but you can find the basic changes here:
http://arstechnica.com/gaming/news/2011/02/bulletstorm-and-you-how-to-get-it-playing-nice-with-your-pc.ars

schism84
02-23-2011, 03:55 PM
I got the editor.exe thing, I jsut copied and pasted the text into notepad++ then saved it.



Try in documents
\Documents\My Games\BulletStorm\StormGame\Config

This. (durrrr at notepad++, didn't even occur to me)

schism84
02-23-2011, 03:58 PM
@ dozerking:

well you can change FOV to your liking, uncap the FPS and get rid of mouse smoothing. You can't get rid of GFWL, for those who are really allergic to it.

Other than that you can make it feel like a real PC game with just a few tweaks. Ok no mouse in menus and awkward "left weapon" will still feel a bit off, but that's not exactly intolerable either.

I enjoyed the game a lot, I do even moreso now that the mouse feels like it should.

Exinjeru
02-23-2011, 04:02 PM
The stuttering is it stream-loading the game. Consoles do this, PCs don't like to. It's a main indication when a game is a lazy console port. It's a thing with Unreal Engine and consoles.

schism84
02-23-2011, 04:06 PM
I figured that it's likely something like that. Do you know if Just Cause 2 did something similar? Because that is one stellar example of a beautiful port.

If it's an inherent console UE related problem it probably won't get fixed, which sucks. It doesn't effect the game all that much but it's distracting and could've been avoided altogether.

schism84
02-23-2011, 07:56 PM
So after messing around with stormengine.ini and looking around the internets for others who had too, I have the following suggestions:

-bUseBackgroundLevelStreaming=False (instead of True)

This will get rid of the stutteriness entirely for cutscenes and noticeably in general. The game will load in one chunk instead of streaming. Expect a freeze for a couple of seconds while it does this, but after it won't stutter once. You can try it and compare the results on the intro chapter, when you break into the building and Ishi gets shot at. Also on the part where Gray flies through the Ulysses. I know those are parts where I had noticed some really nasty clunkiness and this entirely solved it.

-bUseTextureStreaming... Well sorry, you'll have to leave this one as True because otherwise the textures are all broken. Further in the ini you'll have a short block dedicated to this though. Increase the pool size to 320, you can even go up to 420-450 if you have a lot of Vram. This will increase the streaming buffer significantly and you'll see a very obvious (and very nice) improvement.

With these two tweaks the game is now (almost) stutter free. Only noticeable annoyance is a brief freeze at the beginning of prerendered cutscenes.

You can experiment with the other things in there, such as turning on AmbientOccularLighting, hardware improved shadows etc. Just don't forget to make a backup in case you do something game-breaking. I tried turning on the high quality mode but it instantly crashed. I was just curious. You'll notice a line to allow DX10 but AFAIK the game doesn't have any DX10 assets, I'm guessing it's a vestigial line from the usual UE code, or something for later implementation.

I strongly suggest you go towards the end with the list of movies and get rid of the logos (first one in the list). You'll really be glad you did after you start the game a dozen time to try out tweaks ;)

GrimCW
02-23-2011, 07:58 PM
I was just reading about it on Ars Tech and to think the community has to do this really ticks me off. Either way , if it helps get rid of the consolitus , that's great news.

FYI welcome to PC gaming.
nothing new here, its the same as it was 20 years ago, the community fixing/adding to the game post release.

Bozebo
02-23-2011, 08:05 PM
Just as a note, tweaks for bioshock and mass effect will also probably work to some degree in bulletstorm. Especially when it comes down to mouse input.

If all it takes to fix the mouse is edit an ini file why couldn't the devs do that before finalizing the game for release? pssht.

I might get this one when it's on sale later

GrimCW
02-23-2011, 08:08 PM
If all it takes to fix the mouse is edit an ini file why couldn't the devs do that before finalizing the game for release? pssht.


because they were to busy encrypting the ini files instead to prevent us from doing it ourselves :p

schism84
02-23-2011, 08:20 PM
The mouse smoothing might be a ♥♥♥♥♥♥ move to make sure PC players with superior controls don't take over all the leaderboards, what with it being GFWL and sharing them with XBox360 players... It's still completely ♥♥♥♥♥♥♥♥, but at least it's fixed in a matter of seconds.

With the fixes I mentioned in the very beginning and the ones I gave above for the streaming, the game really feels like a good PC game now. It didn't take much, as in my opinion it's an excellent game at its core.

Exinjeru
02-23-2011, 10:26 PM
GFWL shares nothing at all with xbox live. They were going to originally, but they realized it'd never work and no one wants GFWL so they've basically abandoned doing anything with GFWL except find ways to have it sell games like steam.

schism84
02-24-2011, 07:57 AM
Bumping this up. Also, while I haven't found anything new really since I last posted, I suddenly have a new odd problem. Everything runs smooth and better than before (the game wasn't broken on my rig, but could used some improvement which I described) but I now have a slight broken shadow problem.

Environments looks great, ambient occlusion works fine, even bloom activation adds a (slightly noticeable) touch. But the direct shadows on weapon (also seen on characters in the main menu) are flickery and blocky at certain angles. From what I could tell, it's only from direct outdoors lighting hitting the asset, such as their suns.

Light shafts doesn't change anything, ambient occular either, nor does bloom or messing with the various shadow parameters. I have no idea what's causing it and it wasn't around before. It's literally the ONLY problem I have and it's not a big one, but it is distracting.

So, major fixes for major NVidia broken engine problems aside, has anyone found what specifically causes only this one blocky flickery direct shadow issue? I'll try downgrading my display drivers and then reinstalling the new ones if that doesn't fix it.

As an aside, if you ever screw up in the StormEngine file, you can delete it along with stormcompat from the documents/my games folder. When you relaunch the game it'll reinitialize and recreate these based on the defaultcompat.ini located in the game's program directory. It's convenient if you just want to reset the engine to mint condition.

THE Nakedgun
02-24-2011, 12:20 PM
Anyone else having problems with the .ini being overwritten?

schism84
02-24-2011, 01:18 PM
Which one? StormEngine?

When you manually change things in the Settings section, DO NOT change the settings in-game. As the basic in-game controls govern a wide variety of functions, this will overwrite some of your parameters, like bloom, ambient occlusion etc. If you set DX10 to be True, you will have to reconfigure in-game, close and relaunch though.

THE Nakedgun
02-24-2011, 01:24 PM
No I just do the tweaks save it but the tweaks dont show ingame vsync is still on etc I have not touched anything in the settings in any menus.

schism84
02-24-2011, 01:34 PM
That's pretty damn strange... Have you tried changing settings in-game (such as vsync) to see if it registers in the engine ini once you close it? Not what you want to do, but it'd be good to see if it actually works.

krameriffic
02-24-2011, 01:38 PM
Turning off mouse smoothing turned it into a completely different game for me. Also, raising the ADS FOV made it easier for me to control the mouse while aiming. Without a sensitivity reduction, zooming in really far makes the mouse feel way oversensitive.

But more than anything, you absolutely have to turn off mouse smoothing.

schism84
02-24-2011, 01:42 PM
Definitely mouse smoothing needs to be turned off, no question there. I've found you can increase FOV to about 100 from the original 85 without warping the image too noticeably (I personally use 95). And yeah, agree on the aiming FOV as well (if that is what you meant).

ironhorseUSMC
02-24-2011, 02:06 PM
anyone found a way to turn down the sensitivity when aiming down the sights? its far too sensitive. in fact, its an increased sensitivity from what you use without aiming.. which is weird, should be opposite.

JK_DC
02-24-2011, 02:08 PM
I upped the aiming FOV to 50. That is the only way I found so far to alter it. There might be a ADS sensitivity setting somewhere.

ironhorseUSMC
02-24-2011, 02:09 PM
I upped the aiming FOV to 50. That is the only way I found so far to alter it. There might be a ADS sensitivity setting somewhere.

its unrelated to FOV, i've decided, after some careful observation.

JK_DC
02-24-2011, 02:12 PM
Have you tried 80? It might zoom it out enough where sensitivity wouldn't be too bad.

schism84
02-24-2011, 02:41 PM
I'm fine here with +10 to standard FOV and aiming FOV. The overall mouse sensitivity should definitely be set very low in the game menu.

By the way, I have FINALLY solved my flickering weirdo shadow problem. Set World Detail to Low, voila! Completely gone and to be honest, try as I might, I can't even see the impact of that setting in-game. I haven't had the patience yet to find what it alters in the engine file so I could experiment and find WHICH parameter causes that bug.

So I now have a very stable and functional game with no bugs whatsoever. Here is what I modified:

-upped FOV as well as aiming FOV by 10 pts
-deactivated mouse smoothing
-deactivated bakground level streaming
-upped texture streaming pool size to 320 (originally 150)
-D3DDX10 activated, but I can't see a difference to be honest

The game is set to 1280*720 (I have a 1440*900 sceen) with everything on High except World Detail on Low, Vsync OFF, no AA (I force it to 4x with Catalyst).

Now runs perfectly on my weak dualcore rig with ATI HD5770. Only thing I notice is some textures are pretty ugly up close but that might just be the game itself. I tried to activate max quality mode but it just crashes my game so I can't tell you if it fixes that. Might just be that the game really has some ugly textures up close. Overall though it all looks very nice when you're playing instead of staring at a piece of wall.

LordGurciullo
02-24-2011, 05:05 PM
It is insanely pathetic and horribly disgusting to me that they just didn't let you mess with the config.

If they INSIST on being cheap about making a proper port. ATLEAST let us tweak a few things.

Changing True to False on mouse smoothing (cause they didn't add it as in-game option) changes the game ENTIRELY.

Yet they still don't let you access it?

It is starting to seem like a anti-pc conspiracy. Like they are Purposely trying to kill pc gaming. WTF.

schism84
02-24-2011, 05:12 PM
The CEO of PCF recently stated that they should have made things like FPS cap and mouse smoothing non-crypted and are thinking of including that in a patch.

They crypted the .ini files to avoid jerks modding the game balance and breaking the leaderboards. Of course we can see how effective that was, as it took less than 48hrs for people to do that very thing and brag about it on this forum.

Yes it was dumb for sure, but they have very quickly publicly stated that they should have been selective with encrypting instead of just doing it for the entire batch of .ini files. At least it seems like they are listening to feedback and answering promptly, that's a rather good sign.

THE Nakedgun
02-24-2011, 05:32 PM
I managed to bind F12 for screenshots
I also managed to make a bind to record a demo but its not much use since I cant play it back binding a key to playdemo 123 doesnt work.

Exinjeru
02-24-2011, 05:37 PM
There's a series of shadow options for UE3, bad console ports always set them all to off, but most videocards don't like that. It basically destroys shadow effects.

Look in the Engine.ini and find a list of shadow related options all together all set to FALSE. Turn them all to TRUE. It doesn't effect performance on most computers and shadows should display right now.

Bulletstorm also seems to have the same problem as Black Ops where it's just not using videocard resources properly. The Compat.ini has hardware settings, but is mostly copy/pasted default values. I corrected my hardware settings there and the game stopped loading bad textures and such.

Lazy broken port, glad I got it for 50% off.

schism84
02-24-2011, 05:41 PM
For shadows, are you talking about enabling hardware shadow processing and improved shadows? There are A LOT of shadow parameters and they are all over the place in the System section.

Btw, I'm not even completely sure it's shadows and not some actual texture bug relating to lighting as all shadows work perfectly fine except that one thing. Btw, messing with shadow settings in the ini, I didn't get any fixes. The only thing I found was the world detail setting in-game that instantly fixed it.

For the hardware settings of the compat file, would you have a source to use to correct those?

schism84
02-24-2011, 06:00 PM
Well I tried tweaking the settings in the compat for my GPU to something closer to reality, mostly upwards as like you said a lot of it is really low by default. Still didn't fix the artefacting. Only fix so far remains Low World Detail. I'll see if it improves textures though.

Exinjeru
02-24-2011, 06:07 PM
you might be having a unique shadow problem, I had the problem most ATI users do of shadows being fragmented all over the place. The maps completely broken.

schism84
02-24-2011, 06:12 PM
I just get glitchy flickery black shadows on gun/hand (also visible in the title screen) depending on the angle of light. I'm tweaking the LODbias for some parameters in the engine as well as resolutions etc right now. I'll let you guys know if I find a fix or stumble into something that significantly improves the game.

Exinjeru
02-24-2011, 06:27 PM
An improved compat.ini http://www.megaupload.com/?d=6KKC97RN could fix serveral issues.

shadows would be
bEnableBranchingPCFShadows=True
bAllowHardwareShadowFiltering=True
bAllowBetterModulatedShadows=True
bEnableForegroundShadowsOnWorld=True

you can also optionally throw on
DynamicLights=True
DynamicShadows=True

schism84
02-24-2011, 06:43 PM
Hey thanks for that man, I changed that little block and it makes things a bit nicer in-game.

I've found the exact parameter that fails on my end btw. It's DynamicShadows. So if I turn it off, I don't get artefacts but characters don't project shadows (well they project a silly looking circle one at their feet, oldschool style). If I turn it on, everything looks great except I get some distracting texture/shadow artefacting on the foreground objects. I don't have a capture to show, but I'm sure you can imagine what it looks like, that kind of bug has appeared in many games before.

It's not game-breaking, but distracting and stupid. DynamicShadows is such a basic feature nowadays, it's weird to play without and silly to have bugs with it on.

Any ideas on what could cause that?

I posted my specs earlier, but FYI I have a HD5770 with latest drivers.

JK_DC
02-24-2011, 06:49 PM
I believe foregroundshadowsonworld projects that blob. I have it turned off.

schism84
02-24-2011, 06:53 PM
I already had it turned off actually, I just turned it on now to see if it affects projecting your own shadow into the environment, which the engine doesn't seem to do.

I'll double check, but I'm pretty sure it isn't that. Btw the blob shows up on the visible part of the character/weapong itself but nowhere else in the world.

PurpleHaz3
02-24-2011, 07:00 PM
I just get glitchy flickery black shadows on gun/hand (also visible in the title screen) depending on the angle of light. I'm tweaking the LODbias for some parameters in the engine as well as resolutions etc right now. I'll let you guys know if I find a fix or stumble into something that significantly improves the game.

I'm having the exact same problem on the exact same card, shadows are glitching out on the main screen on the characters.

Mplayer OG
02-24-2011, 07:05 PM
Here's a new one: Anyone know if there's a way to increase the weapon firing sound(s)? I mainly want to up the stock assault rifle as it sounds like one of those dinky airsoft guns at the moment. I've found some audio parameters in a few of the ini's. Not sure if this is viable or not.

GlobalFiringVolumeMultiplier=1
FireAudioComponentNumber=2

are the only 2 that seem worth looking at so far. Not sure exactly what messing with them does, though I will certainly check when I make it back home tomorrow.

schism84
02-24-2011, 07:05 PM
Glad to see we share the same problems lol. Only fix I've found so far is disallowing dynamicshadows. It's not foreground shadows on world, or foreground self-shadowing. It's not bloom either, or light shafts. I have no idea why dynamic shadows would cause this or what other sub-shadow thing (min/max resolutions?) could fix it.

Well we can be glad it's the only glitch we get as it's super easy to fix, and it's not really awful to deal with it and get all the dynamic shadows as a trade-off. I'm still looking into it though.

As an aside, has everyone also noticed a lot of the environment textures are pretty low-res and muddy up close? Is it inherent to the game, in which case I can live with it and the game still gives off a great overall visual style, or is it something that can be fixed? I've seen the similar "crude" look in other UE games so I'm guessing it's just an inherent quirk.

Mplayer OG
02-24-2011, 07:13 PM
Glad to see we share the same problems lol. Only fix I've found so far is disallowing dynamicshadows. It's not foreground shadows on world, or foreground self-shadowing. It's not bloom either, or light shafts. I have no idea why dynamic shadows would cause this or what other sub-shadow thing (min/max resolutions?) could fix it.

Well we can be glad it's the only glitch we get as it's super easy to fix, and it's not really awful to deal with it and get all the dynamic shadows as a trade-off. I'm still looking into it though.

As an aside, has everyone also noticed a lot of the environment textures are pretty low-res and muddy up close? Is it inherent to the game, in which case I can live with it and the game still gives off a great overall visual style, or is it something that can be fixed? I've seen the similar "crude" look in other UE games so I'm guessing it's just an inherent quirk.

Those "glitchy" shadow issues are inherent to the ATi series gpu's. Same thing on most UE3 games on both my 4850's and my new 5770.

The low-res looking textures are also part of the package it would seem. They serve their purpose given the scope of the levels, but I'm betting the dev's were banking on the speed of the action and linearity of the game would distract people from wall-gazing too much. Like you said, I can certainly live with it.

schism84
02-24-2011, 07:17 PM
Well considering the nature of the gameplay and the excellent postprocessing and backdrops, yea I don't really mind muddy textures on the environment either.

FYI I've used the improved defaultcompat.ini to absolutely no avail. It seems some ATI cards are doomed to glitch with dynamic shadows... At least until a patch or future driver corrects it (it's not unheard of).

I didn't have the problem in ME2, Bioshock or Arkham Asylum though. I just remembered that glitch from further back than that.

schism84
02-24-2011, 07:50 PM
Well, I thought maybe deactivating foreground self-shadowing would to the trick (considering that blockiness depends on the angle of light and it looked like self-shadowin), but no dice. I guess we'll have to live with slightly distracting artefacts, or no dynamic shadows.

As an aside, I did find something hilariously quirky. If you activate foreground shadows on world, you'll enjoy the shadow of a pair of arms carrying a gun following you everywhere you go. I can understand why they set that to False, but it's still funny if you want an imaginary friend who's a pair of arms. Also, he's invisible.

I think allowing ATI texture filtering (and setting the appropriate parameters in CCC) improves the textures somewhat. They'll still look muddy though. Then again, it's late and I've been staring at shadows and pieces of wall for quite a while, so don't take my word for it.

GrimCW
02-24-2011, 08:03 PM
As an aside, I did find something hilariously quirky. If you activate foreground shadows on world, you'll enjoy the shadow of a pair of arms carrying a gun following you everywhere you go. I can understand why they set that to False, but it's still funny if you want an imaginary friend who's a pair of arms. Also, he's invisible.

tbh i find it quirky that they have your legs visible only during context actions but never otherwise.
they really should've chosen one or the other, legs/body, or no legs/body.
its really odd to see them magically pop in/out.

schism84
02-24-2011, 08:09 PM
It's a bit weird by today's standards that they didn't include the character into the world, per se, as it's become sort of a standard in terms of projecting shadows etc. Crysis and FarCry 2 pushed the envelope a bit more as well. To be honest though, I absolutely don't mind. I hadn't even noticed the appearence of the magical legs, except during slides of course.

All these things aside, stylistic choices, day 1 bugs and tweaks you have to do manually, can we all agree this game is immensely fun? I guess we wouldn't be here trying to optimize how it runs if we didn't plan on playing it a lot :) For me, this game scratches the itch I had in just the right way while not feeling like something recycled from games I missed.

helmutcheese
02-24-2011, 08:23 PM
I have edited the "config's" to use hardware PhysX after placing the newer (so it claims on website I Googled for info) Nvidia PhysX files into games older PhysX folder inside the game as it claims they are outdated for some peeps getting PhysX error at load, funny thing is the latest Nvidia files are dated 2009 !

I read enabling hardware PhysX can cause Windows Live to not load so that is why I swapped the files over also.

The game ran with PhysX CPU on indicator before and after editing it changes after a few seconds to PhysX GPU so I guess it actually works !

FOV gives me a sore head even though its 85 which should be correct for Horizontal FOV on 16:10 display !

schism84
02-24-2011, 08:32 PM
The game is very fast paced and the running/sliding makes the FOV weirder. I've found it hard to play the game in long spurts. There's no way in hell I'd complete it in one sitting. I find 95-100 to feel a bit better. You should experiment and see what works best for you.

About the Nvidia stuff, yeah I saw mentions of that elsewhere as well. Couldn't test it myself as I run ATI. Good to know it works!

Exinjeru
02-25-2011, 02:04 AM
The muddy textures are a bug. The game will load textures properly if you mess around with the configs correctly. It's not something you have to just settle with because you have an ATI card. It's the developers fault.

schism84
02-25-2011, 02:12 AM
Any idea of what to actually mess around with? :) Thanks for letting me know but it'd help if you had some insight.

Btw, I've seen tons of NVidia users complaining of really poor textures (among much more serious graphics bugs), I don't think it's an ATI thing. So far it seems the only ATI specific problems are diagonal line due to light shafts, and the glitchy flickery dynamic shadow glitch on foreground.

dazman76
02-25-2011, 03:10 AM
Just a quick post to say thanks guys - for providing these tweaks and helping us all out :) Seems my game is locked until some point later today, but as soon as it's ready I'll be following these guides before my first play.

Thanks for taking the time to do this :)

schism84
02-25-2011, 04:14 AM
Well I wish I didn't have to write this AGAIN, but I lost connection just while posting it so here goes. Apologies in advance if I half-♥♥♥ it a bit. I'll try to sum up all of the known things I have scrounged around this forum and elsewhere.

What everyone should do unless everything works like a charm (golden rule of tweaking: if it ain't broke, don't fix it):

-download the modded defaultcompat.ini here: http://www.megaupload.com/?d=6KKC97RN

-go to documents\my games\bulletstorm\config and delete both stormcompat.ini and stormengine.ini (obviously make backups any time you mess with ini files)

-go to your steamapps\common\bulletstorm\stormgame\config directory and replace defaultcompat.ini with the one you downloaded

This will change the default GPU setups in the game to more realistic (less pathetic) values. Also it will add some models to the lists available which is a good thing if yours happens to not be in there. When you launch the game it will automaticly regenerate the files you deleted earlier based on the info it gets from this one.

From here on out, all fixes will be made to the .ini files found in the bulletstorm directory in your documents.

Now, let's make this feel like a PC game:

-open storminput.ini and disable mouse smoothing (OH YEAAAAH).

-open stormengine.ini and in the early part of the file (15% down or so) disable background level streaming

-further down in that file you'll find a block about texture streaming (40%-50% down or so). Leave streaming enabled or you'll break the textures, but increase the pool size to 320.

-this one is entirely optional. If the field of view feels weird to you, you can modify it (as well as aiming FOV) in stormcamera.ini. You can add 10-15 pts to the base values without the image getting too deformed. Tweak and experiment to your liking.

Tada, now this game mostly runs like a PC game with a normal mouse and the stuttering in random places (such as scripted events and level starts) that many experience are reduced to a bare minimum, possibly eliminated.

Now, onto the fun part. BUGS:

-Nvidia users, particularly GTX4xx owners, if at this point you are still getting godawful graphics, open stormengine.ini. a bit past half way down you'll find a big block called System. Enable max quality mode. You'll probably need to set postprocessing to low after this, but it fixes the really resilient glithces (at least usually)

-ATI users getting a diagonal line artefact across the screen, in stormengine.ini, System section, disable light shafts. No more god beams, but no more artefact

-ATI users getting a flickery ugly artefacting on the foreground (gun and hands) when in direct sunlight, depending on the angle of lighting, disable dynamic shadows in stormengine.ini, system section. No more dynamic shadows, but no more distracting glitch. Up to you to decide which compromise you prefer

Now on to suggested ways to improve the game.

-it is capped at 62 FPS with framerate smoothing (typical of UE3 engine). You'll find two occurences of that in the beginning of stormengine.ini. If you are unhappy about that, either set the max value to something higher, or just disable framerate smoothing altogether

-the game tends to hate 16:10 resolutions (it will underuse CPU and GPU). It's strongly advised that you use a 16:9 resolution instead unless, of course, your framerate is to your liking

-in-game AA is very demanding. It's preferable to leave it off and manually force it from your GPU control pannel

-turn vsync off (available in-game). It tends to tank framerates and this game doesn't need it anyway

-some users have reported that SSAO (ambient occlusion) heavily pulls down framerates. If you want to gain some FPS, you can try disabling it in the system section of stormengine.ini and enabling bloom (if it isn't already) to compensate for the loss in postprocessing polish

For now, that is all I can think of. Sorry if I don't quote the exact command lines which is way more convenient for people with notepad++ who can then just search directly. I just didn't have the courage to look for them again and I'd prefer not misquoting one. I hope all this helps you get the game running to your liking. Please continue sharing your own findings and problems!

THE Nakedgun
02-25-2011, 06:24 AM
Those streaming options do nothing i still get stutters.

I set my ini to readonly so I donthave to keep decrypting them.
The Compat.ini inside ther there is headings such as [AppCompatBucket4] is this related to DetailMode found in the engine.ini?

schism84
02-25-2011, 06:32 AM
bUseBackgroundLevelStreaming = True >> set fo False

This fixed most of my stuttering for scripted/prerendered sequences (such as in the intro, crashing into the Ulysses.

for the other, search "poolsize" which should show up as poolsize = 150 for texture streaming. It's a common problem with UE games that this is set too low. It was 80 on Arkham Asylum and causes texture pop-ins. 320 seems to work well (I haven't seen anyone reporting problems with it for UE games). This should eliminate slight pop-in if you have it and reduce chugging at the very start of loading an environment. I know I could tell the difference.

schism84
02-25-2011, 06:35 AM
Btw, absolutely none of these fixes and tweaks are guaranteed to solve what they should for everyone and obviously, always backup everything.

I've got the game to run a lot better on my system but I still have some crude textures and dynamic shadow glitches (as I've described in the thread). Seems these two are common for ATI, particularly HD5770. One way or the other, the game will need a driver fix from both NVidia and ATI or a competent patch from PCF (yet better, both).

TetraNitro
02-25-2011, 07:44 AM
Is there a way to edit the INI files without downloading a shady executable file that originated on some Russian website? I know people say it's 'clean', but I have my doubts.

I'm also curious because I'm almost positive that as soon as they patch the game, the INI tweaks will be reverted instantly - Just like what happened with Borderlands.

schism84
02-25-2011, 07:51 AM
There's another possible way by decrypting and reencrypting with another exe. (needs latest .Net framework). I don't have a link handy though... And well, we're talking about makeshift tweaking here so it's not gonna be any more official than this method.

Your worries about patching the game destroying the tweaks are probably well justified. You could disable auto-update until you get feedback on updates though.

TetraNitro
02-25-2011, 07:55 AM
There's another possible way by decrypting and reencrypting with another exe. (needs latest .Net framework). I don't have a link handy though... And well, we're talking about makeshift tweaking here so it's not gonna be any more official than this method.

Your worries about patching the game destroying the tweaks are probably well justified. You could disable auto-update until you get feedback on updates though.

Good point about disabling auto updates, I'll have to do that.

Yeah, since there was some mumbling from the developer about splitting the INI files into encrypted and non-encrypted versions, I'm pretty such whenever they do that it'll hose all our settings.

schism84
02-25-2011, 08:29 AM
It might yeah. Will make things waaaaay more convenient for us though.

Surfing Bird
02-25-2011, 09:45 AM
Am I the only one with just Basic*.ini and Default*.ini files? I can't find anywhere the infamous Stormengine.ini file.

schism84
02-25-2011, 09:46 AM
the files to tweak are in documents\my games\bulletstorm, not in steamapps

PurpleHaz3
02-25-2011, 01:23 PM
schism84, you have officially made my game run MUCH MUCH better and smoother than it ever was without these .ini changes. I can actually play an entire Chapter with little to no stuttering, its almost like a whole new game.

One really odd thing I found out about AA still confuses me. If you use the in-game anti aliasing and vsync, you loose triple-buffering, which means either 30 or 60 fps.. no where in between. Oddly enough, if I force 4x AA in the CCC, and enable the in-game anti aliasing, it actually performs better, and enables triple-buffering.

DeepBlue
02-25-2011, 06:38 PM
Is it normal that using this customized DefaultCompat.ini sets Shadow Quality to low? Cause i set all to high before and after applied this "PC patch" it was set to low in the options menu.

I didn't change it, cause i guess its just a result of the custom lightning values and the settings aren't really low.

schism84
02-25-2011, 08:43 PM
Yea it will set your shadows to low. Not a big deal though. And everyone should keep in mind none of these changes have to be permanent if you make proper back-ups. If push comes to shove, you can always redelete stormcompat and stormengine, replace defaultcompat with the mint one (that you intelligently backed up) and launch the game. Tada, vanilla Bulletstorm again.

@ PurpleHaz3: glad it helped :) Btw, you shouldn't use the in-game Vsync unless you really need to. It tends to lock the FPS at 30, or do that wonky thing you described.

schism84
02-25-2011, 09:20 PM
Bumping this up because people are reposting the exact same threads about the exact same bugs, since apparently nobody knows how to read and search before posting. Google must be a challenge.

MegaPigeon
02-25-2011, 09:29 PM
Is there any potential way to fix the GFWL issues with the ini files? I'm guessing the PhysX file swap might be the cause but there's no real way to be sure.

I should also point out that my Ini files are basically displaying as wingdings and gibberish at the moment. I take it that's not a good thing?

Exinjeru
02-25-2011, 09:30 PM
The Compat.ini is what fixes muddy textures for a lot of people because they halfassed it and in most cases it's assuming your videocard has never heard of vram and gives it bad textures to patronize it.

schism84
02-25-2011, 09:31 PM
It's normal, they're crypted with a pretty basic cypher but unusable without a tool. If you look up this thread you'll find links to a specific ini editor some kind folks made for us. From there it's very easy to edit them (even easier with notepad++).

schism84
02-25-2011, 09:32 PM
Btw, as of now, I still haven't managed to fix the HL1 looking textures and dynamic shadow glitch on 5770 ATI cards (such as mine). I think it'll take a driver update or a patch.

MegaPigeon
02-25-2011, 09:47 PM
Notepad++ is still showing everything as gibberish. The Ini Editor works, but the fact I can't search for specific phrases makes it a bit useless at the moment.

schism84
02-25-2011, 09:54 PM
If you search the webs, there's an exe that allows you to decrypt/re-encrypt the files, provided you have the latest .Net framework. I don't have a direct link handy though. That should allow you to search and copy/paste with notepad++

That being said, I pretty quickly got used to where everything I need to tweak is ;)

MegaPigeon
02-25-2011, 09:58 PM
I fixed the Physx problem through the Ini editing method (does this enable or disable Physx?), but I still can't sign into GFWL.

Crap.

I really hate to sound like such a tool considering how I've never had an issue with it, but GOD DAMN GAMES FOR WINDOWS.

schism84
02-25-2011, 10:00 PM
I use an ATI card so I don't have direct hardware PhysX. I can't really directly help you on that :(

schism84
02-25-2011, 10:01 PM
Donwloading the GFWL marketplace client and using it before you launch the game doesn't help? I know it occasionally won't sign on for me but other than that it works.

MegaPigeon
02-25-2011, 10:03 PM
Nope. I've tried it quite a few times now.

schism84
02-25-2011, 10:11 PM
If your game isn't registered yet, you could try making a new account I guess... I know it sounds stupid but who knows with GFWL voodoo. Can you even log onto Marketplace at all?

MegaPigeon
02-25-2011, 10:15 PM
The problem I'm having is that the overlay simply doesn't appear at all. There doesn't seem to be any sort of fix for it. This is incredibly annoying, as I've had to wait until the evening just to download the game, and haven't even been able to play it with no real hope in sight for the near future. I just as easily could've got the game down the street in a box, possibly without these incredibly annoying issues :/

schism84
02-25-2011, 10:19 PM
If you did, you'd still have GFWL with it though. I wish I could help... Maybe you should try a fresh reinstall of drivers (particularly physx) and the game. I know it's a huge hastle since to reinstall via steam you'll need to delete and redownload local content...

When all else fails ... try that and watch it fail :)

schism84
02-25-2011, 10:21 PM
Hey, looking down the forum I found someone posted this :

guys if games for windows live doesnt appear close bulletstorm goto the bullstorm folder
Quote:
C:\Program Files\EA\Bulletstorm\Binaries
goto win32 or win64 or something for 64bit
and search for xlive.dll and delete it then run battlestorm again and you should see GFWL

Maybe it helps :)

MegaPigeon
02-25-2011, 10:25 PM
File doesn't seem to exist with the steam version :/

schism84
02-25-2011, 10:27 PM
Heh good point, I don't have it either :)

Exinjeru
02-25-2011, 11:30 PM
Man up and read the entire ini file like it's 1995.

You must be at least this manly to play bulletstorm.

schism84
02-26-2011, 12:48 AM
bumping this up

DeepBlue
02-26-2011, 12:50 AM
Notepad++ is still showing everything as gibberish. The Ini Editor works, but the fact I can't search for specific phrases makes it a bit useless at the moment.

You can Copy & Paste the content from the ini editor in any editor you like. After you made your changes you can copy it back.

Wazgrel
02-26-2011, 02:28 AM
Man up and read the entire ini file like it's 1995.

You must be at least this manly to play bulletstorm.

Didn't help me with my fps issue. Waiting for patch. :p

WastedJoker
02-26-2011, 02:41 AM
-download the modded defaultcompat.ini here: http://www.megaupload.com/?d=6KKC97RN

-go to documents\my games\bulletstorm\config and delete both stormcompat.ini and stormengine.ini (obviously make backups any time you mess with ini files)

-go to your steamapps\common\bulletstorm\stormgame\config directory and replace defaultcompat.ini with the one you downloaded

This will change the default GPU setups in the game to more realistic (less pathetic) values. Also it will add some models to the lists available which is a good thing if yours happens to not be in there. When you launch the game it will automaticly regenerate the files you deleted earlier based on the info it gets from this one.

From here on out, all fixes will be made to the .ini files found in the bulletstorm directory in your documents.

Now, let's make this feel like a PC game:

-open storminput.ini and disable mouse smoothing (OH YEAAAAH).

-open stormengine.ini and in the early part of the file (15% down or so) disable background level streaming

-further down in that file you'll find a block about texture streaming (40%-50% down or so). Leave streaming enabled or you'll break the textures, but increase the pool size to 320.

-this one is entirely optional. If the field of view feels weird to you, you can modify it (as well as aiming FOV) in stormcamera.ini. You can add 10-15 pts to the base values without the image getting too deformed. Tweak and experiment to your liking.

Now on to suggested ways to improve the game.

-it is capped at 62 FPS with framerate smoothing (typical of UE3 engine). You'll find two occurences of that in the beginning of stormengine.ini. If you are unhappy about that, either set the max value to something higher, or just disable framerate smoothing altogether

-in-game AA is very demanding. It's preferable to leave it off and manually force it from your GPU control pannel

-turn vsync off (available in-game). It tends to tank framerates and this game doesn't need it anyway



I wasn't having any problems but the above tweaks improved my fps and made the game smoother, imo.

I may try enabling max quality mode later.


One thing I did notice, though, was the cut scene quality was terrible after making these changes. Any idea why?

schism84
02-26-2011, 02:56 AM
I haven't had problems with the cutscenes so I'm not sure what could cause it. You might try flushing with your original defaultcompat.ini to see if that solves it. I haven't figured out everything the modded one changes (essentially it sets everything to bucket 5 settings) but it modifies a lot of parameters. Actually, what greatly improved the cutscenes for me, was disabling background level streaming. With it enabled it kept micro-freezing during them.

Personally, max quality won't work at all but hey, knock yourself out and try it. Expect some severe performance drops though.

Overall, I'd advise doing what I've done for all of these changs (the engine ones, that is). Change one thing at a time, unless you know what you're doing or know what something changes specificly). That way at least you can isolate the effects of every parameter on its own.

Surfing Bird
02-26-2011, 03:12 AM
Does anyone know how to activate custom resolutions on ATI cards? A friend of mine is running Bulletstorm at 1680x1024 and he said the game is a LOT smoother, but he has a nVidia card. I'd like to try that too.

schism84
02-26-2011, 03:13 AM
Well good news, from snooping around for screenshots I have concluded I only have one bug with dynamic shadows and flickering artefacts (minor issue). The ugly textures are simply ... because the game has ugly textures. Common crude UE look. It's easy to ignore but a lot of flat surfaces look much uglier than the bump mapped counterparts. Like, Half Life 1 ugly.

If anyone thinks I'm high and has screenshots that show good looking flat textures please post, but I think it's just the nature of the beast. I suspect it's in part because they were struggling with console memory and didn't want this game to have textures popping in, so they had to cut the size of some where they could (ie the ones you don't look at too much).

Devil_Spawn
02-26-2011, 03:57 AM
tried some of these ini tweaks but it hasnt really done much :p

schism84
02-26-2011, 04:36 AM
bumpitty bumpitty bump

IlBleed
02-26-2011, 05:31 AM
Disabling the texture streaming makes the game run like a dream on my rig (e8600, 4gig, 460gtx) but when I die the game crashes while loading the checkpoint :(
Anyone have the same issue?

schism84
02-26-2011, 05:33 AM
bAllowTextureStreaming=FALSE? I didn't even think that was possible. I get horribly corrupt textures when I try that.

IlBleed
02-26-2011, 07:08 AM
Sorry, I meant bUseBackgroundLevelStreaming, not texture

schism84
02-26-2011, 07:12 AM
Ah ok. I can only speak for myself but I haven't had that issue and it's the first I hear about it. The only "issue" I have with it is that *some* cutscenes will freeze for a few seconds before playing. But that's actually better than before, when they'd stutter every two seconds.

IlBleed
02-26-2011, 07:50 AM
Seems to work fine now, maybe it was the increased pool the one causing the crash.

schism84
02-26-2011, 07:52 AM
Possibly ... although an increase from 150 to 320 really shouldn't be a problem at all.

THE Nakedgun
02-26-2011, 09:57 AM
You can Copy & Paste the content from the ini editor in any editor you like. After you made your changes you can copy it back.

No need for all that messign about the game will read unencrypted ini files as well so you canset to read only.

I use this decrypter simpy drag and drop the files onto the .exe.
http://hotfile.com/links/107623246/691f2ba/inicrypt.exe.html

dozerking
02-26-2011, 01:23 PM
FYI welcome to PC gaming.
nothing new here, its the same as it was 20 years ago, the community fixing/adding to the game post release.

haha, I've been here the whole time brotha :) And it was never as bad as it has been over past 5 years...aka, since the 360 Launched. These lazy 360 Unreal Engine ports have given us a disaster of shiz to deal with for years now. More and more corridor heavily scripted texture stream BS, all lacking quicksave functionality. Pre-Xbox, if it was a shooter, it had all the bells and whistles expected on PC. Maybe I'm just spoiled from the FPS multiplayer days of Quake when PC was king in the hearts and minds of Developers and Publishers. Quake Team Fortress anyone? Spent more time playing 2Fort5 than going to class.


This is a very helpful thread for those who need it. This is why I love the PC Gaming community so much, support. Something Epic and other devs/publishers completely lack.

PurpleHaz3
02-26-2011, 01:32 PM
@schism84

Could you possibly post a screenshot of these low-res textures? I have the same video card, and was wondering if I'm just blind, or used to low-res textures.

Because other than that, I find the game runs and looks amazing, though I do notice the shadow flicker problem, which is definitely an ATI problem.

schism84
02-26-2011, 03:11 PM
I've looked at many supposedly "good looking" high detail screenshots of the game, and even reviewers agree the textures are rather bad, although overall the game looks good and it's easy to overlook. I did some caps with steam. You guys know how to link to them through steamcloud? If you do I can post them.

So do you play with dynamic shadows and some flickeriness, or without both? ;) I still go both ways depending on mood lol

schism84
02-26-2011, 03:58 PM
Testing this. Some of my coolest looking texture screenshots:

http://steamcommunity.com/profiles/76561197970358604/screenshots/

Not really the steamcloud system I wanted, but whatever. So is it supposed to be THAT bad? They're not all that bad but some look really horrible up close.

schism84
02-26-2011, 06:09 PM
And it's .... bump time, oh yeah

GrimCW
02-26-2011, 06:19 PM
Testing this. Some of my coolest looking texture screenshots:

http://steamcommunity.com/profiles/76561197970358604/screenshots/

Not really the steamcloud system I wanted, but whatever. So is it supposed to be THAT bad? They're not all that bad but some look really horrible up close.

texture streaming bug in the UE3 engine.
that or the devs got lazy at some points.
tbh the game relies heavily on bump maps and such to fake better textures, your not supposed to look closely at them :p
notice they look much nicer at a distance most of the time? :)

schism84
02-26-2011, 06:22 PM
Yeah definitely noticed that, and the really bad looking textures are the ones without bump map (3d rocks look nicer than the same 2d texture applied to a flat surface). But, should it really be this ugly though?

For reference, those screens are from the first Echoes map, in the area with all the explosive containers dangeroulsy looming over unexpecting meatbags.

NitroBullet
02-26-2011, 07:40 PM
Is there an option in the .ini for mouse sensitivity?

schism84
02-26-2011, 07:46 PM
I haven't really figured out what controls it or how the digits might work honestly (mostly as my mouse works ok and I'm a lazy selfish man). I'm guessing you're looking to modify the sensitivity to adjust for ironsight/zoom?

Anyway, if you're looking for that stuff, dig into storminput.ini. Hope you get lucky, let people know if you find anything useful ;)

NitroBullet
02-26-2011, 08:20 PM
If it's UE3, it should look something like this "MouseSensitivity=x.x"
Also no. I'm looking to edit the base sensitivity. I heard it was a stupid bar, and I like to fine tune my sensitivity, for example 5.6.

Exinjeru
02-26-2011, 10:44 PM
When I talk about people having bad textures and fixing it, I mean they're really bad textures, like you're running the game on all the lowest settings. I can't account for lazy texture artists.

Ryne S.
02-27-2011, 02:58 AM
-deactivated mouse smoothing
-deactivated bakground level streaming
-upped texture streaming pool size to 320 (originally 150)


Thank you!!! I was like an hour into the game and couldn't stand that stuttering. It runs perfect now! I use the ingame menu for 8x AA since it works and forcing it though nvidia control panel doesn't. I do force vsync and triple buffer with the ingame vsync on. I also put SmoothFrameRate=True to False.;)

Ryne S.
02-27-2011, 02:59 AM
Anyone figure out how to keep the bodies and gore from disappearing? It's driving me nut's!!!! lol

elevul
02-27-2011, 04:01 AM
Hello.
I was wondering if it is possible to do two things:
- Different languages for audio and subtitles
- Change the aim button to stay in sight mode until I press the right button again, instead of having to keep it pressed

Are these two things possible? I searched in the inis a little bit, but it seems that the sight is done in a layer xbox pad - variable - pc input (which is ridiculous, but anyway)...
Regarding the languages, I searched the engine file, but there was only one value for language, which changed everything.

I managed to bind F12 for screenshots
May I ask you how did you do it?
NVM, found it. It was enough to add
Bindings=(Name="F12",Command="shot")
to StormInput.ini

Is there any way to specify the folder where it should save the screenshots?

cj75s
02-27-2011, 04:18 AM
Anyone figure out how to keep the bodies and gore from disappearing? It's driving me nut's!!!! lol

Necrophiliac? lol

Not sure, but they've probably put a limit in to help with memory and FPS!?

schism84
02-27-2011, 10:42 AM
I didn't see something clearly referencing the time that stuff stays displayed. Also, bumping this for greater justice!

Exinjeru
02-27-2011, 11:50 AM
There should be separate commands for subtitle language and game language in the U3 engine. They're in there somewhere.

schism84
02-27-2011, 03:26 PM
Bumping this up, maybe someone will have some answers to the audio, subtitles etc

elevul
02-27-2011, 04:27 PM
There should be separate commands for subtitle language and game language in the U3 engine. They're in there somewhere.

Mass Effect 2 had 2 values (TextLanguage=INT and VOLanguage=INT) that could be edited to change VO and Subs language, but I cannot seem to find them in Bulletstorm's .ini files.
Also, the BulletstormINIeditor doesn't seem to be able to read StormGame.ini, and I don't know why. I did check DefaultGame.ini, though, and the two values I mentioned before aren't there...

Meh, whatever. I finished the game in an afternoon anyway. There is no point in wasting more time on it.

wonderpookie
02-28-2011, 03:14 AM
So I now have a very stable and functional game with no bugs whatsoever. Here is what I modified:

-upped FOV as well as aiming FOV by 10 pts
-deactivated mouse smoothing
-deactivated bakground level streaming
-upped texture streaming pool size to 320 (originally 150)
-D3DDX10 activated, but I can't see a difference to be honest

The game is set to 1280*720 (I have a 1440*900 sceen) with everything on High except World Detail on Low, Vsync OFF, no AA (I force it to 4x with Catalyst).

Now runs perfectly on my weak dualcore rig with ATI HD5770. Only thing I notice is some textures are pretty ugly up close but that might just be the game itself. I tried to activate max quality mode but it just crashes my game so I can't tell you if it fixes that. Might just be that the game really has some ugly textures up close. Overall though it all looks very nice when you're playing instead of staring at a piece of wall.

I'm able to activate the High Quality mode and the game runs fine (no crashes), BUT THE TEXTURES ARE STILL FUGLY. In fact, with high quality mode set to true, the game looks exactly the same (at least to me!), but the FPS drops significantly. Bah.

Thanks for this thread. It has been very enlightning!

dskinner
03-01-2011, 05:35 AM
Disabling the texture streaming makes the game run like a dream on my rig (e8600, 4gig, 460gtx) but when I die the game crashes while loading the checkpoint :(
Anyone have the same issue?

Yes, same here. I've found that not dying helps :) but seriously, press Esc as soon as you die and manually load your checkpoint and that avoids the CTD. (Ah, the twists and turns we must endure.)

I also get the artefacting (jumpy little black sqaures) on the guns/characters (in sunlight) and I have an nVidia (GTS250), not an ATI. Disabling dynamic shadows seems to have worked for me, too, tho.

By the way, thanks to everyone (especially schism84) for this thread.

lucky644
03-01-2011, 12:41 PM
This game actually runs quite well for me, with all settings maxed out, my issue is with the sound, randomly it dies and I have to reboot the pc before it comes back.

My question is, for those rooting around in the .ini, do you guys see anything related to sound? Such as how many sounds can be played at once for example? I'm wondering if a bad config is overloading peoples sound card drivers and crashing them.

It has made the game unplayable for me now, since rebooting every 15-20 minutes really breaks the fun :(

Exinjeru
03-01-2011, 02:17 PM
That sounds more like a fault in your soundcard.

If no one else has the bug then it's a 90% chance it's your computer, but there's still a small chance it's the software.

lucky644
03-01-2011, 02:34 PM
That sounds more like a fault in your soundcard.

If no one else has the bug then it's a 90% chance it's your computer, but there's still a small chance it's the software.

http://forums.steampowered.com/forums/showthread.php?t=1771457

I'm not the only one who has sound issues, and more specifically, an issue with the sound cutting out and having to reboot.

Nekki
03-02-2011, 09:52 AM
Thanks for all the tweaks, now I can say my game runs awesome smooth.

Also, I discover we can force to run the game in dx10. Usually, in HIgh post processing you can see the sun shafts which is removed when you go to medium post-proccesing setting. It bump the performance to stable 60 fps but if you turn dx10=on in SteamEngine.ini, the shafts are back even in medium, but without loosing performance.

zxeuk
03-02-2011, 04:41 PM
Thanks for all the tweaks, now I can say my game runs awesome smooth.

Also, I discover we can force to run the game in dx10. Usually, in HIgh post processing you can see the sun shafts which is removed when you go to medium post-proccesing setting. It bump the performance to stable 60 fps but if you turn dx10=on in SteamEngine.ini, the shafts are back even in medium, but without loosing performance.

You mean StormEngine.ini?

Plus the line is "AllowD3D10=True" (if you want dx10 on, default is False).

Nekki
03-02-2011, 07:32 PM
You mean StormEngine.ini?

Plus the line is "AllowD3D10=True" (if you want dx10 on, default is False).

Yes, you right. Just I was not at home when I posted it so didn't remember the precise file and cvar.

Ryne S.
03-02-2011, 08:43 PM
dx10 doesn't seem to do anything. It looks the same to me.

Ryne S.
03-02-2011, 11:52 PM
Here's my config tweaks:

StormInput:

bEnableMouseSmoothing=false

(set to false for better control)


StormEngine:

bSmoothFrameRate=False

(Set to False so the game doesn't try to smooth the framerate slowing it down)

[XAudio2.XAudio2Device]
MaxChannels=128

(I set this to 128 since my soundcard has 128 channels)

[ALAudio.ALAudioDevice]
MaxChannels=128

(I also set this to 128 since my soundcard has 128 channels)

[TextureStreaming]
PoolSize=320

(for the textures to stream better and have more breathing room..I also set this to 640 testing it...since my ram on my gtx 470 has 1280mb of ram..but I see no difference...so I keep it at 320)

bAllowBetterModulatedShadows=True

(set to True for alittle better softer edges on shadows)

OneFrameThreadLag=False

(set to False to prevent one frame lag before rendering)

[Engine.TelemetryInterfaceEAOnline]
TelemetryServerHostName=
TelemetryServerPort=

(I delete both lines to disable EA from monitoring and collecting information even though in the game menu you can untick it to prevent them...it goes back to being ticked after restarting the game)

StormPawn and StormPawnBS:

bXboxPMCUnlocked=true
bPCPMCUnlocked=true
bPS3PMCUnlocked=true
bXboxBootsUnlocked=true
bPCBootsUnlocked=true
bPS3BootsUnlocked=true
bLeash0Unlocked=true
bLeash1Unlocked=true
bLeash2Unlocked=true
bLeash3Unlocked=true
bLeash4Unlocked=true
bLeash5Unlocked=true
bLeash6Unlocked=true
bLeash7Unlocked=true
bLeash8Unlocked=true
bLeash9Unlocked=true
bLeash10Unlocked=true
bXboxCharSkinUnlocked=true
bPCCharSkinUnlocked=true
bPS3CharSkinUnlocked=true

(set all these to true to unlock all color leashes including DLC ones and epic edition PC, PS3 and Xbox skins)

Testing and Notes:

Under StormPawn and StormPawnBS:

bGoldenBootsUnlocked=false

(this doesn't seem to unlock anything set on true so leave it on false)

under StormEngine:

bUseBackgroundLevelStreaming=True

(setting this to False may give you a smoother framerate but I keep it on True because some of the cutscenes get cut off and restart for no reason as well as falling through maps at the beginning of a level...basically the game doesn't work correctly with this on false)

bUseMaxQualityMode=False

(setting this to True will make the game run slowly and will disable alot of textures from showing..leave this on false)

AllowD3D10=False

(setting this to True will turn on DX10...but has no diffrence in anything so leave it on False)

MaxShadowResolution=800

(you can set this to 1024 if you like but I see no difference so I leave this at 800)

bEnableVSMShadows=False

(setting this to True makes the shadows look the same as default leave it at False)

bEnableBranchingPCFShadows=False

(setting this to True makes the shadows look like dots and have a softer edge I leave this on False since it looks weird and looks like a console)

bAllowHardwareShadowFiltering=False

(setting this to True makes the shadows look like lines I leave this on False)

bEnableForegroundShadowsOnWorld=False

(setting this to True casts a shadow of the player...well half of the players shadow..it looks goofy looking since it only shows half of your torso...leave this on False)

Kiljoy66
03-02-2011, 11:56 PM
So this supposed ATI shadow glitch thing, is THIS what you are referring to? I get this and it's annoying as sin ingame.

http://i5.photobucket.com/albums/y200/Larduuk/WTF.jpg

It's the shadowy lines on the floor, it's pretty much like that everywhere and even on the character models in cutscenes, VERY distracting.

Ahmmork
03-03-2011, 08:22 AM
So this supposed ATI shadow glitch thing, is THIS what you are referring to? I get this and it's annoying as sin ingame.

http://i5.photobucket.com/albums/y200/Larduuk/WTF.jpg

It's the shadowy lines on the floor, it's pretty much like that everywhere and even on the character models in cutscenes, VERY distracting.
Got Nvidia and i see those things. Changing post process to medium removes them...

But the colors and graphics are still ♥♥♥♥:(

Ryne S.
03-08-2011, 08:10 AM
Anybody figure a way to keep gore and blood decals yet? ;p

NoVaTuRiEnT
03-08-2011, 11:56 AM
You mean StormEngine.ini?

Plus the line is "AllowD3D10=True" (if you want dx10 on, default is False).

Changing this does absolutely nothing.
I have a program called Rivatuner showing FPS and GPU Temp.
Changing "AllowD3D10" to True still shows DX9 before the FPS (DX9 : 110.23 FPS).

So I doubt DX10 mode is even supported in this game (even though it's built off the Unreal Engine).

As for the other problems listed in this thread, the only issue I've really had is the crashing when getting killed in the chapter where you're getting chased by..bombs?

Runs completely fine otherwise.

ncdiver2
03-08-2011, 05:51 PM
ok so ive changed the resolution to meet the factor 8 requirement turned off mouse smoothing backgroud level streaming to fase texture streeming pool to 320 smooth frame rate to false stil have slow responce and lag any other ideas?OBTW the game is still a hoot it will be killer pun intended if i ca get it to run right

ncdiver2
03-08-2011, 06:09 PM
in what folder do you find fov?

Ryne S.
03-09-2011, 08:03 AM
in what folder do you find fov?

Documents > My Games > BulletStorm > StormGame > Config > StormCamera

Under StormCamera you will see the Default Camera FOV of 85.

satsun
03-09-2011, 08:38 AM
I haven't had any problems with the game but I played with the INI files anyway; I've got an i7-950 and a GTX 480.

I disabled mouse smoothing, framerate smoothing, upped the FOV to 95, enabled the shadowing features, added the GTX 480 to the compat.ini, added 16501048 to make it run better and it has done well. It's actually using a good 700-900MB of the video card memory and most of the GPU processing power and definitely feels snappier without the framerate smoothing.

I tried to enable PhysX but that blocks the GFWL interface so I can't access my save. Tried some fixes for that but ended up having to disable it.

The textures look fine but not spectacular and I'm guessing that they just won't ever look great since they're probably optimized for consoles. I've seen shots of the texture issue but I'm not experiencing that.

buckiesmalls
03-09-2011, 12:09 PM
I have found that leaving framerate smoothing on, but change it to 60 instead of 62 (use vsync here) minimized the stuttering quite a bit. and oh yeah untick "share usage date" under game options, that seems to have to be unticked every fresh restart of the game.

buckiesmalls
03-11-2011, 12:43 AM
added the GTX 480 to the compat.ini
Exactly what did u enter for that??

elevul
03-12-2011, 05:51 AM
I haven't had any problems with the game but I played with the INI files anyway; I've got an i7-950 and a GTX 480.

I disabled mouse smoothing, framerate smoothing, upped the FOV to 95, enabled the shadowing features, added the GTX 480 to the compat.ini, added 16501048 to make it run better and it has done well. It's actually using a good 700-900MB of the video card memory and most of the GPU processing power and definitely feels snappier without the framerate smoothing.

I tried to enable PhysX but that blocks the GFWL interface so I can't access my save. Tried some fixes for that but ended up having to disable it.

The textures look fine but not spectacular and I'm guessing that they just won't ever look great since they're probably optimized for consoles. I've seen shots of the texture issue but I'm not experiencing that.

Disable also oneframethreadlag if you want an even snappier gameplay. ;)