PDA

View Full Version : I'm having a weird error


fallinroxas
03-01-2011, 08:43 PM
It say" Steam is Required. Please make sure you are running Braid from Steam! This version of the game won't work otherwise." But I'm hitting the play button from within Steam itself. I just bought the game. I did have the demo downloaded before but I deleted it before I bought the full game.

fallinroxas
03-01-2011, 09:07 PM
Nevermind I got it working lol. I just went to the store page and clicked download demo and it worked. Sorry.