PDA

View Full Version : Freeze every 5 minutes, please help


- RÍveur -
03-06-2011, 07:44 AM
Hi everyone,


First, thanks for reading my post, hope you can help me.


I just can't play M&B Warband for a long time, without having problems:
When I enter a large battle, I'm almost sure the game will freeze.
Only solution then is to alt + tab, to be able to continue to play, for a few minutes, then it'll freeze again.
Also happens when I enter a tavern and sometimes when I upgrade troops.


My system:
Windows XP
Pentium(R) Dual-Core @ 2.50 GHz
3 Go RAM
ATI 4850, drivers updated
DirectX 9
Don't know if important: I used steam to play it


I searched a lot, to find a solution and tried this:

-I formated and freshly reinstalled everything.
-I set all settings to low
-I checked "Load textures on demand" in Configuration settings
-I Have "Force Single Threading" checked in the advanced settings.
-Battle size set to 100
-Ragdolls and corpses disabled
-Anti-aliasing disabled
-No background program running
-I tried to play with directX 7
-I Set max frame rate to 80
-I tried old drivers for my graphic card (10.5 and 10.6)

-I used the solutions of this thread (http://forums.taleworlds.com/index.php/topic,131274.0.html).
* Menu Start -> Run, type sysdm.cpl and press ENTER
* a window should open, go to tab Advanced -> Startup and Recovery Settings -> Edit
* at this point you're editing your boot.ini file. Don't mess things up.
Look for the line with your operating system mentioned and add "/3GB /USERVA=2990" without quotes. Should look like this:

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB /USERVA=2990

just add only the "/3GB /USER...", don't erase or add anything else as it may corrupt your booting file
* save changes and reboot
Adding "/3GB /USERVA=2990" to my boot.ini prevents the game from launching.

* Menu Start -> Settings -> Control Panel -> System -> Advanced
* Performance -> Settings
* Advanced tab -> Change
The tricky part is setting the values right. Microsoft suggests (http://support.microsoft.com/kb/308417 , Step 2) to set the minimal value as 1.5x of your RAM and maximal value as 3x your RAM (so if you have, for example, 2GBs of ram then minimal is 3.5GBs and max is 6GBs... so that's 3500MBs and 6000MBs). There's plenty of topics on the web with performances results and such revolving around this subject so... Google.
* Save, reboot
Changed memory usage like specified.

I seriously can't find a solution to this problem, please help.
Thanks.

Asphe
03-08-2011, 03:09 AM
Hi everyone,
-I used the solutions of this thread (http://forums.taleworlds.com/index.php/topic,131274.0.html).

Adding "/3GB /USERVA=2990" to my boot.ini prevents the game from launching.


Changed memory usage like specified.

I seriously can't find a solution to this problem, please help.
Thanks.

Don't use that method, instead set your page file to 'custom size' and set max and min to be the same number. My Computer - Properties - Advanced/etc. I'd suggest 4GB or more. Just make sure it's 'fixed' in size (you probably have 4GB of RAM but your system will not normally see more than 3GB due to OS/hardware limitations but that's ok. Warband should run fine in even 1GB/WinXP if your page file is big enough.)

You might also want to disable 'Load Textures on Demand' (it's loaded invo video memory anyway) to see if that helps.

Note that this applies to Native, a lot of the 'Large' mods like POP or Brytenwalda are just too big to run on your OS/system configuration.

Asphe
03-08-2011, 08:28 AM
BTW, "Dreamerr", you should've mentioned that you had installed POP. You would definitely need to enable 'Load Textures on Demand' else you will run out of video memory while loading POP.