PDA

View Full Version : Steam changing volume on other windows applications


RaidSoft
03-12-2011, 03:25 AM
Hi!

I recently started running into this issue, at first I wasn't sure what was causing it but I narrowed it down to steam. My other programs were getting their volume sliders automatically changed somehow in the windows mixer (win7 ultimate 64-bit) and it kept forcing the volume back down to the low level as well if I tried to change the volume back up to the normal level in the mixer.

Now I am not entirely sure if this is related to the fact that I recently activated the beta for steam, it might be why (which is why I inactivated the beta for now) but this is extremely annoying.

Have anyone else run into this? Basically randomly when you get a message that plays a sound from steam then other application volumes get lowered significantly and they don't get raised up after so they are stuck being lower volume then normal?

I am pretty sure that it's steam related because it only happens when I get a message (but not every time either which is weird) on steam that plays the message received sound.

Thanks for your time!

edit: after disabling the beta it's still doing the same thing... So I guess it's not that.

edit2: people have reported success in this thread with turning off a windows setting, you can find it in the Communications tab (set to Do nothing) in the Sound control panel in win7 (not sure if vista has that feature? maybe, should be in the same place if it does)

RaidSoft
03-12-2011, 03:56 PM
Guess nobody else have this issue then? I have turned off the sound for receiving a message on steam and I am not getting this issue anymore so I guess that "fixed" it but I prefer having the audio when I get a message :/

kenmantx
03-17-2011, 05:23 PM
I just noticed I'm having this problem as of yesterday. Were you able to fix it?

At first, I thought that receiving a message was the only thing that triggered it, but today I went to download a demo through Steam and it triggered it. I'm not sure where in the process it happened, but I do know that I didn't receive a message during that time.

I have to restart whichever application is affected to restore the sound :(

RaidSoft
03-17-2011, 05:29 PM
Not quite sure, I have turned off sound from recieving a message and that seems to have stopped it for now.. I found something interesting though, I am not 100% convinced that steam is the cause right now.

I have a monitor and a tv connected to my computer, the tv through hdmi and that had the audio enabled for it (which I didn't use) so I disabled that. Why? because I noticed that if I switched screen mode between just using my monitor, just my tv or both at the same time seemed to trigger exactly the same thing where volumes got thrown around in the mixer.

Now I haven't confirmed that this fixed it for me but I haven't noticed this issue pop up since I believe.. So just checking, you using a monitor/tv connected through hdmi with the audio feature? Trying to find anything similar for us in terms of gear or whatever.

kenmantx
03-17-2011, 06:53 PM
While I have dual LCD's connected via HDMI, neither of them offer and sound capabilities. Possibly related, possibly not, but I do have most of the Steam windows opened on the 2nd LCD; is that true for you?

I have Win7 Ultimate x64 sp1, using the onboard sound from a Gigabyte mobo.

RaidSoft
03-17-2011, 06:59 PM
what steam runs on varies for me since I don't always run both at the same time, but I don't think that's the reason, does your drivers allow you to enable or disable the audio function over hdmi? or is that disabled because the monitors don't have that functionality? I use an nvidia card (gtx460) and in my nvidia control panel I have a setting under Change Resolution for enabling or disabling audio, no idea if that is "detected" if it has that capability?

I run Win7 Ultimate x64 (no sp1 yet) and I actually have 2 soundcards, but that doesn't seem to affect it, I primarily only use my soundblaster x-fi xtreme audio.

kenmantx
03-17-2011, 07:08 PM
I appreciate the replies!

And yeah I don't think that I have that option (but I do have that exact same model card, from EVGA); here's my Change Resolution settings:

http://i.imgur.com/EXfsl.png

I have a x-fi xtreme too, but I could never get Win7 to recognize it. I checked again just now and it's still not there.

I think Steam is to fault. I haven't run windows updates since I installed sp1, and considering that you don't even have sp1 I think we can rule out any Win7 updates. I also haven't updated any other drivers for a few weeks. So, the only software that has updated since I first encountered this problem (which was yesterday or the day before) is Steam.

I think that it is part of Steam's game overlay, which I think attempts to mute the game you're playing when you bring it up. I have also had this problem while watching Netflix movies when I receive a message on Steam.

EDIT: realized that I have DVI (and not HDMI). No difference though.

RaidSoft
03-17-2011, 07:18 PM
That's different than me. http://dl.dropbox.com/u/56180/nvidiahdmi.jpg

Also DVI doesn't have audio feature (I believe) so it wouldn't show up there :)

But so far it haven't freaked out on me yet.. But I have also turned the overlay off, it could very well be the overlay that's messing stuff up.. Tbh I first started noticing this when I added the steam overlay on rift as a non-steam game. I stopped using that though.. Worth testing I guess?

My creative x-fi xtreme audio is the pci version (not pci-e) and is detected just fine by windows, it even lists drivers for it in windows update (which I don't use, I use creatives)

kenmantx
03-17-2011, 07:21 PM
I don't have Rift although I did play in the open beta...

I have the PCI x-fi as well, and it was working fine in my old box. Maybe I just need to reseat it or swap it to a different PCI slot.

I'm going to disable the overlay to see if that helps :)

RaidSoft
03-17-2011, 07:28 PM
I don't think it's specifically rift related though, if anything it's the adding games as non-steam games that would cause it.

Sounds like you should try swapping pci slot then yea, obviously there are drivers for win7 x64 so something else is most likely the problem :)

I have my overlay turned off and I haven't noticed the glitch so far.. I will post if it does happen again though..

TheRealScale
04-04-2011, 05:51 AM
Same problem here, No rift ever run.
On board sound card.

This behavior is like what used to happen when i call somebody on skype, and now steam uses the skype codec not sure if there is a relation there.

But it's freaking annoying.

Slayer00
04-04-2011, 06:03 AM
Try disabling Windows voice call sound mixer changer annoying thingy.

Screenshot: http://slayer00.net/img/steam-volume-fix.png

TheRealScale
04-04-2011, 06:13 AM
Try disabling Windows voice call sound mixer changer annoying thingy.

Screenshot: http://slayer00.net/img/steam-volume-fix.png

Awesome thanks bro, works like a charm.
Not sure why the message beep is detected as a voice call but whatever is off now anyway.

Markov
04-09-2011, 03:01 AM
Thanks for that, was wondering if it was steam related because it only happened there but looks like its windows. Thx again.

RaidSoft
04-09-2011, 04:16 AM
So we are completely sure that was the culprit? I recently deactivated that setting as well, I can't remember if changing that was what caused it to stop happening for me though..

If we are 100% sure then we should try and bug report it to steam so they can fix it?

carlichaotic
04-09-2011, 04:30 AM
Having the same problem aswell! Didn't think it was steam but I also have Win 7 Ultimate 64-bit and that exact thing is happening!

DarkByke
04-17-2011, 02:51 PM
Try disabling Windows voice call sound mixer changer annoying thingy.

Screenshot: http://slayer00.net/img/steam-volume-fix.png

Yes, this was the solution for me as well. Steam was the culprit, because as soon as I would hear a ping noise for a friend going online, the volume would drop to 80% as it was set, and wouldn't return to normal after that.

RaidSoft
04-17-2011, 02:54 PM
I noticed that they changed this in the latest steam patch! Hopefully that means that they read this thread and fixed it ;)

KhaoticReign
04-17-2011, 03:05 PM
I'm having a slightly different problem, though it is related to these updates. The Silk codec that's being used now is probably the culprit for both your problem and mine.

I tried the solution mentioned, switching the option in communications to Do Nothing, and that didn't do anything for my issue.

The issue I'm having is that when someone speaks while I'm in a game, my sound output goes from my headset to my speakers, and it stays this while until I exit both the game and the Steam client. Hopefully they fix this stuff quick. Sort of ate away my weekend trying to figure it out.

DarkByke
04-18-2011, 04:17 AM
I noticed that they changed this in the latest steam patch! Hopefully that means that they read this thread and fixed it ;)

When was the patch out? I had this problem as of yesterday.

RaidSoft
04-18-2011, 05:13 AM
When was the patch out? I had this problem as of yesterday.

I got that update yesterday I think..

Mickie Jade
10-13-2011, 09:13 PM
I got that update yesterday I think..


*Digs old Thread back up*

I ran into that Problem just now downloading the Overlord Demo. I was considering changing the auto volume adjust to fix it, I hope it works.

Syrinx
10-21-2011, 06:37 PM
I recently had this happen to me, so I've changed the communications setting to "do nothing". Hope it works!

campy
12-03-2011, 06:14 AM
same as above, i've had this problem for some time and hope the fix in the OP does the trick

mavmike
01-14-2012, 11:03 AM
this is still happening when you have the "beep" turned on when a friend sends you a message. It's a STEAM problem.


Basically you have to disable steam sounds for notifications, unfortunately. I like that feature though. It's like a phone call.
Except, my phone ring doesn't affect the volume of my cd player... cough STEAM cough