PDA

View Full Version : Dungeon Siege I - Windowed mode crash


Xfraze
04-09-2011, 05:04 PM
When I start dungeon siege I in windowed mode on windows 7, I can proceed as far as loading or starting a new game. The screen enlarges (not past my current screen resolutoin) and then goes black. From there, it sits and task manager says the program has failed to respond.

Has anyone else run into this problem and know a possible solution?

As a side note, I can play in fullscreen.

knighty101
04-10-2011, 10:19 AM
I have not had this issue, have you checked the event logs to see what's causing the crash??

click on:
start > right click computer > select manage

once computer manager loads look at
> windows logs > application

now you can see whats causing the app to crash, it might be something simple.

Xfraze
04-10-2011, 10:41 AM
I've checked the event viewer, and sadly, the only warning message in regards to dungeon siege is "The program is incompatible with this version of windows."

As a side note, I recently tried installing the windows xp virtual machine for windows 7 since every other post I read when searching for answers has that as a possible solution. Don't even bother with it, the virtual machine lacks hardware acceleration so the game won't even run. It can't even find your video cards in the environment so it's pointless. Save yourself an hour of setup, or 2 minutes of making a post to offer that as a solution to people.

knighty101
04-10-2011, 10:47 AM
yup, its never gonna work in windows xp mode for the exact reason you state (it was not designed to play games and therefore has no acceleration)..

I think however vm-ware workstation will work as it has dx9 compatability. (not tested myself)

least it works in full screen I guess.

Xfraze
04-10-2011, 10:58 AM
In the end, I've decided to give up on DS1. The game has horrible tearing in full screen, and after further digging, I've found that even if I fix the windowed mode problem, it'll still have the tearing issue. I'm going to chock this one up to my ATI video card since the folks sporting nVidia don't seem to be complaining about much.

knighty101
04-10-2011, 11:09 AM
I remember reading about flickering being fixed by adding bltonly=true (i didnt take a lot of notice as it wasn't the prob I had)

you can also try un-selecting your gfx card in the config and choose primary hardware without the tnl.

knighty101
04-10-2011, 11:21 AM
a guy just made a good update to a post, it looks like its not replicating the settings correctly worth a shot?..

http://forums.steampowered.com/forums/showthread.php?t=1827560

juselasmc
04-10-2011, 01:18 PM
First Excuse me, ´cuz my english is bad...

I fing the solution, this issue is present in W7x86 & w7x86_64, i do this:


1. Go to ...

C:\Program Files (x86)\Steam\SteamApps\common\dungeon siege 1

2. Double click on DSVideoConfig.exe
3. It will probably say “Primary Display Driver – Hardware” change it to whatever video card you have. For example i (Deathmarine) would change it to “NVIDIA GeForce 8800GTX – Hardware” DO NOT PICK THE ONE THAT SAYS “TnL”
4. you can pick whatever resolution, shadows or filtering you want and click OK

5. There, you can select the executable and execute in compatibility mode: Wxp sp2,

with that the game run…. and no black screen or memory exception… the bad thing is that you can run in steam, you need to create a new shorcut,,,, maybe in the desktop

…..

Thanks to Frank Moricz, i put this solution too in his blog...


Excuse my english...

Sardes = juselasmc