PDA

View Full Version : Game will not start


durwoodx
04-22-2011, 02:12 PM
The game refuses to launch on not one, but two different machines. One is running Vista and the other W7 64 bit.

The Steam window will come up very briefly saying "Preparing to launch Zombie Pirates" then disappears and nothing happens. Tried installing XNA Runtime as the individual in the other thread suggested but no help.

Most unhappy.

Jajusha
04-22-2011, 04:16 PM
Try the .NET framework too, i think its in the game directory (dotnetfx35)

durwoodx
04-22-2011, 08:06 PM
I actually did try that as well (on both systems) multiple times and got Installation errors at the exact same point during the install each time.

Jajusha
04-23-2011, 02:45 AM
Download the latest .net then (i belive its 4). If it keeps giving error during the install, then its something in your system.

durwoodx
04-23-2011, 04:10 AM
Ok just tried installing the latest .net (which did so successfully this time. Thanks!) but to no avail - still same problem trying to get the game to run.

I would be inclined to think there was something squirrelly on my system that is causing this if I wasn't having the EXACT same problem on two completely independent systems.

loomis1975
04-23-2011, 07:13 PM
I can't get it to start running on two different systems either. And both have latest XNA distributable and .net framework 4 and down installed. Sent a ticket into support to see what we can find out.

durwoodx
04-23-2011, 08:19 PM
Bless you, sir.

loomis1975
04-24-2011, 04:54 AM
Got it to work by installing the Demo available at the developer's webpage:
http://www.dustdevilstudios.com/

After I installed the demo, it worked fine. I installed the demo, started the demo, played around in the menu, exited the demo, then started Steam and the game then started fine. I exited the game and steam, uninstalled the demo, then restarted steam and the game still started fine. Something it does while installing the demo seemed to take care of the problem.

durwoodx
04-24-2011, 11:34 AM
Awesome - that worked for me too. Thanks!

Ranger_Jax
04-24-2011, 11:48 AM
I had the same issue with Windows7 64bit but installing the demo worked.

Thanks loomis1975!

netscorer
10-29-2011, 09:30 AM
I have the same issue running Windows XP 32-bit with the latest .NET Framework. Game would not launch, which means it is still seriously broken on Steam servers.
I am downloading demo now to see if I can fix it but this is one of those things I do not have to do when I am a paying customer. Bet you pirated copy would launch without hiccup every single time.

P.S. Downloaded demo - all 350Mb of it. During the demo install it also installs XNA 3.5 - this does the trick. I did not even have to open demo, once XNA is installed the Steam version launches all right. By the way, I already had XNA 4.0 installed on my PC but this game requires a specific XNA version. Steam folder contains XNA distribution files and guess what, they are 4.0! No wonder game won't start by itself.

Halanthar
11-01-2011, 07:11 PM
You don't have to install the demo.

7mb download: XNA 3.1 is required, get it from Microsoft at

http://www.microsoft.com/download/en/details.aspx?id=15163

ercmanX
11-04-2011, 09:29 PM
You own!

shintsu01
03-16-2012, 01:59 PM
worked for me thanks!