PDA

View Full Version : an interesting issue


scottimus
05-01-2011, 09:42 PM
tl;dr version: it goes to start, freezes on a white screen, any ideas?

I have been front to back on this forum, and others, to see if anyone seems to have this problem and if there are any potential fixes. obviously, because im posting it here you can tell i have failed.
my issue is: when i run max payne one, purchased via steam, it has the pop-up box thing asking about resolution and color depth etc, then i click ok/continue/whatever and it goes like its making for a full-screen, then freezes as a large white box which takes up the screen. it has the bar up top with min/maximize and close, but none of them work, no key commands can switch out of it, and eventually i have to ctrl-alt-del to close it through task manager.
i have verified the files via steam, they check out as uncorrupted, i have tried running it in compatibility modes and as administrator (i dont why on admin, but i figured it couldnt hurt). i tried patching it from r*, but other than that i havent installed any mods or fixes. any suggestions?
(im going to uninstall it and get a fresh copy from steam)

im running win7 pro 64bit, nvidia geforce 9800m gs card, and will provide other info upon request.

DarkjeThe2nd
05-02-2011, 02:59 AM
Yes, I have seen this before. Probably you don't have the proper codec installed for the intro movie. You can test this by going to your max payne folder/movie and clicking 'intro.mpg' If it does play in mediaplayer you have a codec, but if it doesn't this is your problem.

Now to fix it you can do two things, either install a proper mpg codec or skip the intro movie. To skip the movie use the -skipstartup parameter in the game properties. If this fixes it, you can be sure it's the codec missing.

http://i54.tinypic.com/t6tjwz.jpg


edit: same goes for the shortcut on your desktop, just go to it's properties and add -skipstartup behind the target, and make sure there is a single space between the quoted line already there and the parameter you are adding.

http://i55.tinypic.com/2wqzvja.jpg

scottimus
05-03-2011, 01:02 AM
thank you, DarkjeThe2nd.
the intro did play, but i decided to add the -skipstartup parameter anyway, and upon launch it did work.
also, many props for the legit screen-shots