PDA

View Full Version : Shadowgrounds crash on startup, Survivor and Trine work fine


Kronk
06-10-2011, 01:22 PM
I am having problems with Shadowgrounds crashing every time I try to start it up. I have run both Shadowgrounds: Survivor and Trine and they both start up although I have yet to enter the game to try them out. I am running Windows 7 Ultimate x64, I have a GeForce 9800 GTX graphics card, 4 GB of RAM and a dual core 2.1 GHz processor so I'm well above the minimum requirements.

Whenever I start the game, it attempt to load and then gives me a "Shadowgrounds has stopped working" message. The problem details listed in the error report are below:


Problem signature:
Problem Event Name: BEX
Application Name: Shadowgrounds.exe
Application Version: 1.0.0.1
Application Timestamp: 44ed9d94
Fault Module Name: Shadowgrounds.exe
Fault Module Version: 1.0.0.1
Fault Module Timestamp: 44ed9d94
Exception Offset: 0023e254
Exception Code: c0000005
Exception Data: 00000008
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789



The error message then has me close the program. Please let me know if there is more information I can provide to help solve the problem. Thank you.

JoelFB
06-11-2011, 05:07 AM
Sounds strange. Can you try launching the game from the shadowgrounds.exe file in the game's folder? This might give a more elaborate error message.

I'd urge you to try that SGS and Trine run fine, i.e. you get to gameplay. This will help a bit. In general the original Shadowgrounds is the least demanding game of these, so this is a bit tricky. It could be related to videos/WMV codecs (I assume you have a regular Windows 7 Ultimate version and not e.g. Windows 7 N without the media packs).

Let me know. I'm sure we'll get the game running one way or another.

Kronk
06-13-2011, 12:59 AM
Thank you for the fast response, Joel.

Survivor and Trine are both working fine. I started them up and entered both games with no problems. I had tried running the .exe from the game's folder and it still crashed. I ran shadowgrounds.exe again just now and it gave me the identical crash message and error details as I listed in my original post. I do have a regular version of Windows 7 Ultimate, not the N version minus media packs. Just to make sure, I did download the media pack codecs and I still get the same crash.

kiseitai2
06-13-2011, 05:29 AM
Have you tried running the Shadowgrounds game as administrator? Your problem sounds awfully like one of similar crashes I've had in the past with Windows Vista. Since Windows 7 is practically an update to Vista, I think it may be a compatibility/ permissions issue that pops up once in a while for little reason. Then again, I think recent versions of Steam launch the games with all the read/ write permissions they need, which is how I haven't seen one of these crashes in my computer lately. Try just in case, though.

kiseitai2
06-13-2011, 05:32 AM
You could try pulling out the Windows logs pertaining to applications and see what else does it says about Shadowgrounds crashing.

JoelFB
06-13-2011, 09:58 AM
Those are good tips. The game's log is in the game folder as log.txt or log_errors.txt - usually it's not very useful but it's worth checking out (the last lines are basically the ones of interest).

Kronk
06-13-2011, 02:07 PM
Have you tried running the Shadowgrounds game as administrator? Your problem sounds awfully like one of similar crashes I've had in the past with Windows Vista. Since Windows 7 is practically an update to Vista, I think it may be a compatibility/ permissions issue that pops up once in a while for little reason. Then again, I think recent versions of Steam launch the games with all the read/ write permissions they need, which is how I haven't seen one of these crashes in my computer lately. Try just in case, though.

I run Windows 7 with User Account Control turned completely off and my only profile is the administrator account therefore everything is automatically run as the administrator. Even so, I actually did try to run Shadowgrounds with "run as admin" checked, as well as in compatibility with Windows XP sp 2 with visual themes and desktop composition disabled, all with the same results as before.


As for the game logs, I do not have a "log.txt" nor a "log_errors.txt" anywhere in my shadowgrounds folder.

poleritude
06-13-2011, 05:47 PM
Sounds like something is corrupted or not working correctly. Since its only SG it might be something older that the other games don't use too, or it could just be something quirky. Personally I'd try the following, just to cover your bases.

1.) Remove the local content from steam, also manually delete any SG folders in the steam and windows/user directories that it created.

2.) Reinstall the full directX redistributable from Microsoft (sometimes this matters for older versions of directX used by programs)

3.) Remove and reinstall your Nvidia drivers, you should probably also use driver sweeper or similar before reinstalling the latest ones from Nvidia's site. This should also cover PhysX (which I don't think original SG uses even)

4.) If you have a lot of codecs for media, I'd uninstall all of them that you can from control panels "Programs and Features" and then reinstall one comprehensive set such as CCCP. Having lots of bits of codecs from all over can cause you grief.

5.) (extra catch all step) Not sure if the game requires XNA, OpenAL, .net or the like, but JoelFB probably knows, and any of those it uses it might be worth removing and reinstalling.

6.) Reinstall the game fully from Steam, and see if you get any further. I don't recall needing any compatibility options, but I think I run steam in general as admin.

NOTE: You want to do a fresh boot between each of those steps above to be on the safe side.

If something there doesn't cover it, its probably really quirky, and I'm out of ideas. Though as a final note, make sure you are running the setup/config utility before the game to make sure you have valid settings you want before actually trying to launch the game. Something strange like an invalid resolution or refresh rate might cause the game to bork without loading.

shimmerdoom
06-13-2011, 07:20 PM
I'm having similar issues, Shadowgrounds fails to launch, it gives no on screen errors but the event log shows that it had an error I've reinstalled the game twice, tried running as admin, restarted steam, restarted the computer, installed the newest nVidia driver pack, played through Trine (admittedly didn't have any troubleshooting relevance)

Windows: Windows 7 Professional Edition (64-bit) (Build 7600)
Memory (RAM): 4061 MB
CPU Info: Intel(R) Core(TM)2 Duo CPU T6600 @ 2.20GHz
Display Adapters: NVIDIA GeForce GT 130M


here's what widows log viewer gives me
Log Name: Application
Source: Application Error
Date: 6/13/2011 8:11:41 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: TentapusMK3
Description:
Faulting application name: Shadowgrounds.exe, version: 1.0.0.1, time stamp: 0x44ed9d94
Faulting module name: Shadowgrounds.exe, version: 1.0.0.1, time stamp: 0x44ed9d94
Exception code: 0xc0000005
Fault offset: 0x0023e254
Faulting process id: 0x1ae4
Faulting application start time: 0x01cc2a300420ab51
Faulting application path: c:\program files (x86)\steam\steamapps\common\shadowgrounds\Shadowg rounds.exe
Faulting module path: c:\program files (x86)\steam\steamapps\common\shadowgrounds\Shadowg rounds.exe
Report Id: 427aed85-9623-11e0-9172-8763ba1294cc
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2011-06-14T01:11:41.000000000Z" />
<EventRecordID>27736</EventRecordID>
<Channel>Application</Channel>
<Computer>TentapusMK3</Computer>
<Security />
</System>
<EventData>
<Data>Shadowgrounds.exe</Data>
<Data>1.0.0.1</Data>
<Data>44ed9d94</Data>
<Data>Shadowgrounds.exe</Data>
<Data>1.0.0.1</Data>
<Data>44ed9d94</Data>
<Data>c0000005</Data>
<Data>0023e254</Data>
<Data>1ae4</Data>
<Data>01cc2a300420ab51</Data>
<Data>c:\program files (x86)\steam\steamapps\common\shadowgrounds\Shadowg rounds.exe</Data>
<Data>c:\program files (x86)\steam\steamapps\common\shadowgrounds\Shadowg rounds.exe</Data>
<Data>427aed85-9623-11e0-9172-8763ba1294cc</Data>
</EventData>
</Event>

also used process monitor during an attempt to launch but since it is ~70Mb I'll only bother uploading it somewhere if it's needed

JoelFB
06-13-2011, 11:55 PM
I'll PM you both, to speed things up... These issues tend to be rather strange.

SG (nor any of our Windows versions) do not use XNA, OpenAL, .Net or any other such library. The only things the game needs are WMV codecs (should be included with the installer - or in the Steam folder as a separate installer), and a reasonably new DirectX.

Shadowgrounds Survivor and Trine also need PhysX (but it's not used in SG).

Thanks poleritude for helping out, good stuff (should copy some of that for my regular array of suggestions, heh). :)

xiriod
06-14-2011, 01:51 AM
One thing to try is to turn off DEP (Data Execution Prevention) completely and see how that goes. Have a look here: http://technet.microsoft.com/en-us/library/cc738483%28WS.10%29.aspx for some information. BEX'errors may come from this being turned on.

Kronk
06-15-2011, 02:17 PM
Problem Solved!

Thank you Xiriod! Turning of Data Execution Prevention for Shadowgrounds and the launcher fixed the problem. I can now start Shadowgrounds with no crash.

Hooray Xiriod! :D

xiriod
06-15-2011, 02:33 PM
Happy to be of help, and glad you got it working :) DEP can really cause problems with some applications and games.

JoelFB
06-16-2011, 04:19 AM
This is great to hear, thanks a lot xiriod. I'm going to add this to our FAQ once I have some time. :) (We got shimmerdoom's problem fixed as well so this thread is now solved.)

Enjoy the game, Kronk. :)

aldaris
11-26-2013, 05:02 PM
I am faced with the same problem. Can you help me? (I'm sorry. I'm from Turkey. My English very little)