PDA

View Full Version : Account not recognized


Zoidberg
06-16-2011, 10:25 AM
Created the PW account, each time I try to login it says "incorrect login/password", rechecked my login and password and it's correct.

Guess I won't be playing this.

Kantorek
06-16-2011, 10:51 AM
Hi there,

Could you tell me what link you used to register?

Also, after registering, did you successfully activate your account via the email verification?

-Kanto

Fuhckerschite
06-16-2011, 02:48 PM
I have had to same problem. My account has been activated via email, I have checked and re-checked password and username, and i have made sure to type it in correctly(case sensi). It still does not work. What the eff. Is this why it's free. I have noticed how many posts there are about how buggy this is. It's a shame, all of the other F2P games have worked fine for me.

Simian_
06-16-2011, 02:51 PM
I tried registration from two different browsers. The first time I was not sent a confirmation email, yet the registration page told me my account was activated. The 2nd time I received a confirmation email and clicked the link before it told me I was activated.

Neither account works. I am fed up with this. I spent at least two hours trying to figure this out yesterday, and it is simply not worth the effort. Support also is terrible. They will not help with this. It's been nearly a day since I first contacted them and I have yet to receive any word.

Overall this has been frustrating and off-putting experience. I suggest people do not waste their time with this.

ZanyCynic
06-16-2011, 04:58 PM
I registered via firefox and did not get any mail but my account is working.

My girl friend registered via firefox too and got an email and verified the account and the account is not working.
Even when she is asking via username-forgotten dialog for her username, it tells her, that that email is not registered.

She did it two times with different names and emails.
Completely different email-domains. Twice the same :-(

Stormscape
06-16-2011, 07:20 PM
I'm having same problem. Registered via firefox, claims it activated no problem. Try to login, says wrong username/password. Tried to do forgot username/password, says account doesn't exist. Tried to make another account via Steam, and it wouldn't even activate.

Simian_
06-16-2011, 08:11 PM
Support finally got around to responding to me. They claimed they fixed my account, but I haven't bothered to check and see if they actually did. As I already told them, I won't bother playing their game because of the hassle and frustration involved just in getting a working account.

I don't really think I'm missing much either. I'm told the graphics are terrible and their preview screenshots are doctored, and supposedly the game isn't really that fun anyway.

PyroToaster
06-16-2011, 09:39 PM
Registered by clicking the ingame "register" link, then filled in the details using Firefox, but it won't let me log in and claims the email that I activated it from isn't linked to an account. Same problem as everybody else, I guess..

Zoidberg
06-16-2011, 11:45 PM
Hi there,

Could you tell me what link you used to register?

Also, after registering, did you successfully activate your account via the email verification?

-Kanto

I clicked on register in-game and it brought the Steam integrated browser.

And I activated the account yeah.

I've remarked the mails took quite some time to arrive (several minutes), generally those are like instantaneous or almost.

Korppu3
06-17-2011, 02:34 AM
Had the same problem.
First, I registered two times via Mozilla Firefox. Got the confirmation E-mail no problem, but it still said that my account didn't exist.
Then I tried Google Chrome and then it worked.
No idea why it doesn't work with Firefox..

Tiabhal
06-17-2011, 05:22 AM
Same problem here. sorry for bad english

i had registered 2 account (tiabhal and tiabhal86).
the game always say that are incorrect,but when i'll try to make a third account with this 2 nick (in the website of perfectworld) it say that are already used. and the confirmation email is not arrived


and Facebook connect doesn't work

.O.
06-17-2011, 05:27 AM
i registered with chrome and it works fine, maybe the website just doesn't like firefox

Tiabhal
06-17-2011, 05:39 AM
i registered with chrome and it works fine, maybe the website just doesn't like firefox


i've tried with FF4 and Chrome

Cranial Vacancy
06-17-2011, 06:01 AM
Yea I have tried FF, IE and Chrome to register so my daughter can try this game. Tried the link given here by the guy associated with the game, the in game directed link and the one from the Perfect World site. All attempts give an error of some sort.

darkroastbeans
06-17-2011, 07:20 AM
I am very frustrated with this. I sent PW support an email with this issue, and they responded by saying that it had been entered into their help system, and that I could log in to see responses. Problem is, I can't log in to the site OR the game. If I use the "forgot username" or "forgot password" functionality on the site, it says my email address hasn't been registered, but if I try to register again and use the same email address, the site says it is already in use! I emailed PW support *again* and they replied saying the account was active, but it is clearly not. DO NOT PLAY THIS GAME. There are plenty of other quality F2P games from better companies, such as Allods Online from gPotato.

CourierAl
06-17-2011, 09:43 AM
The thing for me is that I didn't get my email confirmation yet. Do I have to wait?

thorvindr
06-17-2011, 05:00 PM
Yeah. Having the same problem here. I'll try a different game. Not worth the hassle.

Kador01
06-17-2011, 06:50 PM
Registered by clicking the ingame "register" link, then filled in the details using Firefox, but it won't let me log in and claims the email that I activated it from isn't linked to an account. Same problem as everybody else, I guess..

I had the exact same problem. Never got any email for confirmation either or even a mention that I should get an email.

You people are going to lose all of your new users from the big Steam promotion if you dont get this sorted out.

I ended up using the link from the sticky here and making another account and that one worked but how many people are going to figure that out? Everyone is going to try the link from the launcher and that is not working at all.

Cranial Vacancy
06-17-2011, 07:25 PM
I wasn't able to get this working through any of the registration links even the sticky posted here. I sent a ticket to the game support over 24 hrs ago and no response. I finally just uninstalled the game and bought my daughter Fable III. Seems Torchlight is also one of their games and I bought that for my daughter a few months ago and she likes the pet and playing that. This could be good game too, but even a "we are having trouble with our registration right now give us 24 hrs to straighten things out" would be better than no response. I am also someone who would throw some money toward the game if my daughter liked it, so it's their loss.

HankTheHonk
06-18-2011, 01:10 PM
I have the exactly the same problem like the OP.
I registered via FF, got the activation email, activated via the sent link but the game says me "Incorrect Username/Password". When using the option "Forgot Username/Password" it says there is no account bound to my email address.

Please keep me up-to-date if and when the problem is going to get fixed.

Alixxy
06-19-2011, 03:15 AM
Same here, just sent a mail to Forsaken World customer support.

Tried to register, after hitting 'create account' something went wrong, tried it second time with the same information, now it says 'my' account exists... Did not receive a registration mail nor do I've a chance to reset my account password. Both the same to steam & forsaken worlds homepage account creation.

OK guys, what's going on?

Orclev
06-19-2011, 03:49 AM
I'm going to chime in here to more or less say "me too". Pretty much the exact same experience as the OP. I registered through the link on the launcher, did it in FF, and received my registration e-mail. Clicked the link in the e-mail and got a page saying the account had been activated, so far so good. Then I tried to log in, and got an error saying username or password was wrong. Tried it a couple times just to be sure I didn't make a mistake typing the password. After that didn't work, I figured maybe I screwed up the password when I registered, so I go to the site and try the forgot password link. Surprise, it says the e-mail address I provided isn't tied to any account. At this point I'm thinking WTF is going on here, but wait, it gets worse.

So, it tells me the account isn't working so I figure I'll try to re-register, maybe my original registration got lost or something. When I try that, then I get an error saying the username and e-mail I entered are already in use. For those keeping track, it's now said my e-mail/username are invalid, in use, and don't exist at various times depending on which form or application you attempt to login from.

At this point I've pretty much figured out my account is totally screwed up somehow and the only fix is to get tech support to go un-break my account, so I go to contact them. Only option I can find after digging through their totally useless support page is to send an e-mail to them, which I do. After a bit I get an e-mail back telling me the ticket has been filed, and to find out the details of it I need to... wait for it... log into the support site using my account... you know, the one that's broken and that I'm e-mailing them about. So yeah, that works awesome, as in, not at all. Eventually I get an e-mail back from them saying they manually verified my e-mail address on my account... which is totally not what I said the problem was (I think they're just responding to anyone that complains about login issues as if they never clicked the verify e-mail link in their mailbox), and that if I have further problems to update the ticket. On their website. Which I need to login to. :confused:... :mad:.

Interestingly enough, when I attempt to log in to the support site, I get yet another error message which says that I've got to many failed logins.

The only thing I can figure is that they didn't prepare for the number of users they'd get from steam and their system occasionally completely breaks during registration resulting in a completely unusable account. Unfortunately it seems like this also means that whatever e-mail address you used to register can never again be used for registering on their games. It's been over 48 hours now since I contacted their support, and over 24 hours since they responded to tell me they had "fixed" my account, which incidentally is still totally broken. I've yet to receive any further e-mails from them, and I'm not particularly hopeful that I ever will. I'm going to seriously recommend to all my friends and anyone else that will listen to at the very list avoid this game for a few months until they can straighten our their registration process.

Orclev
06-19-2011, 12:08 PM
Just a brief update. Account still broken. Still no response from tech support. And in other news, Champions Online is rather fun, and has already managed to earn some of my hard earned cash. Not really all that hard, you just need to meet a certain minimal threshold that unfortunately for Forsaken World involves a working registration process :p.

Smertnik
06-22-2011, 08:09 AM
Same issue, got the activation email and all but can't log in anywhere. And if I try out the recovery option it says my email isn't linked to any account. Support doesn't reply, either.

Stuff like this shouldn't happen.

Den
06-22-2011, 05:40 PM
I made an account awhile ago and it worked first shot, so I had wondered what was going on around here.
Just to see if people were making things up, I tried to make another account.

3 spent email adresses later and 3 useless accounts locked in limbo, my 4th account was created successfully. Oddly, without any need for email verification.

It's a good thing gmail accounts can be set up quick and easy. I just wasted a bunch of them trying to get another account.

The best advice you are going to get is to keep trying to make your account and try to log into the game after you create it. If it doesn't work, keep at it. However I do feel bad for people who've tried and tried and keep failing through no fault of their own. Something not right over there at the PW account creation process.

If for some reason the account is created instantly and there was no need for an email verification code, then it might be working.

Suicide
06-22-2011, 05:54 PM
I had this problem once but I had to wait a few days (1-2) for them to activate my account. I'm surprised it hasn't been fixed yet.

Demonburnt
06-29-2011, 01:38 AM
Registered and can't log in.(activated etc) When i go recover password it says my account doesn't exist but when i try to create account again it says that my username and email are already registered.

Hofulu
06-29-2011, 10:04 AM
Support finally got around to responding to me. They claimed they fixed my account, but I haven't bothered to check and see if they actually did. As I already told them, I won't bother playing their game because of the hassle and frustration involved just in getting a working account.

I don't really think I'm missing much either. I'm told the graphics are terrible and their preview screenshots are doctored, and supposedly the game isn't really that fun anyway.

did you go to graphics settings?