PDA

View Full Version : Game is currently unavailable


cubevision
06-21-2011, 02:58 PM
The night before last I had to reformat my C drive after a crash. Before this, my game was working fine but after reinstalling all my drivers, steam and AA I would get this message saying "This Game is currently unavailable".
After doing some searching, I found this link (https://support.steampowered.com/kb_article.php?ref=4595-WEXN-6831) taking me to an article on steam's website giving about 8 steps to fix this problem.
So far I've tried:
The steps on that webpage
Opening up ports on my router (recommended from the steam website)
Connecting directly to the modem
Running without the firewall running
Running with the firewall and no exceptions
Running with the firewall and an exception for steam and aa3

I've also tried reinstalling steam as well as having downloaded the aa3 file twice. The only other game I have on steam loads fine (Fallout: New Vegas) although my save files were deleted =(
I'd appreciate any suggestions.

EDIT: After trying everything and waiting for a response, i tried once again to open it up and it worked. As far as I can tell, it was simple available later.