PDA

View Full Version : I'm suddenly forced to press-and-hold in order to Focus! (STEAM).


Nudz
06-22-2011, 08:59 AM
Normally, I'd need to press CAPS LOCK once in order to enter Focus Mode, and press once again in order to exit. However, I just had to fight the "Menacing Ruin" -miniboss, (the part where you first get the Umbrella.), where I had to mess around with my key-bindings in order to get the blocking to work. Finally I got it working, but now, Focusing is suddenly done by pressing-and-holding, rather than just clicking once! :mad: This is incredibly irritating, and makes combat almost impossible for me.

I have tried restoring the key bindings to "Default", restarting the game multiple times, and verifying the integrity of the game cache. No luck. I'm at loss as to what to do, here. Please help. :confused:

gentlefury
06-22-2011, 09:03 AM
I've seen this a few times, it could have to do with Steam....I have a few games that screws with caps lock. I will go into the in-game steam overlay browser and it will be in caps lock even tho its not and I have to turn on caps lock to turn it off. Alice seems to have a lot of sticky key problems...I will have direction keys stick all the time and have to hit escape to stop her from running off cliffs. It's overall a pretty buggy game.

AznBoy222
06-22-2011, 09:17 AM
In configuration, controls, and finally camera, there should be an option to change focus into either toggle or hold.

MADDOGGE
06-22-2011, 09:27 AM
I've had it do so on occasion as well usually if I move some and try again it works other time I just have to hold it. As I have it on Origin, it's not Steam related.

-GS-
05-30-2012, 02:36 PM
In configuration, controls, and finally camera, there should be an option to change focus into either toggle or hold.

Yes, there is, although at first discovering what had gone wrong really drove me mad. I didn't remember about this option: during the first battle against the Menacing Ruin I just thought the game was bugged. Up to that point the focus command had always worked as a toggle: after trying to fix the infamous umbrella bug by restoring the default key configuration (I had re-mapped my bindings), the toggle had reverted to a hold. Defeating the Ruin continuously holding the button instead of using a toggle has been a real pain... then I remembered about this option in the "camera" menu. When it was too late.

Is it just me or do you too find the controls to be quite uncomfortable/unpolished? There are a lot of different buttons to remember, and many of them could have been spared if they had been context-sensitive (the "interact" command, for example, or jumping/dodging). By the way, I'm using Keyboard + Mouse (not a controller).