PDA

View Full Version : Mouse Lag


krimson714
07-05-2011, 07:27 AM
So when I go to play the game I tend to have issues with my mouse. The graphics and everything are really smooth but for some reason when I only move my mouse slightly it does not respond at all, instead I have to basically move it from one side of the mouse pad to the other at a pretty decent speed to get it to respond. A lot of people had this same problem with the game Ark Fatalis and the only way I was able to fix it was to play the game in window mode.

I use
- logitech G500 gaming mouse
- ATI Radeon HD 5700 video card.
- Windows 7 64bit(it says its running in windows 2000 compatibility mode)

Any Ideas?

BishopWonDai
03-07-2012, 01:02 PM
same problem, same mouse Logitech G500, same OS

I had success uninstalling the mouse device then just using the windows hid driver

this worked for one session but after a reboot its back to feeling locked to the x/y axis and small movements don't register

HRPuffN
06-09-2012, 07:36 PM
I found that disabling Window's "Enhance pointer precision" control in the Control Panel\Mouse settings, "Pointer Options" tab, fixed this issue.

Arclayn
07-30-2012, 02:00 AM
I found that disabling Window's "Enhance pointer precision" control in the Control Panel\Mouse settings, "Pointer Options" tab, fixed this issue.

I have a Logitech G700 mouse (supposedly uses the same SetPoint driver as G9x and G500) and I was experiencing similar mouse lag. However, I found an alternative solution to changing system-wide settings in the Windows control panel.

Go into SetPoint and create a new profile for Sacrifice. For convenience, you can have it switch automatically on application detection with sacrifice.exe.
In the new profile, under "pointer", uncheck Use native OS drivers for pointer speed and acceleration.
You may need to slow down SetPoint's pointer speed and/or acceleration. I'm doing okay at 3 speed and 1 acceleration.
You may need to reduce the polling rate. I'm doing okay at 250 reports/second. If it doesn't work for you, go lower.
You may need to reduce the dpi. I am doing okay with 1 dpi level at 2000 (both X and Y). Go lower if you need to.
And from there I adjusted the mouse speed in the game to tweak its response.


I wouldn't worry about reducing the mouse polling rate and dpi. It's not like you use the mouse for movement and need pinpoint precision. This looks like the kind of thing where "mileage may vary," so you may get away with higher settings than I did. But don't fret if you need to go lower.
Checking Enable angle snapping (slightly smooths mouse motion to move straighter) in the profile didn't negatively affect me, and it may help with mouse jitteriness should you experience any.
I played through four campaign levels without any mouse lag and a reboot of my computer didn't break anything.

Seems to me whatever timing mechanism is programmed into Sacrifice, it does not seem to deal well with the kind of speed or data throughput that modern gaming mice can operate at these days.