PDA

View Full Version : Crash upon startup


Tehkrann
07-16-2011, 05:01 PM
I bought swords and soldiers about a month ago during one of the specials they had on the indie packs. But I've never been able to play it because it crashes upon startup. I can start the game and the launcher will load up, but once I click save and play, the screen flashes black once, and it quits out, saying "Swords and Soldiers HD has stopped working". I've tried different resolutions and video qualities and reinstalling as well. Does anybody know the underlying issue here and how to fix it? Much appreciated, thanks.

Krann

Ronimo Joost
07-17-2011, 10:59 AM
I don't know what is wrong exactly from this description, but could you try a couple of things and let me know what happens?

-Have you tried clicking "Verify integrity of Steam cache" in Steam?

-Could you try running "Steam\steamapps\common\swords and soldiers\Data\VCRedist\vcredist_x86.exe"? Does it work afterwards?

-If both of the above don't work: what kind of videocard and Windows version do you have, and have you tried installing the latest drivers for your videocard?

Tehkrann
07-19-2011, 04:03 AM
I have previously tried the "verify integrity of steam" and i just tried the VCredist as well to no avail. I'm currently running Windows 7 personal on a laptop with integrated graphics. I assumed that integrated graphics would not be a problem since the game didn't seem to be too video card intensive. Was I wrong in thinking this?

Ah well, I purchased this game to play while I am overseas but I guess I may have to wait to get home to my desktop...

Ronimo Joost
07-19-2011, 08:19 AM
Swords & Soldiers should indeed run well on integrated graphics cards. The Low graphics quality is for that, since some of them won't be able to run High. Low should work on almost anything.

Have you tried installing the newest drivers for your videocard? Integrated graphics chips still have drivers that sometimes need to be updated.

If that doesn't fix it, could you send me your Application.log file? My email is joost -at- ronimo-games.com.

Ronimo Joost
07-20-2011, 05:25 AM
Thanks for sending me the log, and for trying to install new drivers!

I can see in the log that the problem is that you don't have a version of OpenGL installed. This is strange, because OpenGL should come with your drivers. By default Windows 7 doesn't have a proper version of OpenGL, so this happens a lot. This is the first time I hear that installing drivers doesn't fix it, though. :(

So this issue is quite strange and an error in your drivers, not in Swords & Soldiers. I have heard rumours that in this case it may help to remove old drivers completely before installing new ones, for example using a thorough program like Driver Cleaner. If that doesn't help, then I advice mailing your videocard manufacturer and asking them for a solution, since this is really an error on their side.

The reason other games are working, by the way, is that they use DirectX instead of OpenGL. Both are pieces of software that allow games to show graphics on the screen.

Ronimo Joost
07-20-2011, 05:27 AM
Ow, by the way, this is what OpenGL reports, in case you need to show to Intel that OpenGL hasn't been installed properly:

OpenGL GL_VENDOR: Microsoft Corporation
OpenGL GL_RENDERER: GDI Generic
OpenGL GL_VERSION: 1.1.0
OpenGL GL_EXTENSIONS: GL_WIN_swap_hint, GL_EXT_bgra, GL_EXT_paletted_texture