PDA

View Full Version : Game consistently crashes.


cashomoney
07-21-2011, 04:02 PM
Bought the game a little bit ago, kept on crashing. Waited for a new graphic card update and tried again recently.I tried updating the game via the update link in the steam install folder, I found an update. Still crashes. Game version when launched is 6.8.1 I believe.

Play the game for a little bit, crash. Any country or scenario. ( and by crash, the majority of the time it just locks up my computer completely. I wanna say over heating... but nothing is, and it only does it with this copy. I've tried a retail copy from a friend in the past and it worked perfectly fine.)

Graphics card is up to date, same for Directx. ( and generally the rest of the computer.)

Any suggestions? ( Other then try compatibility mode. It doesn't make a difference, still crashes.

General Computer Specs:
Windows 7 x64 bit Build 7601 ( retail copy, fully up to date )
Motherboard : M3N WS
AMD Quad core 9950 2.6 Ghz Processor.
8192mb of 800Mhz ram.
Graphic card : XFX6950 xxx edition

download link to dxdiagx64 . Don't know live link policy, just say so and I'll break it.
http://www.megaupload.com/?d=26Y6128S


Likely final edit : Supreme Ruler Cold War does it as well. Ugh, I'll probably just play x3/ x3 tc instead. Oh wells.

Balthagor
07-22-2011, 04:49 AM
I'll point our programmer to your DXDiag and ask him to take a look but we haven't had a reported crash in months. Is it crashing at the same point every time?

cashomoney
07-22-2011, 04:04 PM
No it's something around 15 minutes playing. But not always that. Could be 2 minutes to 30. Guaranteed crash though( generally lower end. 2-10 minutes ). It's extremely random and haven't seen anyone with that problem in the past. I wanna say it's hardware related, but it's only with this game. So I'm guessing ati catalyst driver maybe...

EDIT: Running the program a few times with a gpu hardware monitor open. Temps peak and steady at 53C or 127F. Well within safety levels. GPU is well... here's the log. It goes from game start to crash. "2011-07-22 15:35:38" is when I turned the computer back on. I don't know exactly when the screen locked up, so it may have kept recording temps and stuff ( at least until I turned the power off anyways ).

Link to GPU Log : http://www.megaupload.com/?d=MWSJ3VDS

I'd point you towards a log for everything else but I can't seem to find a program that will log to a text file for cpu etc.

EDIT: re-installing mobo / gpu drivers. Graphic done, newer mobo drivers just bluescreen me. :/ figures, though... what they call "windows 7" is clearly the same thing as the vista ones.

Final Edit: Seems to be working now. Unsure why. Crashed even when the new graphic card driver was installed. But installed the mobo drivers( caused bluescreen on startup...) so I rolled the computer back to before I installed the driver. Games works now :/ Don't know why.

kurt_81
07-29-2011, 03:54 AM
just wanted to says i have same problem. its really random usualy around 10 to 15 min of play.

adriaans
07-29-2011, 02:55 PM
Ignore GPU for this game as this game primarily places lots of load the the CPU, so if looking at tempts that's where you should look.

kurt_81
07-30-2011, 03:14 AM
i reset all the option and the game was going fine. no lag at all even when scroling the map with a lot of battle going on. i played for like 3 or 4 hour strait. then i chek the option to show the path line of the unit and the game start lagging until it froze my computer after 5 or 10 min.

cashomoney
07-31-2011, 04:38 PM
Aye, it's more cpu intensive. But cpu temps are low. :/ CPU usage not over half. It worked for a few days, but now just crashes. It's a oh wells basically.

swarfega
08-02-2011, 11:46 AM
Cold war just crashed for me. Admittedly its the first time it has done so since I bought it yesterday morning. Ive 11 hours.

Balthagor
08-18-2011, 01:57 PM
@cashomoney - still having problems? We've got no other crash reports for SR2020, haven't for a while. E-mail support@battlegoat.com if you're still having issues.

swarfega
08-24-2011, 10:26 AM
Ive had this for ages as my earlier post indicated. It would crash when you first quit a game and then quit the game altogether before the background music started.

Today I have been trying to play but it keeps crashing :/ Is there any way I can send you a bug report?

Balthagor
08-30-2011, 01:17 PM
Ive had this for ages as my earlier post indicated. It would crash when you first quit a game and then quit the game altogether before the background music started.

Today I have been trying to play but it keeps crashing :/ Is there any way I can send you a bug report?
If you're talking about SR-CW, it would be better to post in the development forum or the Paradox forum since this is for SR2020.

http://www.bgforums.com/forums/index.php
http://forum.paradoxplaza.com/forum/forum.php?

Send an e-mail to support@battlegoat.com if you like and we can do tech support by e-mail. Do be sure you have the latest update.

swarfega
08-30-2011, 04:22 PM
its strange then that I cannot see 2020 listed on steam store...

Balthagor
08-30-2011, 04:29 PM
Indeed, more keys where sent to them but the game just disappeared...

Securion
04-20-2012, 04:53 PM
SR2020 Gold, latest update, crash/freeze my computer after 15 min.

Plays dozens of other games and no crashes ever.

:mad: