PDA

View Full Version : How to configure a Server.cfg for HL2MP?


Gymnae
12-10-2004, 11:12 AM
Hi,
I read through many posts and used the search feature, and there's this one question some have asked and wasn't answered yet.

I'm a total newbie and stuck at some points.


So I begin with the main problem.
How to configure a server.cfg file for Half Life 2 Death Match. I found some sample files, but they were for HL1 and CS or CS:Source.
My Server should run online and in LAN and must be password protected (it's a small server)

Second Problem is, I forwarded all the ports neede (according to portforward.com and the Steam Support) and when starting the server,

I get this output:
WARNING: NNET_OpenSocket: bind: Cannot assign requested address
Couldn't allocate dedicated server UDP port
cat: hlds.1620.pid: Datei oder Verzeichnis nicht gefunden
email debug.log to linux@valvesoftware.com
Fr Dez 10 20:23:23 CET 2004: Server restart in 10 seconds

The german line sais, it can't find the preceding file or folder. Whatever that means...

I start the server with this command:
./srcds_run -console -game hl2mp +map dm_overwatch +maxplayers 5 -user xxx +ip 82.83.xxx.x -password xxxx -autoupdate -debug


Thanx for your help

pl4tinum
12-10-2004, 01:46 PM
Does your linux machine have a iptables firewall?

service iptables stop

pl4tinum
12-10-2004, 01:54 PM
and here's a sample server.cfg

// Server Name
hostname "Servername"

// RCON Password
rcon_password "secret"

// Server Password
sv_password "serverpw"

// Server Settings
mp_fraglimit 100 // kills before map change
mp_timelimit 20 // timelimit on each map
mp_weaponstay 0 // weapons stay after being picked up
mp_forcerespawn 0 // force player respawn after 4 seconds
mp_falldamage 0 // extra damage when falling
mp_teamplay 1 // set to 1 to enable teamplay
mp_teamlist "hgrunt;scientist" // team models, if mp_teamplay = 1
sv_hl2mp_weapon_respawn_time 20 // time between weapon respawns
sv_hl2mp_item_respawn_time 30 // time between non-weapon respawns
mp_footsteps 1 // enable footstep sounds
mp_flashlight 0 // flashlight in-game availability 1=yes 0=no
mp_autocrosshair 1 // show crosshairs
decalfrequency 10 // amount of decal/sprays visible
mp_allowNPCs 1 // allow computer-controlled characters
sv_alltalk 0
sv_gravity 600 // server gravity level (default=600)
sv_stopspeed 100 // speed at which a player stops while running
sv_noclipaccelerate 5
sv_noclipspeed 5
sv_specaccelerate 3
sv_specnoclip 1
sv_maxspeed 320 // runspeed on the server, default=320
sv_accelerate 10 // speed of movement
sv_airaccelerate 10 // speed of movement in air
sv_wateraccelerate 10 // speed moving in water
sv_footsteps 1 // enable footsteps
sv_rollspeed 200
sv_rollangle 0
sv_friction 4 // when bumping into a wall, slows you down
sv_bounce 0
sv_stepsize 18 // distance covered with each step
r_VehicleViewDampen 1
r_JeepViewDampenFreq 7.0
r_JeepViewZHeight 10.0
r_AirboatViewDampenFreq 7.0
r_AirboatViewDampenDamp 1.0
r_AirboatViewZHeight 0.0
mp_friendlyfire 0 // friendly fire, 0=off, 1=on
coop 0 // cooperative play mode
deathmatch 1 // deathmatch mode enabled = 1
sv_voiceenable 1 // enable speech in-game
sv_pausable 0 // enable server pausing
sv_cheats 0 // disable cheats = 0

Gymnae
12-10-2004, 04:17 PM
Hi,

I run a SusE 9.2 Linux "Server"
and I should have the Yast Firewall running, but I put it off...

the command you tiped doesn't work, and the help printed out via iptables --help
don't show the command to quit...

But it seams the service is started, as it reply to commands...


I'll the server.cfg you gave me, thanx

Gymnae
12-10-2004, 04:37 PM
Hi,

I run a SusE 9.2 Linux "Server"
and I should have the Yast Firewall running, but I put it off...

the command you tiped doesn't work, and the help printed out via iptables --help
don't show the command to quit...

But it seams the service is started, as it reply to commands...


I'll the server.cfg you gave me, thanx