PDA

View Full Version : Slip sliding away...


Tellic
08-06-2011, 02:47 AM
Hi, I've been searching for threads on sliding and/or momentum, but couldn't find any.

Is there a way to stop your character from continuing to move AFTER you have stopped pressing the movement button.

It feels like I'm playing on ice skates and I keep sliding past things I want to click on :eek:

McChadworth
08-06-2011, 07:55 AM
Hi, I've been searching for threads on sliding and/or momentum, but couldn't find any.

Is there a way to stop your character from continuing to move AFTER you have stopped pressing the movement button.

It feels like I'm playing on ice skates and I keep sliding past things I want to click on :eek:
Not that I know of, but you may be able to change the inertia in the ini. file.

When I can not stop on a tight spot, I use the shift button to walk. You become much more precise.

Ardbug
08-06-2011, 08:49 AM
Hi, I've been searching for threads on sliding and/or momentum, but couldn't find any.

Is there a way to stop your character from continuing to move AFTER you have stopped pressing the movement button.

It feels like I'm playing on ice skates and I keep sliding past things I want to click on :eek:

Yeah I have that problem too, I found that the explorer browser will make the character slide around if you have one or more windows opened in the background, try closing them.

Wesp5
08-06-2011, 09:24 AM
Win98 compatibility mode is supposed to fix this bug...

Tellic
08-07-2011, 03:11 AM
Oh well, thanks for the replies ;)
I play with no other windows open, have looked in the .cfg files, and tried Win98 compatibility... all to no avail.

This is a great game, and I'm not sure I'm complaining about a 'bug' - the sliding seems to me to happen in a few Source games and looks like a deliberate physics 'effect'; it just seems more noticable somehow in this game - perhaps because unlike vanilla FPS games, this one requires you to interact with nearby objects that are often on the small side...

But I can live with it for such a good game - especially with the updates from Wesp ;)

Ratspootin
08-12-2011, 06:09 PM
I dug around some Half-life forums and found the code to adjust the sliding:

sv_friction "4"

The default is 4. The lower the number, the more you slide. I set mine to 8.

1) Put "-console" in the game's shortcut target. You can also right click on the game in Steam, choose Properties, then "Set launch options" and add "-console".
2) When the console pops up automatically after the intro videos, type sv_friction "8"
3) Close the console and load your game. No more ice skating!

The bad news is you'll have to do this every time the game loads. You can also add the code to the config.cfg file, but the file overwrites once the game loads.

BTW try not to hit the ~ key by accident. If you load the console during the game, you can't move. Type "exit" to close the game.

Wesp5
08-13-2011, 01:02 AM
BTW try not to hit the ~ key by accident. If you load the console during the game, you can't move.

If that happens type "chareditor" and continue from there.