PDA

View Full Version : GTA IV MP: Can't connect to games with one LIVE friend


OwMyToe
08-07-2011, 11:36 PM
I haven't had a lot of luck finding anything online, I'll keep looking and if I find something I'll update this thread.

I've got a friend that I can't connect to for MP - we tried taking turns hosting, we tried connecting to the same public game. As it turns out I could connect to the pub game but he was unable to connect, and vice versa. We have a mutual friend - either of us can play with this third person (hosted or pub, we tried both) but we two couldn't connect to the same game. Totally weird.

We are all Steam and LIVE friends.

Anyone else have this problem? Any idea what's up and how we can fix it?

FusedCore
08-08-2011, 12:05 AM
Are you or him using any mods? and did you both buy the game?

Deadly_Target
08-08-2011, 12:14 AM
We have a mutual friend - either of us can play with this third person (hosted or pub, we tried both) but we two couldn't connect to the same game.
That is very odd. Perhaps you should try going to your friend's profile and submitting a positive review for him. Supposedly, that will increase the chance of you two playing together or something like that. I'm not too familiar with Live unfortunately.

If all else fails, you could try this (http://iv-multiplayer.com/). I've never tried it myself and I've heard it's pretty buggy, but it should get the job done.

zodaex
08-08-2011, 12:55 AM
Its cause you cant invite friends to ranked games. Try hosting some unranked games.

OwMyToe
08-08-2011, 01:22 AM
Are you or him using any mods? and did you both buy the game?

No mods, and yes, we both bought it and are playing through Steam. I had to change the executable to play in Compatibility mode in order to launch with Steam, but I tried starting my game through Steam and also directly through the exe as well with the same result.

Its cause you cant invite friends to ranked games. Try hosting some unranked games.

All of the games we have tried have been unranked. Both the ones we hosted and the ones we joined.

We have tried the following scenarios:

1. Friend hosts, I cannot join.
2. I host, friend cannot join.
3. I find public game and join (can see other players), he cannot join.
4. Friend finds SAME public game and joins (can see other players), I cannot join.
5. Mutual friend hosts, I can join, friend cannot join.
6. Mutual friend hosts, friend can join, I cannot join.
7. Mutual friend finds public game, I can join, friend cannot join.
8. Mutual friend finds public game, friend can join, I cannot join.

Get the picture? So out of the three of us ONE of us can play with EITHER of the other two, but not both at the same time.

As I said we are all Steam and Windows LIVE friends. We all have legit copies of the game purchased through Steam, no mods or cheats.

OwMyToe
08-08-2011, 01:24 AM
That is very odd. Perhaps you should try going to your friend's profile and submitting a positive review for him. Supposedly, that will increase the chance of you two playing together or something like that. I'm not too familiar with Live unfortunately.

If all else fails, you could try this (http://iv-multiplayer.com/). I've never tried it myself and I've heard it's pretty buggy, but it should get the job done.

I'll try the first and look into the second - thanks for the tip. :)

Discopanda
08-08-2011, 09:37 AM
I am the friend, and it is really lame that we can't play together... but hey, hopefully the mod works!

FusedCore
08-08-2011, 10:28 AM
Please explain How are you two trying to setup the game?

OwMyToe
08-08-2011, 11:14 AM
Please explain How are you two trying to setup the game?

Was my post #5 not detailed enough?

Discopanda
08-08-2011, 12:24 PM
All we want to do is play together. The problem is that we can't be in the same game. If I am in a game, Toe can't join. If I leave, she is able to join that game. If she is in a game, I can't join it. If she leaves, I can join that game. It is frustrating and quite confusing!

Deadly_Target
08-08-2011, 12:41 PM
I searched around and others seem to have this problem too:
http://www.gtaforums.com/index.php?showtopic=436337
http://www.gtaforums.com/index.php?showtopic=480430
http://www.gtaforums.com/index.php?showtopic=342566

A GTAForums admin had this to say about the issue:
This sounds like the classic NAT connectivity limitations you get with Xbox Live - I imagine Windows Live works in much the same way. If your connection isn't properly configured, people won't be able to connect to lobbies you start, and you won't be able to connect to lobbies anyone else has started.

When running the game, open up the Windows Live menu, navigate to Settings, and then somewhere there you should find a Network troubleshooter. That will most likely report that you are connected to Live, but have 'strict NAT'. This basically means your ports haven't all been successfully forwarded - if you can confirm this is the output then we know where the problem is.

How are you connecting to the internet? Read this (http://portforward.com/help/portforwarding.htm) on port forwarding for some more info. If you have a separate modem and router, each will need port forwarding set up to point your data to the correct location. Any break in that line and you'll get a 'strict NAT' report and Live will refuse to work properly.

That's all I could find. Good luck.

OwMyToe
08-08-2011, 07:42 PM
I searched around and others seem to have this problem too:
http://www.gtaforums.com/index.php?showtopic=436337
http://www.gtaforums.com/index.php?showtopic=480430
http://www.gtaforums.com/index.php?showtopic=342566

A GTAForums admin had this to say about the issue:


That's all I could find. Good luck.

Wow, that's a lot of great info, thanks very much for searching that up. I'll let you know if I have any success!

I'd rep you but Steam's not letting me :mad:

SmellyLethality
08-09-2011, 06:39 AM
One of her friends here. I can't connect to her games and she can't connect to mine. I can join about 30-50% of the games in the lobby, and some people can join mine when I host. I could play with one friend last night with ease.

I've noticed two different errors associated with this.

The first is "Unable to connect to the game session". This one sends you back to the server browser and allows you to continue searching.

The second one is "Disconnected from game session." This one kicks me back to single player and I have to use the phone to get back to multiplayer.

The windows live thing says my NAT is open, not strict. I haven't port forwarded anything specific to games and I don't tinker with my router and modem just to play games.

But figured I'd point out the two errors themselves and how they work differently.

OwMyToe
08-09-2011, 10:15 AM
I checked my NAT last night and it's set to "Open" as well.

Just to cross all my Ts and dot all my Is I went through my router settings and forwarded all suggested ports for GFWL. It took some finagling as I've got a server set up that runs dedservs for L4D/L4D2/TF2/MNC/Terraria so I'm testing to make sure I didn't hose those in the process. Fingers crossed! :D

OwMyToe
08-09-2011, 03:37 PM
All the ports are open, all my existing dedserv ports are still working, I can still only connect to some friends but not all. Totally weird and messed up. I guess we'll be trying IV:MP next.

SmellyLethality
08-09-2011, 04:59 PM
It's too bad this game has no dedicated servers and everything is P2P based. I don't know how 30 man rooms would even run on a P2P connection. The most I've seen was a 21 man room last night and it's ping/connection was in the red.

You'd have to have an absolute beast of a rig and a massive upload/download speed to even try it.

maniakers
04-01-2012, 04:55 AM
Hello i have this same problem with my friend ... someone have a solution how we can play together ?


We have tried the following scenarios:

1. Friend hosts, I cannot join.
2. I host, friend cannot join.
3. I find public game and join (can see other players), he cannot join.
4. Friend finds SAME public game and joins (can see other players), I cannot join.
5. Mutual friend hosts, I can join, friend cannot join.
6. Mutual friend hosts, friend can join, I cannot join.
7. Mutual friend finds public game, I can join, friend cannot join.
8. Mutual friend finds public game, friend can join, I cannot join.

Entharion
04-23-2012, 10:13 AM
I've had the exact same issue, it has to do with GFWL for sure, because we have the same issue with Section 8:Prejudice... Which uses, you guessed it... GFWL, it never works properly...

Any suggestion to fix this is appreciated...

elix
07-15-2012, 03:54 AM
I had this exact same problem, and I found a simple (but annoying) solution. I tried all the solutions so far in the thread, nothing. I could not play with one specific friend, but they could play with other friends, and I could play with those friends.

The solution (at least, it worked for me) is: Make another SILVER gamertag in GFWL. Silver gamertags are free, and once I did that, I had no problem. It worked! :D

It seems like some gamertags are just entirely incompatible with each other, which makes no sense and is rage-worthy, but I blame GFWL. :confused:

Someone else want to try it and see if I've found the answer?

Kengon
07-16-2012, 02:03 PM
I had this exact same problem, and I found a simple (but annoying) solution. I tried all the solutions so far in the thread, nothing. I could not play with one specific friend, but they could play with other friends, and I could play with those friends.

The solution (at least, it worked for me) is: Make another SILVER gamertag in GFWL. Silver gamertags are free, and once I did that, I had no problem. It worked! :D

It seems like some gamertags are just entirely incompatible with each other, which makes no sense and is rage-worthy, but I blame GFWL. :confused:

Someone else want to try it and see if I've found the answer?

Yup, this worked perfectly for me!

Thanks a bunch. Completely fixes the problem. :)

elix
07-16-2012, 02:20 PM
...of all the stupid...

But at least we know that this gets around GFWL's brain damage. To bad this is buried at the end of this thread. I wonder if someone could add this information to the fix-GTA4 stickies in the forum.

SmellyLethality
07-16-2012, 02:21 PM
I'll try this with the OP when next they get around to playing GTAIV. I'll post if it works or not.

noahpotato
04-19-2013, 06:26 PM
This didn't work for me. Made a new silver account and still the same problem. I'll try my friend trying a different account now. I'll post back with the results. :/