PDA

View Full Version : Excessive GPU Temperatures?


QualityJeverage
10-08-2011, 08:07 PM
Adore the demo, pre-ordered after one playthrough.

The game runs flawlessly at 1920x1080 with 4xAA for me, I'm on a Radeon HD6870.

Only problem is that my GPU likes to get very, very hot during this game. It approaches 80-85 Celsius during gameplay, and I start to get nervous in that neighbourhood. I've had to take to manually increasing the GPU's fan speed whenever I play the game.

This is not an issue I have in any other game. Just as an example, I've been playing both Rage and the Battlefield 3 beta, both at the highest possible settings. Both run fine, and neither approach these temperatures.

It may be a driver issue, but I've been through more driver updates and rollbacks and hotfixes in the past week than I care to admit, trying to get Rage to work properly. None of those ever had any effect on OMD or this problem.

I have difficulty imagining that Orcs Must Die requires more effort from my video card than Battlefield 3 ;) Is this an issue that's been reported by anyone else? Or is it something on my end?

Thanks in advance.

EDIT/UPDATE

A lot people seem to be suggesting the same thing without reading the thread, so I'll just update everyone here:

- Enabling Vsync solves the problem, but creates mouse lag that hurts gameplay. For the moment, I'm just manually increasing fan speed when I want to play the game.
- Modifying the Vsync settings in the Catalyst Control Panel has no effect on the game.

QualityJeverage
10-11-2011, 04:12 AM
Not usually a fan of bumping my own threads, but I think 3 days is enough time :)

I still haven't heard anything about this issue, or been able to find anyone else discussing the same thing.

Satoru
10-11-2011, 04:47 AM
Enable vsync for now. It could be related to other scenarios where a static image is constantly refreshed which causes the GPU to overheat. If thats the case then enabling vsync will cap the refresh rate and should prevent the gpu from getting too hot.

SixOkay
10-11-2011, 07:09 AM
I'll put this on the list I send over to the programmers to see if we've seen this in test or can reproduce it.

Thanks!

QualityJeverage
10-11-2011, 12:12 PM
Just confirming that enabling VSync does solve the problem, however it also introduces mouse lag. It's slight, but just enough to be noticeable and drive me crazy during gameplay. Thanks for the help though, and here's hoping you guys can find a solution :)

(On another note, hooray the game came out today! Steam was saying it would unlock tomorrow, so I was waiting for that. Lo and behold I get home from class today to find the game ready to play.)

Amy
10-11-2011, 12:15 PM
ASUS RoG Matrix GTX580 Platinium

No overheat at all, 45C all the time, a litle less than normal for all my game including Crysis and metro 2033.

Satoru
10-11-2011, 12:33 PM
Just confirming that enabling VSync does solve the problem, however it also introduces mouse lag. It's slight, but just enough to be noticeable and drive me crazy during gameplay. Thanks for the help though, and here's hoping you guys can find a solution :)

(On another note, hooray the game came out today! Steam was saying it would unlock tomorrow, so I was waiting for that. Lo and behold I get home from class today to find the game ready to play.)

See if enabling the vsync in the CCC is better than using the ingame option. Not sure if it will make a difference but worth trying.

Definitely sounds like when Starcraft2 was frying cards due to a lack of a fps cap if vsync is fixing the issue. Your card is just too powerful :)

voidfox
10-11-2011, 12:51 PM
EVGA GTX570 here and the demo brought the game temperatures of 84c at some points. I have the same issue with Dead Island.

I use EVGA Precision fan control and notice that the speed at which the fan spins at higher temps is quite low, setting it at set intervals to spin faster has kept my temperatures under control.

Not sure why it's getting so hot though, or whether that's normal or not.

deanparkr
10-11-2011, 01:03 PM
My card keeps pretty cool with OMD compared to other games. VSync is usually the answer

Vaner
10-11-2011, 01:28 PM
Download MSI Afterburner

NC37
10-11-2011, 01:49 PM
Find out how much load is on your GPU. There are programs which do this. I use MSI's Afterburner to tell the load on my 460s. OMD may be on XBL, but this isn't the first time I've seen a game from there overheating GPUs. Looks like VSYNC was the issue for you but games like Hydrophobia for PC, which were also XBL titles to begin with, literally needed fans at 100%. Load was 90%+ in that and it just worked GPUs too hard till they patched it.

Thanes
10-11-2011, 01:55 PM
I also realised that my GPU is going nuts playing OMD... Geforce 560 Ti.
I'll try using vsync for now and I hope there will be a solution soon :)

Shaneluls39199
10-11-2011, 02:25 PM
If you have the 8XMMSA or whatever on it might be why? my card hits 60 and has 99% usage with the game up

(radeon HD 6880)

voidfox
10-11-2011, 06:43 PM
Turning on vSync did in fact keep the heat down (and yes, I run it at 8x AA)

CDB
10-11-2011, 08:38 PM
Try running fraps when you start this game...in menus the game runs at 2000+ FPS on my 570, using EVGA precision shows the GPU under 99% load. Basically they didn't put a frame limit in the menus so your GPU is actually maxing out causing the increased temperatures. Turning on vsync limits the FPS to your montior refresh rate at 60 fps thus move your GPU load from 99% to < 40% which in turn keeps your GPU at a nice low temp.

SCII had this same issue when you idled in the menu when they released it and it ended up frying some GPUs...The devs should put in a fps hard cap to avoid this.

ericroslin
10-11-2011, 09:27 PM
Adore the demo, pre-ordered after one playthrough.

The game runs flawlessly at 1920x1080 with 4xAA for me, I'm on a Radeon HD6870.

Only problem is that my GPU likes to get very, very hot during this game. It approaches 80-85 Celsius during gameplay, and I start to get nervous in that neighbourhood. I've had to take to manually increasing the GPU's fan speed whenever I play the game.

This is not an issue I have in any other game. Just as an example, I've been playing both Rage and the Battlefield 3 beta, both at the highest possible settings. Both run fine, and neither approach these temperatures.

It may be a driver issue, but I've been through more driver updates and rollbacks and hotfixes in the past week than I care to admit, trying to get Rage to work properly. None of those ever had any effect on OMD or this problem.

I have difficulty imagining that Orcs Must Die requires more effort from my video card than Battlefield 3 ;) Is this an issue that's been reported by anyone else? Or is it something on my end?

Thanks in advance.

Enable v-sync and your problems should be solved. It might be the engine if anything though that's causing the over heat. Be careful though, 80-85C is at boiling point for graphics cards.

QualityJeverage
10-11-2011, 10:49 PM
OP updated, so we don't get the same suggestion multiple times ;)

swat_1990
10-12-2011, 02:24 AM
fix here: take AA off:cool:
it solves the problem

gnoupi
10-12-2011, 02:42 AM
Check with FRAPS or something similar which FPS you get without vsync.

The problem recently is that that new GPUs tend to not be able to cool themselves down for a quite regular use. Your computer is fast, it generates a lot of frames per second, much more than necessary.... And the GPU can't handle it.

It's highly stupid, I agree. And it never was a problem a few years ago, too. When the scene was complicated you had lower FPs, and that's all.

I assume the issue is related to shaders, which are easily heating the card, and have no influence on the initial number of scenes processed (since this is an after effect).

But it is really annoying. It shouldn't be the game developers to handle this. It should be GPU makers, which should make sure that their GPUs are not frying just because someone requested a lot of images, with a lot of effects.

(PS: the max temperature is different depending on the GPU. My Radeon Mobility can go up to 120 (the security cutoff happens at 125)).

Bague
10-12-2011, 02:45 AM
If you have a decent amd card you dont need to get nervous when it gets a bit hotter, the automatic fan increases its speed slowly up to a certain point and it might look dangerous, but it never gets over the limit.


and vsync fixing it means its the same problem starcraft 2 had with its mainscreen, frames are simply not capped and the game requests maximum GPU capacity no matter what.

gnoupi
10-12-2011, 12:59 PM
If you have a decent amd card you dont need to get nervous when it gets a bit hotter, the automatic fan increases its speed slowly up to a certain point and it might look dangerous, but it never gets over the limit.

The problem is that it depends, really. Most recent cards actually can't handle their heat, even with the fan on full speed, if a game doesn't limit the fps and has a generous amount of shader effects. It keeps increasing, even with full fan.

Chadwick
10-12-2011, 03:47 PM
Could we get the option to cap our FPS to 60 or 120 without using vsync? A lot of games allow this and it avoids mouse input lag.

SixOkay
10-12-2011, 04:23 PM
Could we get the option to cap our FPS to 60 or 120 without using vsync? A lot of games allow this and it avoids mouse input lag.

We're looking into this as I write.

Amy
10-12-2011, 04:26 PM
If you have a decent amd card you dont need to get nervous when it gets a bit hotter, the automatic fan increases its speed slowly up to a certain point and it might look dangerous, but it never gets over the limit.


and vsync fixing it means its the same problem starcraft 2 had with its mainscreen, frames are simply not capped and the game requests maximum GPU capacity no matter what.

No need an AMD card, NVIDIA will do fine too.

ASUS RoG Matrix GTX580 Platinium

No overheat at all, 45C all the time, a litle less than normal for all my game including Crysis and metro 2033.