PDA

View Full Version : DirectX failed to install


triarry
10-19-2011, 12:14 PM
Plain and simple, getting this error when installing that UDK at the beginning. Is there anyway to bypass it? Worked fine on my desktop, is not working on my laptop (they have extremely similar specs).
also, i just installed the most recent end user runtimes for DirectX to no avail. Getting the same error.

Satoru
10-19-2011, 12:17 PM
Try running the c:\program files\steam\steamapps\common\dungeon defenders\binaries\redist\ue3redist.exe manually. Also try running the exe as an administrator to ensure that it installs properly.

triarry
10-19-2011, 12:18 PM
Trying now, thank you for the quick response.

triarry
10-19-2011, 12:21 PM
Beautiful, seems to have worked, starting up now. Thank you so much Satoru.

TimeStamp12
10-19-2011, 01:21 PM
Had this same problem myself..

Can also say, indefinitely, Satoru's method works. I went straight to running UE3Redist.exe as an administrator

The Conductor
10-28-2011, 04:58 AM
My brother has had the exact same problems when trying to install DD - except running the redist from the Dungeon Defenders install directory has not helped... It errors out as the DirectX is trying to install...

Here's the log.

"UnSetup has encountered a problem and needs to close. We are sorry for the inconvenience."

"EventType : clr20r3 P1 : unsetup.exe P2 : 1.0.4308.38770
P3 : 4e9df1a2 P4 : system P5 : 2.0.0.0 P6 : 4db9c770 P7 : 3a8d
P8 : 288 P9 : system.componentmodel.win32"

Halp?

The Conductor
10-28-2011, 02:35 PM
Also, on an unrelated note, my game has no sound, other than the cutscenes.

It's Realtek HD Audio (onboard), and I run windows Vista 64.

THis is a problem I also had with Monday Night Combat, which uses a similar engine, iirc.

The Conductor
10-28-2011, 08:28 PM
bump.

aciada
11-03-2011, 09:30 AM
i also have the "unsetup has encountered an error" and i cannot find a way to fix the game. i run windows xp 64 bit, and have the required specs to run the game. i also tried running the setup independantly of the game but the error still appears, and leaves the dungeon defenders logo plastered permanently across the middle of the screen untill i end the process. eep