PDA

View Full Version : Sin 1 Crashes After Launch (Buffer Overrun Detected)


Blood_Wraith
11-24-2011, 08:49 PM
The fix (at least for me/nvidia users) was taken from another thread.

I've encountered the same problem. The fix is simple: go to nVidia control panel, click "Manage 3D settings", go to to the tab "Program Settings", select in the list "SiN:Episodes (sin.exe)" and set "Extension limit" to "On". SiN should run fine after this.


This works at least for nvidia users, someone should seriously sticky this. Most people are clueless on how to fix this problem.

Here's (http://forums.steampowered.com/forums/showthread.php?p=12412874) the link to the thread, if that helps further.

metalhead0043
11-27-2011, 10:06 PM
I tried that and it didn't work for me. Apparently new versions of the control panel do not have that option. I tried downloading the suggested program called "nHancer" and it will not run on my system, Win7 Professional 64-bit, despite that I downloaded the 64-bit version. I am at a loss and I cannot play the game as of now.

The only other thing I can try is running it on my XP. Maybe it will work better on XP as opposed to Windows 7.

Edit: The program in this thread fixes it.

http://forums.steampowered.com/forums/showthread.php?t=1933477

To get to the game settings click on the little wrench/screwdriver icon next to where it says "Driver version". Then select Sin Episodes from the drop down box. Underneath "Common" turn the Extension Limit on. That should fix the problem.

eyezex
11-29-2011, 04:24 PM
why did i purchase a game so i cannot play it??
:eek:

Grue12
11-30-2011, 06:42 AM
Even easier fix (NVIDIA)

1) find game folder (c:\program files (x86)\steam\steampps\your_login_here\sin 1\)
2) copy sin.exe to quake2.exe (you can just rename it if you want)
3) copy steam.dll from "c:\program files (x86)\steam\" to the game folder
4) create a shortcut "quake2.exe -steam"
3) run the shortcut

Problem solved!

Technical: This is because GL_EXTENSIONS string returned to the games by graphics driver/card for modern cards because of too much extensions is too long for older games (string is longer than 4096 characters - older games weren't programmed for that), and it creates buffer overrun. quake2.exe detects by NVIDIA driver as an older game and for this game the driver returns shortened extension list string (without advanced shader options etc. I think, but quake2/sin1 do not use shaders anyway). So I just faked sin.exe as quake2.exe