PDA

View Full Version : Refuses to run, says PhysX not installed properly


Totalitator
12-04-2011, 03:23 PM
I purchased this game during the Autumn sale.

I have the latest PhysX driver installed, but the game says it is not installed properly. No other game I own that uses PhysX has an issue. I even have tried re-installing all the nVidia drivers including PhysX to try to resolve it, but no luck. The game comes with some ancient version of PhysX but it never tried to install it during first run or anything. I found it in the game's folder, but when I ran it, it says (of course) that I have a newer version already installed and cancels out.

If anyone else is having this problem, I can't find any evidence of it. I can't imagine anyone with an up-to-date system is interested in removing their current drivers in order to install antiquated drivers that may or may not work.

Totalitator
12-06-2011, 06:53 AM
I found someone else with the same problem at the developer's support forum. The person posted it in 2009 and nobody has yet responded to it. I have written to both the publisher and developers regarding my issue and nobody will even respond to me.

Solon25
12-06-2011, 07:12 AM
Have you re-installed the game? For me it works on Vista/32.
Delete the files, run a Registry Cleaner, load it again.

Totalitator
12-06-2011, 07:57 AM
Hey Solon25 thanks for your reply. Funny, I just learned yesterday about Solon, the ancient Greek lawmaker from whom Plato descended, and there you are! Anyway..

Yes I did all the usual stuff. Deleting the drivers and game didn't resolve anything, which were the first things I tried originally. However, after a few more hours on this I am pleased to announce that I have discovered something that worked.

The solution here was to completely uninstall PhysX, then install the antiquated version of PhysX that is included in the game's folder. At this point the game worked. So then I installed the latest driver on top of that, and the game still works. I guess the game, when doing a startup check to see if PhysX is present, looks for something that was left behind by an older version but is not present in later versions.

If anyone else runs into this problem, there's the solution.

Devoured
03-20-2013, 12:13 PM
Thanks Totalitator I tried what u said and game worked with no problems.