PDA

View Full Version : PC completely hangs on startup


crunchyfrog555
12-07-2011, 04:41 PM
Just bought the game with the "Indie Gala" bundle.

Tried a few times to run it, and each time, will start quickly but immediately go to a black screen and then renders everything completely unresponsive. I can't Ctrl-Alt-Del or anything to get out of the game. Only a complete power off, then on resolves the issue (which is, frankly, a pain in the ♥♥♥♥).

Anyway, my specs are:
MSI CX705MX laptop
Windows 7 64-bit Ultimate Home Edition
Intel Celeron T3300 Dual Core @2 Ghz
4 Gb RAM
ATI Radeon HD545v graphics chipset

I also use Comodo firewall, AVG anti-virus and SpyBot S&D.

Any help appreciated.

psyko12
12-08-2011, 07:43 AM
We're on the same boat.
Sony Viao Laptop
Win 7 64 Bit
AMD CPU
2GB Ram
ATI HD 6320

Spyn Doctor
12-08-2011, 01:38 PM
Hi!

Sorry for the problems. Please try if the game works if it is started in Window mode:

In your Steam library, right click on YDAB! -> Properties -> Set Launch Properties -> enter "-window" into the field (without the quotes) and click OK.

Try to start the game again. It should start in a window instead of full screen. Does this work?

Doc

crunchyfrog555
12-08-2011, 01:53 PM
Hi!

Sorry for the problems. Please try if the game works if it is started in Window mode:

In your Steam library, right click on YDAB! -> Properties -> Set Launch Properties -> enter "-window" into the field (without the quotes) and click OK.

Try to start the game again. It should start in a window instead of full screen. Does this work?

Doc

Yes! It works for me.

That was painless. Thanks for the prompt attention. :)

Spyn Doctor
12-08-2011, 02:10 PM
If the game works in window mode but not in full screen mode, then most likely the game selects a full screen resolution that somehow does not work on your PC (even though the graphics device reports it as supported, because otherwise the game wouldn't pick it).

The game has an algorithm that tries to pick from the supported full screen resolutions the one that is closest to the game's native 1280x720 (720p) resolution. I guess that for some reason in your case it picks one that hangs the system.

You can override this algorithm by specifying the following parameter under "Set Launch Properties" (instead of, or additionally to, "-window"):

-r:WIDTHxHEIGHT

where you replace WIDTH with the desired resolution width and HEIGHT with the desired height, for example -r:1280x1024.
IMPORTANT: Make sure that you only supply a WIDTHxHEIGHT combination that is actually supported by your graphics card and monitor, because this resolution will be used without any further checks!
I recommend that you simply specify the WIDTH and HEIGHT that matches the native resolution of your display. If this is not 16:9, then the game should automatically be letterboxed.

BTW, you can specify both the -window and the -r:WIDTH:HEIGHT parameter.

If -window is specified, the game will always start in window mode, but you can then switch it to full screen mode with ALT+ENTER or via the options menu. If you do not specify -window, then the game will always start in whatever mode you had active when you last played the game.

If -r:WIDTHxHEIGHT is specified, then this resolution will be used for full screen (no matter if it is in full screen from the beginning or is switched into full screen later, with ALT+ENTER/options menu). If it is not specified, then the game will try to determine the best full screen resolution itself, as explained above.

Doc

crunchyfrog555
12-09-2011, 02:50 AM
If the game works in window mode but not in full screen mode, then most likely the game selects a full screen resolution that somehow does not work on your PC (even though the graphics device reports it as supported, because otherwise the game wouldn't pick it).

The game has an algorithm that tries to pick from the supported full screen resolutions the one that is closest to the game's native 1280x720 (720p) resolution. I guess that for some reason in your case it picks one that hangs the system.

You can override this algorithm by specifying the following parameter under "Set Launch Properties" (instead of, or additionally to, "-window"):

-r:WIDTHxHEIGHT

where you replace WIDTH with the desired resolution width and HEIGHT with the desired height, for example -r:1280x1024.
IMPORTANT: Make sure that you only supply a WIDTHxHEIGHT combination that is actually supported by your graphics card and monitor, because this resolution will be used without any further checks!
I recommend that you simply specify the WIDTH and HEIGHT that matches the native resolution of your display. If this is not 16:9, then the game should automatically be letterboxed.

BTW, you can specify both the -window and the -r:WIDTH:HEIGHT parameter.

If -window is specified, the game will always start in window mode, but you can then switch it to full screen mode with ALT+ENTER or via the options menu. If you do not specify -window, then the game will always start in whatever mode you had active when you last played the game.

If -r:WIDTHxHEIGHT is specified, then this resolution will be used for full screen (no matter if it is in full screen from the beginning or is switched into full screen later, with ALT+ENTER/options menu). If it is not specified, then the game will try to determine the best full screen resolution itself, as explained above.

Doc

Exceptional service!

Thank you very, very much.

And this is a fitting example why I love indie gaming. Problem solved and expanded solution given within 24 hours.

I've got a problem currently with a game on my PS3 which cannot update - Pixeljunk Monsters - giving a generic corrupt download error. I've been in content with Sony for the last 3 months over this issue, and naturally despite assurances to the contrary, they never get back to me, which I assume by this time, they're hoping I will just go away.

Naturally, I should iterate that Pixeljunk/Q Games are indie, however the problem has been identified as strictly Sony's.

Anyway, thank you very, very much for excellent service, and I hope it works out for you too psyko.