PDA

View Full Version : Constant disconnects.


Kaphei
12-07-2011, 08:24 PM
Hey guys. So I tried the game and I've liked it a lot so far. Graphics are nice and it feels satisfying to kill your enemies. But it seems that I'm getting constantly kicked out of the server for no apparent reason. It may be that the server is getting hammered with a lot of new players and such. Can I get a confirmation on this? It is really frustrating to be dc'd in the middle of a mission after killing three dudes in a row.

Freyar
12-07-2011, 08:27 PM
What kind of disconnects? A typical "You lost connection to the server"? which server and district have you been trying to play on?

The_wind
12-07-2011, 08:37 PM
Hey guys. So I tried the game and I've liked it a lot so far. Graphics are nice and it feels satisfying to kill your enemies. But it seems that I'm getting constantly kicked out of the server for no apparent reason. It may be that the server is getting hammered with a lot of new players and such. Can I get a confirmation on this? It is really frustrating to be dc'd in the middle of a mission after killing three dudes in a row.

You problaby are "disconnected" or "kicked from server" because u dont have "punkbuster", a program anti-cheat and games use it for servers ^^
You problaby dont have it, google it and get it ;)

Kaphei
12-07-2011, 09:38 PM
I get the "You lost connection to the server" message. This happened a lot when playing in the Financial District in the West Coast server. I never got disconnected when playing in the Tutorial.

Also, I do have Punkbuster, and it is enabled while I play. I've used PB in many games before and it has never given me any kind of problems.

Thanks for the replies, I'll be awaiting an answer.

Freyar
12-07-2011, 09:41 PM
My first recommendation is to make sure Punkbuster is up-to-date.

Second, use a command prompt to monitor your connection.

ping "the URL of your ISP" -t

Look for dropped packets or excessive lag.

Kaphei
12-07-2011, 09:44 PM
How do I make sure that PB is up to date? And I was monitoring my ping after I closed the game, wasn't lagging at all at that time.

Freyar
12-07-2011, 09:46 PM
Go to http://www.evenbalance.com/index.php?page=support.php

PBSetup will update Punkbuster for you

Kaphei
12-07-2011, 09:58 PM
Okay, I ran PBSetup and it seems it did a little update. Gonna hop into the game right now to see how it goes. Will report back. Thanks for all the help so far.

EDIT: Also, how do I link my G1 account to my Steam account?

Freyar
12-07-2011, 10:03 PM
Okay, I ran PBSetup and it seems it did a little update. Gonna hop into the game right now to see how it goes. Will report back. Thanks for all the help so far.

EDIT: Also, how do I link my G1 account to my Steam account?

When you attempt to log in using Steam for the first time it will ask you to also provide your G1 login information. After that your SteamID will act as a login token when launching APB with steam running.

Kaphei
12-07-2011, 10:07 PM
'k gotcha...

So, I just got disconnected, and that was even faster than a couple of hours ago. :<

Kaphei
12-07-2011, 10:34 PM
Then I tried Waterfront, was able to play for about 20 minutes, then dc'd.

Freyar
12-07-2011, 10:47 PM
What kind of network connection do you have?

Gman03
12-08-2011, 09:30 AM
I'm also getting constant disconnections, on any district on both NA servers. I'm sitting on the best internet in the state here on campus, and it is never overloaded or bogged down. I get perfect connections to every game I own, except I continually disconnect on this one. I have PB and it's up to date, I just had to jostle it around to get BF3 to run.

I'm really enjoying this game otherwise, but the continual disconnecting is ruining it for me. There's a 32 page thread on the G1 forums for people having disconnects, but it's 6 months old and appears to be abandoned/ignored by the staff over there. There's no listed fixes in any of the threads about it, does anyone here have a solution?

Gman03
12-08-2011, 09:45 AM
Just manually updated PB, no change. I still disconnect roughly every 5 minutes or less.

Robthebob
12-08-2011, 09:50 AM
The last few minutes I have had problems logging in. Think the servers mighta popped for a while. Just wait a bit and it might be ok.

Freyar
12-08-2011, 12:11 PM
I'm also getting constant disconnections, on any district on both NA servers. I'm sitting on the best internet in the state here on campus, and it is never overloaded or bogged down. I get perfect connections to every game I own, except I continually disconnect on this one. I have PB and it's up to date, I just had to jostle it around to get BF3 to run.

I'm really enjoying this game otherwise, but the continual disconnecting is ruining it for me. There's a 32 page thread on the G1 forums for people having disconnects, but it's 6 months old and appears to be abandoned/ignored by the staff over there. There's no listed fixes in any of the threads about it, does anyone here have a solution?

May seem like the disconnect thread is ignored, but it's merely a place used to collect data.

You're playing on a campus? Does your campus have fairly restrictive port management?

TentacleMayor
12-08-2011, 12:34 PM
Serious trouble here too, on Obeya. I can't spawn in action districts and sometimes get kicked due to 'losing key packets' (though Ping is under 150)

Gman03
12-08-2011, 02:36 PM
It's not the servers, I'm still getting the disconnects and I've been getting them since a few hours after the game's steam release (when I started playing). My friends I play with don't get disconnected when I do, or at all. They're all progressing quite far while I'm left in the dust because I can't complete a single mission, I get dc'd in the middle of them. Can anyone please help me? I'd really like to get to play the game.

Gman03
12-08-2011, 02:38 PM
May seem like the disconnect thread is ignored, but it's merely a place used to collect data.

You're playing on a campus? Does your campus have fairly restrictive port management?

Not really. Peer-to-peer is blocked, but anything else works just fine. I can't host most games either, but I can play anything really except this game. I know it's just used to collect data, I was just hoping they'd have used that data to do something by now. I understand it can be a tricky thing to do, but after 6 months I'd expect it to be fixed, given that it's not a super uncommon issue.

Freyar
12-08-2011, 05:34 PM
Serious trouble here too, on Obeya. I can't spawn in action districts and sometimes get kicked due to 'losing key packets' (though Ping is under 150)

That is a Punkbuster issue. Make sure your Punkbuster files are up-to-date, if that doesn't work you may need to reinstall Punkbuster from scratch.

I used to have this problem on a machine at my work and rebooting typically solved that for me, your mileage my vary.

It's not the servers, I'm still getting the disconnects and I've been getting them since a few hours after the game's steam release (when I started playing). My friends I play with don't get disconnected when I do, or at all. They're all progressing quite far while I'm left in the dust because I can't complete a single mission, I get dc'd in the middle of them. Can anyone please help me? I'd really like to get to play the game.

Are you getting the same behavior on other servers?

Not really. Peer-to-peer is blocked, but anything else works just fine. I can't host most games either, but I can play anything really except this game. I know it's just used to collect data, I was just hoping they'd have used that data to do something by now. I understand it can be a tricky thing to do, but after 6 months I'd expect it to be fixed, given that it's not a super uncommon issue.

It's more of an issue when you throw in Universities into the mix. There are some Peer2Peer technologies and VOIP technologies at work with APBR, but are you getting friends that are getting disconnected at the same time in the same district?

Gman03
12-08-2011, 08:09 PM
That is a Punkbuster issue. Make sure your Punkbuster files are up-to-date, if that doesn't work you may need to reinstall Punkbuster from scratch.

I used to have this problem on a machine at my work and rebooting typically solved that for me, your mileage my vary.



Are you getting the same behavior on other servers?



It's more of an issue when you throw in Universities into the mix. There are some Peer2Peer technologies and VOIP technologies at work with APBR, but are you getting friends that are getting disconnected at the same time in the same district?

I get this issue on both NA servers, I haven't tried other servers though. Noone I know is getting disconnects like this, and some live in the same area.

Freyar
12-08-2011, 08:12 PM
I get this issue on both NA servers, I haven't tried other servers though. Noone I know is getting disconnects like this, and some live in the same area.

Do they have the same ISP?

Gman03
12-08-2011, 08:14 PM
Do they have the same ISP?

No, I'm hoping to try this game on a friend's computer sometime soon though to test it.

I'm not sure why this ISP would be blocking or interfering with this game though, it works perfectly with all other programs except pure torrenting peer-to-peer style websites and files, which I have to download externally.

Freyar
12-08-2011, 08:35 PM
No, I'm hoping to try this game on a friend's computer sometime soon though to test it.

I'm not sure why this ISP would be blocking or interfering with this game though, it works perfectly with all other programs except pure torrenting peer-to-peer style websites and files, which I have to download externally.

Well.. if you get a chance to test it, it'd be interesting to see what's going on.

Gman03
12-08-2011, 09:09 PM
Indeed. Thanks for all of the help so far Freyar, I see you on a lot of the steam boards! Always helpful and constructive. :D

Kaphei
12-09-2011, 12:47 AM
Yeah, Freyar has been really helpful, I'm also grateful for that.

But it seems that Gman and I have the same issue, my Internet connection is pretty good; I've been playing online games and have never had this kind of issues. Well, I'll be keeping an eye on any update.

Gman03
12-10-2011, 11:36 PM
So this has been really iffy so far. Sometimes I can play for an hour without disconnects or crashes, sometimes it only lasts 2 minutes. I'll be able to test this on a friend's computer on the same network tomorrow. Hopefully this is something I can get resolved, I'm loving what little of this game I get to play. Racing around busting criminals is insanely fun with a bunch of friends.

Freyar
12-11-2011, 02:32 PM
Still looking for feedback. Testing this on another network would eliminate the router, modem and route to the server as being a problem.

Gman03
12-11-2011, 07:18 PM
I won't be able to test on another network for a week or so. I tested on another computer though, I still got frequent crashes but not a single disconnect. Only tested it for 2 hours though, there is plenty of room for error. Sometimes I don't disconnect for close to two hours, so it is possible that the issue persists on the other computer as well.

Kaphei
12-11-2011, 10:13 PM
I should also be able to test in the same network but in a different computer next week.

farfletched
12-12-2011, 04:48 AM
One simple thing to try would be to run "Game Booster 3" in the background, it kills all un-needed processes and boosts sytem performance. It should also cut any communication from malware / trojans running on your computer that you are un-aware of.

Just be sure to un-tick all the crap that comes with GameBooster when installing.

Gman03
12-12-2011, 09:13 AM
Thanks farfletched. I'll try that out later today.

I seem to crash more than disconnect now, though both are still common. Played for 3 hours yesterday with only two crashes and one disconnect, while I usually crash or disconnect every 5 minutes.

Gman03
12-12-2011, 09:55 AM
The strange blackscreen-crashes are still occuring, though a little less frequently. I didn't have enough time to test for disconnections since the servers are going down in a minute, may try again later with more results.

Revoemag
12-12-2011, 10:26 AM
The latest patch going onto live as I speak should in theory help resolve your problem, I'm not sure if it's the specific fix to the problem you have, but I have a feeling it might be, give it a try, servers should be up in around two hours time :)

sc0rp24
12-12-2011, 10:44 AM
In theory... Sounds kinda suspicious that even developers are not aware of what exactly will happen with the game after patch is applied. Let's just hope it doesn't take a bunch of extra patches to fix the results of current fix.

Gman03
12-12-2011, 11:58 AM
Thanks Revoemag, I was hoping for that. Will give it a try.

RpTheHotrod
12-12-2011, 12:00 PM
The latest patch going onto live as I speak should in theory help resolve your problem, I'm not sure if it's the specific fix to the problem you have, but I have a feeling it might be, give it a try, servers should be up in around two hours time :)

Hey Revo! Good to see you here on the forums. Welcome!

Gman03
12-12-2011, 01:08 PM
Okay, I've played for about an hour post-patch. In that time, I disconnected twice and crashed once. It seems somewhat less frequent, but it still persists.

Rave2n
12-12-2011, 01:37 PM
Your issue sounds network related. Being you are not getting the usual General Protection Fault report crash, or a blue screen being video related to a driver, or any other add-on.

I would start looking at your networking gear if you have that ability.

My lady and I have to restart the linksys wrt every now and then because of the same issue.

For instance she'll play BF2BC2, while i'm playing APB...when she comes to APB, i'll get disconnected, or she'll get in, but shortly be kicked.

Though it is a physical layer issue with my router, which a replacement would fix, a temp power cycle resolves it. Which is were I believe your issue is. Not all games show this either. I assume it has something to do with what ports the query.

If you want, you can PM some details, and I can walk you through some things to completely confirm it is not your computer that is the issue, but that would require some sensitive information to an unknown individual being me =P