View Full Version : bejeweled 3 suddenly choppy

01-12-2012, 09:02 PM
I don't know what happened but the game was running smooth (and very addictive) the first time or 2, and now 3 days later, it is getting very choppy. The animation and play are both choppy even at lowest resolution, with me shutting off every other process on my computer and it alone set at the highest priority. I reinstalled it, restarted the computer and still the same choppiness to the point of being non-playable. Does anyone else have this problem?

01-13-2012, 10:36 AM
Try running it in window mode?

01-13-2012, 06:25 PM
yep tried that...

01-15-2012, 08:07 PM
Computer specs?

04-13-2012, 06:04 PM
I just started this game up today to find out that this is the case for me.. In some cases the shuttering was so bad that in wouldn't even bother to play through all the animation effects and would jump straight to the final board layout. Other times it would shutter and I would loose up to 4 seconds for no apparent reason.

When I first bought the game it ran perfect and silky smooth so this is bad step backwards.. I do remember that there was a small update to my game since the sale. But I hadn't play it till now.

System Information
Time of this report: 4/13/2012, 19:49:40
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1
Processor: Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz (4 CPUs), ~3.3GHz
Memory: 16384MB RAM
Available OS Memory: 16364MB RAM
Page File: 4280MB used, 28445MB available
DirectX Version: DirectX 11

Display Devices
Card name: NVIDIA GeForce GTX 570
Manufacturer: NVIDIA
Chip type: GeForce GTX 570
DAC type: Integrated RAMDAC
Display Memory: 4064 MB
Dedicated Memory: 1248 MB
Shared Memory: 2815 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: BenQ BL2400 (Digital)
Monitor Model: BenQ BL2400
Monitor Id: BNQ8002
Native Mode: 1920 x 1080(p) (60.000Hz)
Output Type: Displayport External