PDA

View Full Version : Just installed Sourcemod for local server, and now L4D2 crashes mid-game


KingofCreation
01-27-2012, 05:33 PM
I've just installed Sourcemod, but now after playing for maybe 10-15 minutes L4D2 crashes to the desktop. No error message, no Windows warning messages...nothing. It's like the game was never running. Has anyone had experience with this or know how to fix it? Thanks in advance.

ajs410
01-27-2012, 05:58 PM
Sourcemod is typically installed on a console Dedicated Server which is running on a computer that is NOT the one which the game is playing on. It sounds like you installed Sourcemod on the client PC. If so, I highly suggest finding a different PC and installing the Dedicated Server and Sourcemod on that one instead.

You may also wish to post in the Windows DS forum instead. You may get more help there regarding DS issues. http://forums.steampowered.com/forums/forumdisplay.php?f=44

KingofCreation
01-27-2012, 06:02 PM
I installed it to run for my local server, mainly to kick griefing players which seems to be happening more often. I was under the impression that it was ok for hosting local servers.

kikiokyo
01-27-2012, 06:13 PM
I have the same issues, tried removing the plugins, but still something was wrong. This happened after a few updates ago, I want to host a local server for L2D matches, and there are plugins that help fix some issues the game has had (stuck invincible zombies, bots not grabbing items, etc...) Anyone who got around this problem, your help would be appreciated.

KingofCreation
01-27-2012, 08:48 PM
If I remove -insecure from the launch options, the game no longer crashes. This obviously doesn't help if I want to use sourcemod though.

ajs410
01-27-2012, 08:55 PM
In my experience, I've never used Sourcemod with a Local Server nor have I heard of anyone who has done so successfully. It might be possible, but it's hard enough to find people who know how to get Sourcemod to work with Dedicated Servers.

I have a DS for much the same reason, kicking griefers and customizing the game with plugins. I have an old (circa 2006) laptop running the Dedicated Server (it uses 16% CPU and ~500 MB of RAM), and two other much newer client PCs on the LAN for playing coop.

KingofCreation
01-27-2012, 09:48 PM
In my experience, I've never used Sourcemod with a Local Server nor have I heard of anyone who has done so successfully.

I just followed the instructions here, specifically for Local Servers: http://forums.steampowered.com/forums/showthread.php?t=1125208

From what I've seen through Google, it seems to be pretty accepted that Sourcemod should run fine on a local server. It just doesn't want to cooperate with mine :(

Random Engineer
01-28-2012, 03:11 AM
I thought I was the only one with this problem (phew, glad I'm not). I used to play on my own local server with friends half a year ago and everything worked fine (lasted from around november 2010 to may-june 2011, then I stopped playing). Yes, Sourcemod *used* to work with no problem on client servers. Now, I want to play again but whenever I try, within 10 to 15 minutes (as you said) the game just goes *poof*. It's like I Alt+F4'd. Any word from Valve about this?

ajs410
01-28-2012, 08:13 AM
I don't think Sourcemod is property of Valve, so I don't think Valve will have anything to say about this. You'd be much farther ahead to ask on the Allied Modders forum. http://forums.alliedmods.net/

Bear809
02-07-2012, 01:16 PM
I have this issue too.

synthemesc
02-07-2012, 01:29 PM
I literally installed sourcemod on my pc for single player/local use yesterday. I haven't seen any problems yet. Could it be a plugin issue?

CanadaRox
02-07-2012, 01:42 PM
Have you checked the Sourcemod error logs?

kishkuma
02-18-2012, 03:14 PM
Same issue here, I have no plugins installed except the ones it came with, and nothing in the logs to indicate an error.

awesomealvin
07-19-2012, 12:49 AM
I have this error too, if I check the Logs, it says
"[LEFT4DOWNTOWN] Detour -- Could not find 'SpawnWitch' signature"

POLICEMATRIX
07-19-2012, 01:03 AM
In my experience, I've never used Sourcemod with a Local Server nor have I heard of anyone who has done so successfully. It might be possible, but it's hard enough to find people who know how to get Sourcemod to work with Dedicated Servers.


It works just some plugins fail to work
for instance i could never get more slots on listen server

ProdigySim
07-19-2012, 02:57 AM
There's lots of reasons sourcemod could crash your client. It's really not a safe or good idea to run it on one.

If you want to "local host" games, a much safer solution is to run a srcds install on your PC. You can even run it out of the same directory as your client (just install the l4d2 dedicated server package from the Tools section). Then you don't have to worry about weird client-specific sourcemod bugs, and you can still basically do the same local game hosting.


Also you should be aware that if you're hosting games with -insecure on your client, you're disabling VAC--meaning that anyone who joins the game is free to cheat as they please.