PDA

View Full Version : [Bug] SuperUser Access


Bubbo
01-28-2012, 03:35 AM
I have a rooted Android phone and was fairly surprised when the steam app tried to get superuser access.

I denied access to it (as why would it even require it?) and told the phone to remember my decision. Now it keeps trying to get access again (I can see the access denied message pop up all the time). This is starting to really slow down the app as the ui slows to a crawl each time it gets denied.

Thebigone
01-28-2012, 03:43 AM
and this is why it's a closed beta. Thanks for reporting this ^^

Savage Alien
01-28-2012, 04:02 AM
When did it first ask for Super User access?

DarkLite123
01-28-2012, 04:11 AM
What happens if you allow the access? Blizzard's authenticator app tries to get root and pops up a security warning if the phone is rooted, this could be something similar.

Savage Alien
01-28-2012, 04:14 AM
I have a rooted Galaxy Nexus running a custom ROM and have not had it ask for Super User access.

Bubbo
01-28-2012, 04:25 AM
I can't seem to get it to repeat this now.
I quit the app as it was too annoying with all the slowdown, but now I've opened it again, it hasn't asked for access. I've tried going to all the screens to see which one might get it to ask and to see what it does, but none of them have triggered it so far.

DpNo1
01-28-2012, 04:30 AM
My phone is rooted and I haven't seen any superuser access requests from the steam app yet.

gamer007
01-28-2012, 05:06 AM
Same here. Steam Mobile hasn't asked for superuser access yet.

Cirunz
01-28-2012, 07:06 AM
HTC Desire with root and custom ROM, no request for superuser here.

postamt87
01-28-2012, 08:54 AM
HTC Desire HD rooted and Steam did not asked for SU

eraks
01-28-2012, 08:56 AM
HTC Desire HD rooted and Steam did not asked for SU

Same here. Did not ask for anything. (I also have a modded firmware installed)

The Dog
01-28-2012, 08:59 AM
Rooted Samsung Galaxy S II, no requests here.

Nickolaeris
01-28-2012, 09:54 AM
Rooted HTC HD2 with custom Android, and rooted Asus Transformer TF101, no request for Superuser.

spartan0078
01-28-2012, 10:51 AM
It could be a bug related to the ROM he's using or even just the type of phone he has.

lavacano201014
01-28-2012, 12:37 PM
Rooted Samsung Galaxy S II on stock (well Samsung stock) Android 2.3 and it hasn't asked for superuser

Eunos
01-28-2012, 12:41 PM
How do you get the pop ups about access requests?
I've got a rooted Samsung GS2.