PDA

View Full Version : Mansion FPS Drop (spoiler?)


Bassick
02-07-2012, 09:38 AM
I don't believe this is a spoiler, seeing as it is not vital to the storyline, but if it is I apologize in advance.

Anyways, after you complete the first level/area and are taken to the mansion I notice significant drop in framerate, it was so much a stutter as a...skip? Maybe that's the same thing but it didn't seem like your normal FPS drop. It was random and seemed to only happen in certain rooms of the mansion. All that aside the game has been running completely smooth.

Running 460m's SLI.

Any ideas?

Manloi
02-09-2012, 11:10 PM
I have a rig that have i7 920 and GTX 580 with Revodrive 3 SSD. Every time I got into the Mansion, random Frame Rate Drop. It is kinda ruin the challenge for me. 2K games and Digital Extreme, you should both look into it. It's very irritating.

KevinLongtime
02-09-2012, 11:12 PM
I do recall some framerate drop here and there in the mansion (i7 920, GTX 560). It didn't bother me too much though, personally.

MD1990
02-10-2012, 08:49 AM
I'm using a 6850 and I never experienced an fps drop during my playthrough. I explored the entire mansion too.

kornetto
02-10-2012, 08:56 AM
Same problem here, but not only in the mansion but through
the whole freaking game, constant framedrops that feels like skipping.
Running GTX460 here 295.51 driver, lowering settings or using older drivers didn't help.

Arpogest
02-10-2012, 09:15 AM
Experiencing the same on GTX560 with 275.33 & 295.51 drivers.

MD1990
02-10-2012, 11:24 AM
Could this be one of the few games where I feel good about my choice of buying an AMD card?

So far it looks that way.

Manloi
02-10-2012, 11:30 AM
Hello!

After sending my problems to 2k Support. Their response is in the following:

After looking at your computer's Direct X Diagnostic report, it shows that your video card is running - Driver Version: 8.17.12.9053

Checking Nvidia's website for drivers and it shows that the 8.17.12.8562. Please uninstall your current graphics drivers and install the 285.62 drivers by following the below link.

http://www.geforce.com/Drivers/Results/38915

Best Regards,

Wesley B.


I have not tested the driver yet. But I don't really want to roll back my beta driver.

Johnana
02-10-2012, 12:15 PM
i7 ; radeon6670 ; 8gb & mansion seems to run smoothly for me.

HT UK
02-10-2012, 01:41 PM
Yea I get fps drops in the mansion too.

i7 870 w/ GTX 580

Manloi
02-10-2012, 01:56 PM
I hope the Digital Extreme Fix it with a patch. Oh and 16:10 too

Air Tortoise ME
02-10-2012, 03:13 PM
Yep, most likely an issue with Nvidia cards.

2600k w/ GTX 580 SLI has big drops in framerates. (SLI enabled or disabled doesn't matter).
3960x w/ 7970 runs very smooth.

I switched cards between systems, now 2600k is smooth while 3960x has huge dips in framerates.

slymenstra
02-10-2012, 03:37 PM
if i switch to windowed mode all my mansion slowdowns (and stutters) are gone and its all very smooth.

update.....if i use nvidia inspectors framerate limiter set to 60 with vsync on my slowdowns are also gone.

just like deus ex i might add
http://forums.steampowered.com/forums/showpost.php?p=28952905&postcount=880

Killtacular
02-10-2012, 08:30 PM
In case it helps, I had framedrops in the demo here and there, and setting Physx to cpu in the nvidia panel seemed to eliminate them. Of course I can't test the Mansion area you guys are referring to, but it did work in the demo sections.

Zydrate Addict
02-11-2012, 06:12 AM
Could this be one of the few games where I feel good about my choice of buying an AMD card?

So far it looks that way.

I know the feeling

Manloi
02-11-2012, 10:34 AM
In case it helps, I had framedrops in the demo here and there, and setting Physx to cpu in the nvidia panel seemed to eliminate them. Of course I can't test the Mansion area you guys are referring to, but it did work in the demo sections.

It did not work for me. But thanks for the suggestion.

marcelus
02-11-2012, 12:22 PM
if i switch to windowed mode all my mansion slowdowns (and stutters) are gone and its all very smooth.

update.....if i use nvidia inspectors framerate limiter set to 60 with vsync on my slowdowns are also gone.

just like deus ex i might add
http://forums.steampowered.com/forums/showpost.php?p=28952905&postcount=880

Thank You very much. Work perfect. No slowdowns or stutters in mansion and the game run absolutely smoothly!

Screenshot from NV_Inspector

http://www.abload.de/img/nvinspector_darkness6lq1q.png

Manloi
02-11-2012, 06:22 PM
By playing the game in windowed mode is really help. It solve the problem. However, I do not want to play the game in Windowed mode. The FPS Limiter did not solve my problem.

slymenstra
02-14-2012, 01:43 AM
By playing the game in windowed mode is really help. It solve the problem. However, I do not want to play the game in Windowed mode. The FPS Limiter did not solve my problem.

Manloi try the frame limiter in MSI afterburner, it works better than the nvidia one.
Also when you use the limiter have vsync ON or it wont fix the stutter, totally illogical i know.....but it works.

Hellstrong
02-14-2012, 03:53 AM
constant framerate on 6670 looking at tread looks to be a Nvidia issue