PDA

View Full Version : Legacy achievements not work


josanguapo
02-11-2012, 03:20 PM
Hi,

Im playing the Blackwell Legacy game and have observed that none of the achievements seem to register in Steam. They appear in the ingame achievements section, but they don't register in Steam. What's happening? In other games the achievements work perfectly. What can I do?

serieus1
02-11-2012, 06:59 PM
I'd say reboot Steam, if that doesn't work reboot your computer, if that doesn't work then right click on Blackwell Legacy and go to properties/local file and check file integrity just to make sure that all files are correct.

Worst case scenario, uninstall and redownload.

Hope that helps, I just recently played that game and loved every minute of it. The voice acting isn't the greatest and neither are the graphics, but the overall experience was more than gratifying.

hustlayo
02-12-2012, 01:45 AM
Since like three days ago achievements in Blackwell games don't work. It's probably because of the client update. I already contacted Dave and told him about the issue. I hope he'll resolve it with Steam.

RuNN!nG sCaRe:D
02-27-2012, 07:55 AM
Wait for an update

We *think* it's because our Steam plugin needs to be recompiled with the new version of the Steam API. If that's so, then the savegames won't break. Cross your fingers.

B.U. steam achievements don't want to work (http://forums.steampowered.com/forums/showthread.php?t=2530621)

WadjetEye
02-27-2012, 10:52 AM
Good news - our programmer has created a fix that *should* solve everything. Unfortunately his timing is a bit awful as we are in the midst of traveling right and we can't implement the changes from where we are. But we have our laptops with us and we'll try to get the changes up on Steam as soon as we can. Thanks again for your patience!

josanguapo
02-28-2012, 10:37 AM
Unfortunately, the fix uploaded yesterday doesn't seem to work properly. Achievements still don't register in Steam even if starting a new game in a new computer where the game hasn't been installed previously.

fvdrhee
02-28-2012, 10:47 AM
Unfortunaly for me it's the same in The Blackwell Legacy. The Hello Joey won't register even when starting a completely new game.

Kaese
03-02-2012, 01:28 PM
Just starting playing the ganes and achievements aren't unlocking.
Read the update notes some days ago that it should have been fixed? Well, it isn't.

lordofterror
03-02-2012, 07:04 PM
yeah im waiting out to see , if they finally fixed it so i can play the three blackwell games again

Kaese
03-06-2012, 05:19 PM
Any news about this from the devs?

PATAVATSIZ
03-12-2012, 02:15 PM
I achievements for Legacy worked for me but Unbound did not. I tried some achievements 3 times but no luck. Ingame achievements are working though. Hope new patch will fix this.