PDA

View Full Version : SF1 CD-Key startup


Yan.42
03-21-2012, 09:49 AM
So do I have to type the CD key everytime I start the game? You can't be serious. How can I change/fix that?

Hagenmaster
03-21-2012, 01:16 PM
So do I have to type the CD key everytime I start the game? You can't be serious. How can I change/fix that?

Same problem to me what's wrong :confused:

rocketsurgeon66
03-21-2012, 03:08 PM
I'm having the same problem. And since it can't even be cut&pasted, it's something of a drag.

Hagenmaster
03-21-2012, 03:19 PM
Here is a solution that works for me:

Go to the steam folder where the game is installed , then select the SpellForce.exe and set it to run as administrator. After this the key is recognized by the game.

RmSlash
03-21-2012, 04:24 PM
Here is a solution that works for me:

Go to the steam folder where the game is installed , then select the SpellForce.exe and set it to run as administrator. After this the key is recognized by the game.

didnt work for me .. I had to set steam to run as admin first to write to key. then I can unset it

pyronix2002
03-21-2012, 10:12 PM
I was getting really frustrated with the same problem as well but the solution that Hagenmaster mentioned worked for me (running Win 7 64-bit).

What I did was to go to the steamapps folder and under the subfolder corresponding to SpellForce 1 (on my computer it is -- C:\Program Files (x86)\Steam\steamapps\common\spellforce platinum edition\), right click on "Steam.exe", click Properties, go to Compatibility tab.

Near the bottom of the tab, there is a section called "Privilege Level" with a checkbox "Run this program as an administrator". Check that box, then click "OK".

Run the game again. It will still ask you for the CD-key so make sure to input it correctly. However, it'll be the last time it will ask you as the next time you run it, it will not be asking the CD-key anymore.

Hope that helps.

wRAR
03-22-2012, 03:32 PM
And after you've entered the key, you can disable the checkbox.

Operations
03-24-2012, 05:21 PM
Here is a solution that works for me:

Go to the steam folder where the game is installed , then select the SpellForce.exe and set it to run as administrator. After this the key is recognized by the game.
Thanks for the fix, works for me too.
Can get rid of the macro I made for the keyboard now :)
And after you've entered the key, you can disable the checkbox.
Yeah did this too, gets rid of that UAC pop up.