PDA

View Full Version : Won't start on mac


hamsu
04-06-2012, 11:08 PM
I have installed and played this game on my pc but now my pc is broken and got my older mac. Installed it on mac and when trying to launch the game it crashes.

System info:
Model: MacBook3,1, BootROM MB31.008E.B02, 2 processors, Intel Core 2 Duo, 2 GHz, 1 GB
Graphics: kHW_IntelGMA965Item, GMA X3100, spdisplays_builtin, 144 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x88), Broadcom BCM43xx 1.0 (5.10.91.22)
Bluetooth: Version 2.1.9f10, 2 service, 1 devices, 2 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: ST980811AS, 74,53 GB
Parallel ATA Device: MAT♥♥♥♥ACD-RW CW-8221
USB Device: Built-in iSight, (null) mA
USB Device: Apple Internal Keyboard / Trackpad, (null) mA
USB Device: IR Receiver, (null) mA
USB Device: Bluetooth USB Host Controller, (null) mA
USB Device: USB Optical Mouse, (null) mA

Civilization 4 runs great on this why not this?

kb320e
04-09-2012, 04:40 AM
Video Card: NVIDIA GeForce 8800/ATI Radeon HD 3850 or higher (integrated video cards not supported), 512 MB RAM, OpenGL 3.0.

unknowntitle
04-20-2012, 08:32 AM
I have the same problem, but the demo from citiesinmotion.com works fine.

MacBookPro4,1, Intel Core 2 Duo 2.6 GHz, 4GB RAM, SSD, NVIDIA GeForce 8600M GT 512, OSX Lion 10.7.3

carpii
04-20-2012, 03:15 PM
Similar problem, except I did manage to play it for 15 minutes when I first bought it a couple of hours ago.
Then I quit, and now cannot launch it again

Model Name: iMac
Model Identifier: iMac11,1
Processor Name: Intel Core i7
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 8 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: IM111.0034.B02
Gfx: ATI Radeon HD 4850

I even deleted it, then rebooted, and reinstalled from scratch

Lets just say Im getting pretty fed up spending money on Steam only for every thing I buy to have some sort of problem meaning its unusable.
As others have noted, Its not necessarily the app,

its Steam. Its a *^&$% heap

natbudin
04-21-2012, 07:35 AM
Same here.


Model Name: MacBook Pro
Model Identifier: MacBookPro7,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 3 MB
Memory: 8 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP71.0039.B0E
Chipset Model: NVIDIA GeForce 320M
VRAM (Total): 256 MB

(I realize I'm not supposed to be able to run this with 256MB VRAM, but it worked fine on low settings until the latest Steam update.)

unknowntitle
04-22-2012, 10:47 AM
The is what the log says at the moment I run CIM from Steam:

22-04-12 19:40:24,815 [0x0-0x102102].com.valvesoftware.steam: Failed to create Service pipe
22-04-12 19:40:24,815 [0x0-0x102102].com.valvesoftware.steam: Failed to connect to Steam Service
22-04-12 19:40:24,815 [0x0-0x102102].com.valvesoftware.steam: Failed to load Steam Service
22-04-12 19:40:24,815 [0x0-0x102102].com.valvesoftware.steam: ServiceStart: failed to start
22-04-12 19:40:24,899 [0x0-0x102102].com.valvesoftware.steam: Game update: AppID 73010 "Cities in Motion", ProcID 7284, IP 0.0.0.0:0
22-04-12 19:40:25,274 com.apple.launchd.peruser.501: ([0x0-0x105105].com.ColossalOrder.CitiesInMotion[7284]) Exited with code: 254
22-04-12 19:40:25,355 [0x0-0x102102].com.valvesoftware.steam: saving roaming config store to 'sharedconfig.vdf'
22-04-12 19:40:25,355 [0x0-0x102102].com.valvesoftware.steam: roaming config store 2 saved successfully
22-04-12 19:40:27,166 [0x0-0x102102].com.valvesoftware.steam: Game removed: AppID 73010 "Cities in Motion", ProcID 7284
22-04-12 19:40:27,667 [0x0-0x102102].com.valvesoftware.steam: saving roaming config store to 'sharedconfig.vdf'
22-04-12 19:40:27,667 [0x0-0x102102].com.valvesoftware.steam: roaming config store 2 saved successfully

victor29
04-23-2012, 10:31 PM
Same problem, click launch button and I get nothing more than the program icon popping up in the dock for a second.

jontxucillo
04-24-2012, 08:28 AM
They just solved it, it was STEAM client last update that messed up things on the Mac.

It's a real pity that Valve and STEAM don't pay attention to Mac users... It's been more than two years and STEAM is the only application on my Mac with a horrible scroll, almost impossible to control...

woodynightshade
05-22-2012, 04:55 AM
so what is the solution?

i just downloaded the steam client and game today, game is not launching. If you said it was because of a recent steam update is the fix to use an older client of steam?