PDA

View Full Version : won't launch


dimitry03
04-28-2012, 02:41 PM
everytime i try to launch it it shows up on my dock and then if i try to click on it to bring it up, it goes away. ?? osx lion btw.

purdee
04-28-2012, 11:18 PM
Same here
No response as yet from kalypsomedia
snow leopard

28/04/2012 10:04:49 [0x0-0x13013].com.valvesoftware.steam[181] ServiceStart: failed to start
28/04/2012 10:04:49 com.apple.launchd.peruser.504[135] ([0x0-0x26026].unity.Kalypso.PP2012[268]) posix_spawn("/Users/johnhgough/Library/Application Support/Steam/SteamApps/common/pole position 2012/PP2012.app/Contents/MacOS/PP2012", ...): Permission denied
28/04/2012 10:04:49 com.apple.launchd.peruser.504[135] ([0x0-0x26026].unity.Kalypso.PP2012[268]) Exited with exit code: 1
28/04/2012 10:04:49 [0x0-0x13013].com.valvesoftware.steam[181] Couldn't get PID for app /Users/johnhgough/Library/Application Support/Steam/SteamApps/common/pole position 2012/PP2012.app (-600)
28/04/2012 10:04:50 [0x0-0x13013].com.valvesoftware.steam[181] saving roaming config store to 'sharedconfig.vdf'

idahr
04-29-2012, 05:36 AM
Same problem for me, so I edited the permissions on

/Users/USERNAME/Library/Application Support/Steam/SteamApps/common/pole position 2012/PP2012.app/Contents/MacOS/PP2012

After setting that to read/write for all and unlocking it, I had this come up:

29/04/12 7:25:29.238 PM [0x0-0x1ca1ca].com.valvesoftware.steam: Couldn't get PID for app /Users/USERNAME/Library/Application Support/Steam/SteamApps/common/pole position 2012/PP2012.app (-600)

the system then decides to update:

29/04/12 7:25:29.238 PM [0x0-0x1ca1ca].com.valvesoftware.steam: Game update: AppID 210150 "Pole Position 2012", ProcID 4294967295, IP 0.0.0.0:0


but then it crashes again and falls back to having no permissions.

dimitry03
04-29-2012, 11:50 AM
yeah well id love to say i got a response from steam support. but i apparently don't exist or matter. 2 days now without a response on this and civ 5 goty. glad they care about their customers. last time ihad a response within 12 hours. sorry guys id love to share what they said but nothin.

cryptographrix
05-01-2012, 12:05 PM
To "fix" Pole Position 2012 in Mac OSX:
Open Applications->Utilities->Terminal.

Copy and paste the following 2 lines:
chmod 777 /Users/$(whoami)/Library/Application\ Support/Steam/SteamApps/common/pole\ position\ 2012/PP2012.app/Contents/MacOS/PP2012

chmod +x /Users/$(whoami)/Library/Application\ Support/Steam/SteamApps/common/pole\ position\ 2012/PP2012.app/installscript_osx.vdf

armandoxyz
05-07-2012, 04:52 AM
will try .. thank you !

anthonysomerset
05-09-2012, 01:39 AM
i just tried the above instructions and had partial success

i got it to load the language selection screen in a window, however as soon as i selected it or tried switching to full screen the window disappeared, but i still had audio but couldnt do anything

i am however using an external display with my MBP not sure if thats related

armandoxyz
05-11-2012, 01:07 AM
Crypto: your fix worked .. thank you !

anthonysomerset
05-11-2012, 04:25 AM
i also tried this after unplugging all external displays and it worked fine too, unacceptable that i have to unplug my monitor to play this game