PDA

View Full Version : Beta issues here please


Misfits Attic
05-10-2012, 05:31 PM
So if you have any issues with the Beta (crash, bugs, features missing, etc.) please report them here.


If you can please check here (https://docs.google.com/spreadsheet/pub?key=0AhcJdq5a1q-tdF9EOTRnMDNVMmdtUzNnVlM5MzZXamc&output=html)first to see if it's a known item. You can also find the spreadsheet of of the support (http://www.avirusnamedtom.com/support.html)page.

If it's a crash, we may ask you for your error log which should write out to somewhere like so:
Documents\aVirusNamedTom\aVirusNamedTom_error.log

Thanks so much for the help!

jonathanmcleod
05-11-2012, 06:07 PM
I just wanted to post to comment how well this beta test is being done. To me it feels like a completed game already, I see some people have had some issues, but in an hour or so of gameplay so far, no problems.

Misfits Attic
05-11-2012, 06:19 PM
Thanks! That feels good because we try really hard to test before we update, and we've been testing the standalone for a while now (finding localization & hardware issues earlier rather than later). The only problem is we're still adding some content and that'll make things less stable, but we wont update the build till we've run it through it's paces. Hopefully launch wont have any issues (not big ones anyway)!

We're planning on doing one more major update before our final launch. That will hopefully be mostly good and putting it out to you guys will find the final kinks. Thanks SO MUCH everyone for helping us by getting the beta version and being active!

I just wanted to post to comment how well this beta test is being done. To me it feels like a completed game already, I see some people have had some issues, but in an hour or so of gameplay so far, no problems.

Corn Flake
05-15-2012, 08:27 AM
Game crashed after 2.1 level tutorial. (but now it's ok)
Error log http://dl.dropbox.com/u/32486460/aVirusNamedTom%20eror%20log/aVirusNamedTom_error.log
I downloaded game from steam.

Misfits Attic
05-15-2012, 02:26 PM
Thanks for this, and the log!

Looks like this is part of the memory issues we're having with certain machines. We're currently doing a code cleanup and being more clever about how much we pre-load. If you're willing, I'd love it if you could send general specs on your machine to support@misfitsattic.com

Thanks so much for helping us make the game more stable for everyone!

Game crashed after 2.1 level tutorial. (but now it's ok)
Error log http://dl.dropbox.com/u/32486460/aVirusNamedTom%20eror%20log/aVirusNamedTom_error.log
I downloaded game from steam.

meisjp
05-15-2012, 02:54 PM
Game crashed after 2.1 level tutorial. (but now it's ok)
Error log http://dl.dropbox.com/u/32486460/aVirusNamedTom%20eror%20log/aVirusNamedTom_error.log
I downloaded game from steam.
Corn Flake - thanks for the log/bug info. It looks like you crashed on an out of memory error. The current Beta is running a little heavy on memory, and I've been working on resolving that over the last week.

Like you mentioned (more for anyone else reading this post for the same issue), it will start working again after a restart, and should not cause you to lose any of the scores you got before the crash.

A fix for this should be out at the next Steam update.

Let me know if you have any questions on this issue, or about the game in general.

...and thanks for helping us test out the Beta :)

JP

DoubleD
05-26-2012, 08:06 AM
Game craches at the start. Select the first SP level and goes right to black screen or crash to desktop.

Win7/64. 4GB. 3.0Ghz / Nvidia 520.

Edit: If I skip the intro video and again select the first level It goes to a black screen. You can still here audio.

Niban
05-26-2012, 10:16 AM
If you can grab the error log (as mentioned in the first post) and email it to support@misfitsattic.com with your explanation, they would love to have it :D

( Documents\aVirusNamedTom\aVirusNamedTom_error.log )

Silphatos
05-26-2012, 11:54 AM
The achievements added lately seems not to be working for me, just completed Sidewalk of the Future but couldn't get the achievement. Also I had completed Teleporter before you added the new achievements, and it didn't sync.

I don't really care about the achievements but wanted to report it. :D

Niban
05-26-2012, 12:12 PM
They just registered the 25 newer achievements a few days ago and are still hooking up the code. The Steam version that we have won't activate the achievements yet. They are still being tested internally.

Thanks for caring! There are a few non-standard achievements in there that will be a challenge to complete. So make sure you give those a shot when the achievements are working. It's like Inception; playing a game within a game.

I have heard from the lead developer that they are aiming for the next Steam Beta Build to be released in 2-3 weeks. Most of the achievements should be working then.

DoubleD
05-26-2012, 12:35 PM
If you can grab the error log (as mentioned in the first post) and email it to support@misfitsattic.com with your explanation, they would love to have it :D

( Documents\aVirusNamedTom\aVirusNamedTom_error.log )

Thanks.

Sent.

Misfits Attic
05-26-2012, 03:42 PM
Thanks for sending this! It's a new one so we're looking into it.

Thanks.

Sent.

Misfits Attic
05-26-2012, 03:45 PM
Yep, we've added a bunch of achievements but we're still hooking them all up. We're hoping we'll have time to make them retro-active (at least the "Complete Teleporter" type ones).

meisjp
05-26-2012, 03:51 PM
Game craches at the start. Select the first SP level and goes right to black screen or crash to desktop.

Win7/64. 4GB. 3.0Ghz / Nvidia 520.

Edit: If I skip the intro video and again select the first level It goes to a black screen. You can still here audio.
TrippleD - I got your error log, and also replied to your email.

The log plus your additional descriptions points to the issue possibly being an issue with Windows Media Player.

The XNA game engine relies on WMP being installed on your computer in order to properly play the videos, and it's preferable that you have version 12 installed.

Could you double-check your version of WMP and either upgrade to version 12, or let me know that it is already the latest version so I can cross that off my list as a possible cause? :)

Thanks!

JP

meisjp
05-26-2012, 04:02 PM
Yep, we've added a bunch of achievements but we're still hooking them all up. We're hoping we'll have time to make them retro-active (at least the "Complete Teleporter" type ones).

Just to reiterate what Misfits Attic and Nibian has said, all the new Achievements you see are only available to us internally at the moment. Think of them as a teaser as to what you will be able to earn in the next release :)

When you first run the next release (not yet out), it will play "catch up" by automatically awarding you all of the area completion achievements you would have earned if they had been available in the current release.

For example, if you have completed Area One through Three in the SP campaign, you will automatically be given the achievements for completing those three areas w/o needing to play them again.

In-game achievements, like getting large energy chains, etc, will NOT be automatically given as those can only be earned while playing the next release.

JP

DoubleD
05-26-2012, 06:19 PM
Could you double-check your version of WMP and either upgrade to version 12, or let me know that it is already the latest version so I can cross that off my list as a possible cause? :)

Thanks!

JP

Hi,
Thanks for the email and post.

WMP V 12.0.7601.17514. Checking for updates tells me I have the current version.

I have not tried the game yet on my other PC which is Vista 32.


Edit: Also I tried the game again and this time after I select the first level it goes to a black screen after the billboard. Before it would zoom in on the dog before it went to a black screen. With muisc still being heard in the backround each time.


Also thanks for looking into it.

meisjp
05-26-2012, 06:46 PM
Hi,
Thanks for the email and post.

WMP V 12.0.7601.17514. Checking for updates tells me I have the current version.

I have not tried the game yet on my other PC which is Vista 32.



Thanks for checking/confirming the WMP version. After your last post, I caught something that I missed the first time around. I believe when you are saying "Level 1" you might actually have meant "Area 1". So when you enter Area 1 (the Billboard reading "Pet of Tomorrow") it goes black, correct? Sounds like I misunderstood and then misdiagnosed your issue. Let me step back and try looking at it again :)

Edit: Also I tried the game again and this time after I select the first level it goes to a black screen after the billboard. Before it would zoom in on the dog before it went to a black screen. With muisc still being heard in the backround each time.


Also thanks for looking into it.


Meanwhile, the behavior you describe in your edit is valid (you know, except for the part about it not working, heh). The first time you enter Area One, we play the transition you describe (zooming into the dog, etc). From then on we only show a quick "scanline" transition (one line that swipes horizontally, and one that swipes vertically).

So NOT seeing the "zoom" the 2nd time through is valid. Question - the 2nd time, before it went black, did you see the 2 scanlines of the quick transition?

I can include screen shots if any of this (Level 1 vs. Area One, scanlines, etc) is confusing/hard to follow in plain text :)

DoubleD
05-26-2012, 06:55 PM
No it just goes to black. Oh and yes when you start the game you only see the first billboard. The rest are locked. When I select the first billboard or area 1 by hitting the enter key it would at first zoom into the dog on the billboard. (At least I thought I remember it doing that?) Now it just goes to a black screen after hitting enter. Again music can still be heard. Don't recall see any scan lines.

I tried on my Vista PC and the same thing happened. But of course I believe it has WMP11 on that machine since my duaghter uses iTunes. ;)

meisjp
05-26-2012, 07:07 PM
No it just goes to black. Oh and yes when you start the game you only see the first billboard. The rest are locked. When I select the first billboard or area 1 by hitting the enter key it would at first zoom into the dog on the billboard. (At least I thought I remember it doing that?) Now it just goes to a black screen after hitting enter. Again music can still be heard. Don't recall see any scan lines.

I tried on my Vista PC and the same thing happened. But of course I believe it has WMP11 on that machine since my duaghter uses iTunes. ;)

:D Well my WPM idea was because I was thinking it was while starting the level 1 game. (I use iTunes too ;) )

I'm going to take this conversation "private" for the moment (continue it in email). Because you have the same problem on 2 computers, and assuming you logged in to both with the same Steam ID, then I have some thoughts that could be causing this, and it might involve a more personal discussion about your Steam profile settings.

Others: I'll post a resolution info on this issue after we discuss further offline.

DoubleD
05-26-2012, 07:09 PM
: Because you have the same problem on 2 computers, and assuming you logged in to both with the same Steam ID, then I have some thoughts that could be causing this, and it might involve a more personal discussion about your Steam profile settings.


Sounds good.

And yes I used the same Steam account on Both PC's. I only have 1 Steam copy of the game.

meisjp
05-27-2012, 12:20 AM
:D Well my WPM idea was because I was thinking it was while starting the level 1 game. (I use iTunes too ;) )

I'm going to take this conversation "private" for the moment (continue it in email). Because you have the same problem on 2 computers, and assuming you logged in to both with the same Steam ID, then I have some thoughts that could be causing this, and it might involve a more personal discussion about your Steam profile settings.

Others: I'll post a resolution info on this issue after we discuss further offline.

Final Status of this Issue (for all following this topic): We found that some players have trouble accessing areas in the game if they, or their friends, have characters we don't yet support (foreign characters, etc). This will be resolved in the next release.

In the meantime, if you experience the same issue as described by TippleD (game crashes and/or the screen turns black when trying to enter Area One [Pet of Tomorrow]), send me an email through support and I will help you patch your version.

IMPORTANT: The patch adds no additional features, etc, to the game, and is only needed if you are having this specific issue.

Thanks!

JP

DoubleD
05-27-2012, 09:03 AM
Yes thanks to the developers for trouble shooting and coming up with the cause of the issue and a solution. Quickly! And all this on a late Saturday evening, (Well in my area it was late Saturday evening). :)

A+ game by the way.

LeVengeurSlippe
06-22-2012, 03:07 PM
Can you add support for keyboards layouts other than qwerty? From what I tried, multiplayer on an azerty keyboard will certainly result in broken fingers. Don't think qwertz will be a problem though, but dvorak may get a little funky.

Niban
06-22-2012, 03:21 PM
What do the layouts of those keyboards look like? I've never seen one. Guess it's time to Google. They currently have support for 3 layouts and you can switch at any time (assuming you are playing SP).

ASWD
Arrow Keys
10-Digit num Pad: 8,4,6, (5 or 2 for down)

meisjp
06-22-2012, 03:41 PM
Can you add support for keyboards layouts other than qwerty? From what I tried, multiplayer on an azerty keyboard will certainly result in broken fingers. Don't think qwertz will be a problem though, but dvorak may get a little funky.

Hey LVS, good to hear from you again :)

Supporting the azerty KB layout is a really good idea (and one I wish I had come up with), but probably one we'll have to hold off on until after the release.

I know it's a pain, but I'm sure you are aware that you can toggle between layouts in Windows. Not an awesome workaround, but one way to give those broken fingers a change to heal :)

Misfits Attic
06-22-2012, 04:15 PM
We debated ESDF instead of WASD but got feedback that WASD was such a standard to stick with that. Like Jeremy said, probably not for launch but maybe we can address it after. The thought of having a config file for re-binding keys/buttons appeals to me as a possible solution.

Hey LVS, good to hear from you again :)

Supporting the azerty KB layout is a really good idea (and one I wish I had come up with), but probably one we'll have to hold off on until after the release.

I know it's a pain, but I'm sure you are aware that you can toggle between layouts in Windows. Not an awesome workaround, but one way to give those broken fingers a change to heal :)

LeVengeurSlippe
06-22-2012, 05:49 PM
What do the layouts of those keyboards look like?

They look amazing. Seriously. They're beautiful with all their accents and gorgeous ... You should be ashamed you haven't got all these marvels on your keyboard, you bloody English speaking persons.

I know it's a pain, but I'm sure you are aware that you can toggle between layouts in Windows. Not an awesome workaround, but one way to give those broken fingers a change to heal :)

Yeah, this is a feature I really don't use often... It becomes pretty confusing when you don't know by heart the layout you're trying to use... But that's not a problem with the simple bindings you made for AVNT. Anyway, this is indeed a workaround, but a really dirty one. I'm not sure many people will think of doing this if they're confronted with this problem. Especially French people. I mean, they (we) are French. They deserve it a little, don't they? (Hint: make this feature a day-one DLC.)

super_aardvark
06-25-2012, 08:17 AM
Completing 2.8 unlocks both 2.9 and 2.10. Not sure if that's a bug or not.

Also, after completing all of level 2, I didn't get the achievement. Not sure if that's because I did 2.10 before 2.9, or if this is NYI (I did get an achievement for level 1), or a separate bug.

Niban
06-25-2012, 11:27 AM
The entire game unlocks like that, a couple levels at a time so you aren't stuck. I'm pretty sure this is the way they intended it.

In regards to the achievement, only the level 1 achievement will work until the Steam Beta is updated. From their AVNT Group it was just announced:

"...our release date has been pushed back to early August. As such we're taking some more time to QA and hope to release the final Beta update in the next week or two. When we do this we'll announce the contest levels as well." ( http://steamcommunity.com/games/aVirusNamedTom/announcements )

Misfits Attic
06-25-2012, 12:01 PM
Yeah, it's been confusing that you get just 1 achievement right now so I added a sticky post to the top of the forum explaining it. Basically the rest will be available once we update and we'll retro-actively unlock any of the area ones you've earned. Thanks!

ChocoladeEter
06-27-2012, 10:23 AM
After finishing the first level, the game crashed and when I restarted everything seemed normal. However, when I try to continue my game I just get a black screen (just after selecting the dog level/image). The game seems to continue normally, but I can't see a thing. Reinstalling the game didn't work.

Misfits Attic
06-27-2012, 12:58 PM
This sounds somewhat like a known issue but to be sure, could you email you error log (somewhere like: Documents\aVirusNamedTom\aVirusNamedTom_error.log) to support@misfitsattic.com? I believe we have a patch for this but I just want to be sure it's the same issue I'm thinking of.

Thanks! And sorry for the trouble.

After finishing the first level, the game crashed and when I restarted everything seemed normal. However, when I try to continue my game I just get a black screen (just after selecting the dog level/image). The game seems to continue normally, but I can't see a thing. Reinstalling the game didn't work.

ChocoladeEter
06-27-2012, 04:23 PM
Hi, I tried deleting everything related to the game to see if that would fix things. But since it didn't, I kept everything in the recycle bin (which was eventually emptied :/). The game hasn't generated a new folder since (most likely because it hasn't crashed since then, but the black screen remains).

Misfits Attic
06-28-2012, 12:52 PM
Doh. Well lemme take a wild guess and say that maybe it's the leaderboard problem we're having when players have non-english characters in their Steam username or a friends username (see above in this thread). We've fixed it, but haven't updated the Beta yet. Could you try running the game directly from the .exe and see if this allows you to run normally? If it does then we can get you a patch. The .exe should be somewhere like this:
C:\Program Files (x86)\Steam\steamapps\common\a virus named tom\AVNT.exe

Either way could you email support@misfitsattic.com? That way we can get you the patch or dig into this deeper with the rest of the team? Thanks!

Hi, I tried deleting everything related to the game to see if that would fix things. But since it didn't, I kept everything in the recycle bin (which was eventually emptied :/). The game hasn't generated a new folder since (most likely because it hasn't crashed since then, but the black screen remains).

meisjp
06-30-2012, 02:06 PM
Hi, I tried deleting everything related to the game to see if that would fix things. But since it didn't, I kept everything in the recycle bin (which was eventually emptied :/). The game hasn't generated a new folder since (most likely because it hasn't crashed since then, but the black screen remains).

Hey ChocoladeEter - I just sent you an email with a patch to fix your issue. Please let me know if you don't receive it, and/or if you continue to have issues.

Thanks!

JP

ChocoladeEter
07-04-2012, 02:53 PM
Thanks all, I used the patch and it's working properly now. Lovely game :)

meisjp
07-04-2012, 04:18 PM
Thanks all, I used the patch and it's working properly now. Lovely game :)

Great - glad to hear it!

Let us know if you run into any other issues.

Thanks,

JP

jonathanmcleod
07-07-2012, 05:46 PM
Bug: On the intro to section 5, modified is spelt incorrectly in the text on screen. Should be an easy fix for you guys! :D

Misfits Attic
07-07-2012, 05:48 PM
Got it, thanks for the help!

woko
07-15-2012, 02:31 AM
I experienced a few crashes.

14/07/2012 08:16:05
System.ArgumentException: The character '♥' (0x00a0) is not available in this SpriteFont. If applicable, adjust the font's start and end CharacterRegions to include this character.
Nom du paramtre♥: character
Microsoft.Xna.Framework.Graphics.SpriteFont.GetInd exForCharacter(Char character)
Microsoft.Xna.Framework.Graphics.SpriteFont.Intern alDraw(StringProxy& text, SpriteBatch spriteBatch, Vector2 textblockPosition, Color color, Single rotation, Vector2 origin, Vector2& scale, SpriteEffects spriteEffects, Single depth)
Microsoft.Xna.Framework.Graphics.SpriteBatch.DrawS tring(SpriteFont spriteFont, String text, Vector2 position, Color color)
CircuitGame.EliminationRoomGame.Draw(GameTime gameTime)
CircuitGame.ScreenManager.Draw(GameTime gameTime)
Microsoft.Xna.Framework.Game.Draw(GameTime gameTime)
CircuitGame.GameStateManagementGame.Draw(GameTime gameTime)
Microsoft.Xna.Framework.Game.DrawFrame()
Microsoft.Xna.Framework.Game.Tick()
Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
Microsoft.Xna.Framework.GameHost.OnIdle()
Microsoft.Xna.Framework.WindowsGameHost.RunOneFram e()
Microsoft.Xna.Framework.WindowsGameHost.Applicatio nIdle(Object sender, EventArgs e)
System.Windows.Forms.Application.ThreadContext.Sys tem.Windows.Forms.UnsafeNativeMethods.IMsoComponen t.FDoIdle(Int32 grfidlef)
System.Windows.Forms.Application.ComponentManager. System.Windows.Forms.UnsafeNativeMethods.IMsoCompo nentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
System.Windows.Forms.Application.ThreadContext.Run MessageLoopInner(Int32 reason, ApplicationContext context)
System.Windows.Forms.Application.ThreadContext.Run MessageLoop(Int32 reason, ApplicationContext context)
System.Windows.Forms.Application.Run(Form mainForm)
Microsoft.Xna.Framework.WindowsGameHost.Run()
Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
CircuitGame.Program.Main()

14/07/2012 08:17:29
System.ArgumentException: The character '♥' (0x00a0) is not available in this SpriteFont. If applicable, adjust the font's start and end CharacterRegions to include this character.
Nom du paramtre♥: character
Microsoft.Xna.Framework.Graphics.SpriteFont.GetInd exForCharacter(Char character)
Microsoft.Xna.Framework.Graphics.SpriteFont.Intern alDraw(StringProxy& text, SpriteBatch spriteBatch, Vector2 textblockPosition, Color color, Single rotation, Vector2 origin, Vector2& scale, SpriteEffects spriteEffects, Single depth)
Microsoft.Xna.Framework.Graphics.SpriteBatch.DrawS tring(SpriteFont spriteFont, String text, Vector2 position, Color color)
CircuitGame.EliminationRoomGame.Draw(GameTime gameTime)
CircuitGame.ScreenManager.Draw(GameTime gameTime)
Microsoft.Xna.Framework.Game.Draw(GameTime gameTime)
CircuitGame.GameStateManagementGame.Draw(GameTime gameTime)
Microsoft.Xna.Framework.Game.DrawFrame()
Microsoft.Xna.Framework.Game.Tick()
Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
Microsoft.Xna.Framework.GameHost.OnIdle()
Microsoft.Xna.Framework.WindowsGameHost.RunOneFram e()
Microsoft.Xna.Framework.WindowsGameHost.Applicatio nIdle(Object sender, EventArgs e)
System.Windows.Forms.Application.ThreadContext.Sys tem.Windows.Forms.UnsafeNativeMethods.IMsoComponen t.FDoIdle(Int32 grfidlef)
System.Windows.Forms.Application.ComponentManager. System.Windows.Forms.UnsafeNativeMethods.IMsoCompo nentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
System.Windows.Forms.Application.ThreadContext.Run MessageLoopInner(Int32 reason, ApplicationContext context)
System.Windows.Forms.Application.ThreadContext.Run MessageLoop(Int32 reason, ApplicationContext context)
System.Windows.Forms.Application.Run(Form mainForm)
Microsoft.Xna.Framework.WindowsGameHost.Run()
Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
CircuitGame.Program.Main()

meisjp
07-15-2012, 02:41 AM
I experienced a few crashes.

Likely this has to do with you or a friend having an unusual character in the steam name. We thought we had that issue locked down in this release.

I'll look into it on this side first thing in the morning, and get back to you with a solution.

Thanks for the heads up!

JP

meisjp
07-15-2012, 03:18 PM
I experienced a few crashes.

Hey Woko...ok, I've been looking into this issue. First, I'm glad (relieved) to say it's NOT the steam name issue coming back like I feared!

The issue is related to your computer's regional settings. More specifically it's a limitation in our game that is assuming a US number format when displaying the energy in a game. When the energy exceeds 999 (1,000 or greater), the crash is triggered. I've been able to reproduce here using the French regional setting. I know the fix, and am working on it at the moment.

To make sure I correctly address your issue with this fix, could you let me know your Windows' language/region settings?

Again, I apologize about the crash, and thanks again for helping us resolve it!

JP

woko
07-17-2012, 12:23 PM
It is French. This happened while I was practicing on level 2.05. I used another computer for the contest with US settings.

Another thing I noticed is sometimes the winning screen came before I really should have won on level 2.05, which made my score lower than the score I was aiming by finishing the level with my manner. But this only happened a few times, randomly.

meisjp
07-17-2012, 12:58 PM
It is French. This happened while I was practicing on level 2.05. I used another computer for the contest with US settings.

Ok, cool. If you drop me an email at support, I can send you a patch that should fix your FR machine. However, Steam will be updated soon (release in < 2 weeks) which will also have that fix if you just want to wait. Either way works for me.

Another thing I noticed is sometimes the winning screen came before I really should have won on level 2.05, which made my score lower than the score I was aiming by finishing the level with my manner. But this only happened a few times, randomly.

Do you think it might be possible to catch the early victory screen issue you mentioned in action (using fraps or the like)? I can't picture what might trigger something like that to happen :)

Thanks!

JP

woko
07-17-2012, 01:36 PM
I can wait for the fix. I may be a bit busy for the next week or so anyway.

As for the early victory screen, it seems a bit random and only happens rarely. I might try to catch it.

mungo1913
07-18-2012, 07:44 PM
When running in fullscreen mode I can only see a little more than the top left quarter of the game. My monitor can handle up to 1024x768, and the game runs fine windowed, but when I switch to fullscreen it seems like it's trying to display 1024x768 but only showing the top left 800x600. On the main menu, I see nothing below "Options". I'm running the steam version of the game, and my video card is an ATI Radeon HD3450 with the latest drivers.

I took some screenshots here (http://steamcommunity.com/id/Mung0/screenshots/).

EDIT:Oops sorry, just reread the first post, I now see this is a known issue.

Misfits Attic
07-18-2012, 08:51 PM
Yeah, I'm so sorry. Currently we don't support less than 1280x720. Screen resolution is something we didn't look at till the end of development and we worried that a major update to the code would delay us more. Please email support@misfitsattic.com if you don't have a monitor that supports AVNT and we'll see what we can do for you. Thanks, and sorry :\

When running in fullscreen mode I can only see a little more than the top left quarter of the game. My monitor can handle up to 1024x768, and the game runs fine windowed, but when I switch to fullscreen it seems like it's trying to display 1024x768 but only showing the top left 800x600. On the main menu, I see nothing below "Options". I'm running the steam version of the game, and my video card is an ATI Radeon HD3450 with the latest drivers.

I took some screenshots here (http://steamcommunity.com/id/Mung0/screenshots/).

EDIT:Oops sorry, just reread the first post, I now see this is a known issue.

meisjp
07-20-2012, 09:37 PM
All Beta Owners: There was an issue with the latest release (out 7/20/12). If you downloaded this version, you may not be able to play right away.

See this thread for more information on the issue, as well as a patch you can download to fix the issue (so you can keep those high scores coming in!): http://forums.steampowered.com/forums/showthread.php?t=2826172

Unfortunately getting Steam to release updates on a weekend is all but impossible, so plan on the corrected release not being available until Monday (7/23/12). Until then, the patch should resolve any issues you have with the current one.

Thanks,

JP

noseforget
07-21-2012, 08:15 PM
desde siempre pongo el ajuste a pantalla completa en 1920x1080 pero no cambia sigue pequea la pantalla. en los ajuste aparece 1920x1080 pero no funciona
w7 home premium x64, i7 2630, nvidia gt54m (notebook) 2gb, 8 gb ram, 1920x1080
desde ya muchas gracias

always put the setting to display full 1920 x 1080 but does not change the screen is small. in the setting 1920 x 1080 appears but does not workW7 home premium x 64, i7 2630, nvidia gt54m (notebook) 2 gb, 8 gb ram, 1920 x 1080from already thank you

meisjp
07-21-2012, 10:12 PM
desde siempre pongo el ajuste a pantalla completa en 1920x1080 pero no cambia sigue pequea la pantalla. en los ajuste aparece 1920x1080 pero no funciona
w7 home premium x64, i7 2630, nvidia gt54m (notebook) 2gb, 8 gb ram, 1920x1080
desde ya muchas gracias

always put the setting to display full 1920 x 1080 but does not change the screen is small. in the setting 1920 x 1080 appears but does not workW7 home premium x 64, i7 2630, nvidia gt54m (notebook) 2 gb, 8 gb ram, 1920 x 1080from already thank you

Hey, thanks for playing our game (and for translating your question!). The resolution options are a little misleading, and do not control the size of the game. It will always run at 1280x720, with black borders when needed to fill the remaining screen space. That option allows you to choose other resolutions other than the default when running in full screen (default = what the game thinks would look best on your hardware).

We exposed that option to players to give them the ability to override the default full screen resolution. In earlier beta releases, people either had to accept the default, or run the game in Windowed mode.

Most people do not need to override the resolution to get the best look. On some systems, however, it can pick a resolution with a different aspect ratio as the game, which causes it to look stretched or squashed, and is the primary use case of that particular setting.

I know the setting's name sounds like it will make the game (in your case) fill a 1920x1080 screen. In a later, post-release version, we plan to offer that type of scaling. For now, however, it's just about adjusting the full screen resolution to find one that makes the game look better to you.

In all cases, if the resolution chosen is larger than 1280x720, there will be the black "filler" border.

I hope that answers your question, but please let me know if this isn't clear, or if you need additional assistance...

Thanks!

JP

noseforget
07-22-2012, 01:23 PM
1920x1080 es solo para modo ventana (entendi bien?)

1920 x 1080 is only for window mode (do understand well?)

noseforget
07-22-2012, 01:57 PM
Ahhhhhhh! en realidad no existe la resolucion 1920x1080, solo aparece por si existen problemas de compatibilidad?


Ahhhhhhh! in reality there is no resolution 1920 x 1080, only appears if there are compatibility issues?

Misfits Attic
07-22-2012, 02:45 PM
Exactly. So sorry it's mis-leading :\
We put it in because some players with odd aspect ratios saw some stretching in full screen, or wanted full screen but didn't support 1280x720. We basically put a black box around it.

Hopefully on a future update we can do a better job of filling the screen by scaling the images etc. We just ran out of time/$ for now.

Hope that makes sense, and sorry again for the confusion.

Ahhhhhhh! en realidad no existe la resolucion 1920x1080, solo aparece por si existen problemas de compatibilidad?


Ahhhhhhh! in reality there is no resolution 1920 x 1080, only appears if there are compatibility issues?

Varstahl
08-01-2012, 05:26 PM
I have a couple questions regarding problems in the game.

First comes the oddity: if I started campaign, decide to go back, quit, menu and then go again for Single Player Story the game simply shuts down, cleanly, no questions asked.

Then a real problem: no videos whatsoever for me, no tutorials, no nothing. The error log shows something like this a few times:

System.InvalidOperationException: An unexpected error has occurred.
at Microsoft.Xna.Framework.Media.VideoPlayer.Play(Vid eo video)
at CircuitGame.VideoManager.Start()
I saw that the videos are WMV, the framework is Xna, and thus assume the problem relies in the fact that I disabled standard windows video decoders in favor of FFDShow.

So basically I just get either plain black screen, or black screens with a "Skip/Continue" buttons. I'll be looking at the standard decoders issue to find out whether or not it's the real deal.

If you have any heads up I'll be glad to hear.


Great game btw, had to buy as soon as I saw it. Really great fun.

__________________________________________________


Edit

It just so happens I answered both my questions.

2 - Using Win7DSFilterTweaker 4.6 as a reference, everything can disabled and be assigned to FFDShow EXCEPT for 32bit WMV3 preferred decoders which MUST be set to Microsoft instead of FFDShow in order to show both the videos and the tutorials. Keep this in mind, I might not be the only one with this issue.

1 - This happens only if the video decoding has failed the first time apparently. Since I fixed the videos, the start/quit/start doesn't close the game anymore. You might correct the code if you see fit.

Cheers :)

meisjp
08-01-2012, 05:53 PM
I have a couple questions regarding problems in the game.

First comes the oddity: if I started campaign, decide to go back, quit, menu and then go again for Single Player Story the game simply shuts down, cleanly, no questions asked.

Then a real problem: no videos whatsoever for me, no tutorials, no nothing. The error log shows something like this a few times:

System.InvalidOperationException: An unexpected error has occurred.
at Microsoft.Xna.Framework.Media.VideoPlayer.Play(Vid eo video)
at CircuitGame.VideoManager.Start()
I saw that the videos are WMV, the framework is Xna, and thus assume the problem relies in the fact that I disabled standard windows video decoders in favor of FFDShow.

So basically I just get either plain black screen, or black screens with a "Skip/Continue" buttons. I'll be looking at the standard decoders issue to find out whether or not it's the real deal.

If you have any heads up I'll be glad to hear.


Great game btw, had to buy as soon as I saw it. Really great fun.

Thanks for the great comments on the game!

Yes - XNA unfortunately relies on WMP (not sure the specific codec, but it uses WMP to run the videos). Just one of the many side-"benefits" of using a Microsoft-based technology :)

Let me know how the codec/decoder hunt goes for you, and/or if you are unable to get it to work. I do believe, however, that you are on the right track...

JP

meisjp
08-01-2012, 05:55 PM
It just so happens I answered both my questions.

2 - Using Win7DSFilterTweaker 4.6 as a reference, everything can disabled and be assigned to FFDShow EXCEPT for 32bit WMV3 preferred decoders which MUST be set to Microsoft instead of FFDShow in order to show both the videos and the tutorials. Keep this in mind, I might not be the only one with this issue.

1 - This happens only if the video decoding has failed the first time apparently. Since I fixed the videos, the start/quit/start doesn't close the game anymore. You might correct the code if you see fit.

Cheers :)

Great, thanks for the additional info! I'll check out what you've done on my side. Sounds like an interesting way of fixing the issue for those that prefer to not use the standard player.

JP

Varstahl
08-01-2012, 06:13 PM
I use my PC for gaming and home theater needs, and the switch was mainly needed to properly support multi-language audio streams and subtitles. The Win7DSFilterTweaker lets you manually disable Win7 Microsoft Decoders, Media Foundations and manually set for each video type the decoder you want. This way every program will rely on video decoders you choose rather than MS defaults. And as we discovered today, it may cause a "slight" problem with XNA & video playback.

Every day's a learning day...

Misfits Attic
08-01-2012, 08:20 PM
Yeah, thanks Varstahl for sharing the info with the group. The game is gonna be too easy for you now that you can watch the tutorials ;) Stuff like this is why I'm glad we have an option to shot the videos every time!

That's only two problems and two fixed problems on launch <crosses fingers>. Thanks goes to all our pre-order-ers for ramming the hell out of the beta!

Varstahl
08-02-2012, 07:00 AM
Actually I'm a pre-order-er too, I just thought it was "normal" in beta for whatever reason until I came to conclusion that... well... it really wasn't.

Back to playing now :D

Misfits Attic
08-02-2012, 10:53 AM
Hahaha, no we didn't intend to keep the videos from you ;)