PDA

View Full Version : Unable to playAvernum 4 and 5


DrHojo123
05-16-2012, 05:50 AM
It just crash's to desktop no matter what is it a problem with Win7 or what? it doesnt warn me about it on the bundle or anything

DJ_Ig
05-16-2012, 07:46 AM
I too have this problem. But on Vista. The Data Execution Prevention stops it running and it won't let me disable it - it worked fine before today.

ibitato
05-16-2012, 08:05 AM
it seems that there is a problem with latest steam client update
and the games.

that is why yesterday you could play ok and today you can't

see spiderweb forums

chrome242
05-16-2012, 10:39 AM
What ibitato said. And if you own the Geneforge games, exepct the same problem there too. Worked fine until the last steam Client update. =(

Tripiṭaka
05-16-2012, 11:05 AM
Ditto here. Windows 7 64 bit.

4 and 5 crash on launch. Seems to be a memory management (heap) issue.

- ugh and yep same with geneforge 1-4.

Tripiṭaka
05-16-2012, 11:19 AM
Tried to fix with the application compatability toolkit (emulate heap).

Didn't work :(

DrHojo123
05-16-2012, 12:47 PM
Hopefully the notice and patch it soon I just brough these if I knew 4 and 5 wasnt working I would of saved money and just got 6

LLAndy
05-16-2012, 01:51 PM
It seems to be working the first time you play it, as mine worked earlier when I just tried it out. Now when I try it again, it crashes.

Actually, now that I think about it, I did restart steam between tries so maybe it updated and it's all on the new steam client version.

Meirnon
05-16-2012, 02:25 PM
Yeah, same problem. Steam updater is likely what messed it up. It isn't the games not running on a 64-bit system.

whitknight25
05-16-2012, 03:20 PM
It's exactly what the middle user have said I'll quote ibitato, "

it seems that there is a problem with latest steam client update
and the games.

that is why yesterday you could play ok and today you can't

see spiderweb forums"

^^^^^^^^^^^^^ That's the exact Issue Steam Update

ibitato
05-17-2012, 08:58 AM
From spiderweb forums:

It's definitely related to the steam update. I have two machines with steam, I ran the update on my primary (Win7/64-bit) machine and Avernum 4 stopped working.
I then copied the steam install from my secondary machine (everything except the steamapps folder which contains the games themselves) and Avernum 4 works again.

Avernum 4 works with steam client:
Built: April 18 2012, at 10:17:32
Steam API: v012
Steam package versions: 1868 / 1868

Avernum 4 does not work with steam client:
Built: May 15 2012, at 10:21:05
Steam API: v012
Steam package versions: 1869 / 1869

There were no changes at all made to the Avernum 4 install during this test, so that presumably rules out an issue due to a change on Spiderweb's side (though they may still be stuck holding the bag to work around the crash).

Dalfurion
05-17-2012, 12:18 PM
Add me to the list. The games (Avernum 4 & 5) just won't run.

On the Avernum website it says this as a present solution until somebody figures out what's going on:


I bought this game on Steam and it crashes on launch:
A number of people have purchased Geneforge Saga and Avernum 4-6 from Steam and found that they crashed on launch. This problem seems more common (or exclusive to) on 64-bit versions of Windows.

It is not a universal problem. It doesn't happen on all Windows PCs, even those using the 64-bit version of the operating system. However, we are determined to make sure everyone who pays for these games gets a working copy of them.

If you purchased one of our games on Steam and it doesn't work, write us at support@spiderwebsoftware.com. Be SURE to tell us the games that aren't working. We will provide a download link to a version that should work correctly for you.

We apologize for the inconvenience, and we are also talking to Steam. Hopefully we can come up with a fix for the problem.


http://www.avernum.com/avernum6/support.html

Tripiṭaka
05-17-2012, 12:48 PM
If you can wait a few days the problem should be fixed.

I have heard back from Steam. Nobody will be surprised to hear that this IS a problem related to the newest Steam update. They are working on fixing it.

If they can't fix it soon, I have come up with versions of Avernum 4 and 5 and Geneforge 1-4 that work around the problem, and I will submit the patches on Monday if the issue isn't resolved by them.

I may be able to come up with a workaround sooner, but I need to check in with Steam to see if it's workable for general users.

We apologize sincerely for this problem. It WILL be fixed in the next few days.

In the meantime, Geneforge 5 and Avernum 6 do work. Playing them instead of the game you want to play is a lousy solution, but at least it's something to do until them.

- Jeff Vogel
_________________________
Official Board Admin
spidweb@spiderwebsoftware.com

sea-
05-17-2012, 03:57 PM
The recent Steam beta update fixes this problem.

LLAndy
05-17-2012, 07:58 PM
the update just went live for me and fixed it :D

Meirnon
05-17-2012, 08:03 PM
New update fixes it. Just click the "Steam" tab on your client and choose "Check for Steam Client Updates". It'll update, restart, and you'll be able to play the games again.

fenixraven
05-17-2012, 11:22 PM
ironically i got to like the 7th post and steam wanted to update :P now it works

whitknight25
05-18-2012, 06:50 AM
I had to restart steam a couple of times (just showed checking for updates)..and even cancel the download once (stopped at 16.18)..but finally it downloaded..and yup..everything works again..:)