PDA

View Full Version : Game crush


Genkaro
07-04-2012, 01:21 AM
Precipice of Darkness 3. Doesn’t work for me on Windows 7 x64. Nor is Cthulhu, your previous game. Even though they did on my other PC which uses Windows XP SP3. Both have similar error and crash after intro screen (Rainslick after your logo, Cthulhu after full quirky name of the game). Same problem as the guy here:
http://zeboyd.com/2010/06/11/cthulhu-saves-the-world-press-release/comment-page-2/#comment-11774
Here is the error. Excuse me for such… strange form, the only way I managed to extract it:

CLR20r3
rainslick3.exe
1.0.0.0
4fefab6d
mscorlib
4.0.0.0
4ba1da6f
3dab
105
System.IO.DirectoryNotFound

6.1.7600.2.0.0.256.1
2057
0a9e
0a9e372d3b4ad19135b953a78882e789
0a9e
0a9e372d3b4ad19135b953a78882e789

Now, for “typical solutions” I googled before posting. Media Player 10 – installed, working, dll’s are in right place. .NET – installed from file provided in game folder, after uninstalling previous version and registry cleaning. Did restart after both uninstalling and installing too. XNA – same as above. Running as administrator – didn’t help. Compatibility with XP – didn’t help. Checking for integrity – didn’t help, though in case of Cthulhu it consistently finds one “problem” file and downloads it. In case of Rainslick – doesn’t find a thing, clean install. Direct X – 11 and latest. Video/Audio drivers – latest version, videocard GTX460, without any sort of extensive tinkering. Trying to force using one core out of 6 (AMD 1090T) didn’t help either. Would really like some input on my problem. Greatly enjoyed Cthulhu and would like to play it on this PC too. Not mentioning new game. Both games are bought from Steam.

morbosfist
07-04-2012, 08:44 AM
Use compatibility mode to set it to XP. This seems to be a common issue.

Genkaro
07-05-2012, 12:15 AM
Compatibility with XP – didn’t help.
And checked again just to make sure today. Nope, still not helping.

morbosfist
07-05-2012, 12:50 AM
The latest version of media player is 11/12. Install that. Also try running through other compatibility modes besides XP.

Genkaro
07-05-2012, 02:16 AM
WMP comes with Windows 7, version 11 or 12. It seems they call slightly tuned 11 version 12. Anyway, technically I have version 12. Checked other compatibility modes and... nothing. I have some suspicions that most likely there is a problem with XNA, but... I tried cleanly re-installing it. My friend has Windows 7 too and it works fine for him. Didn't need to do anything to get it work either. So it is definitely problem on my side. I just can't get which problem and where.

morbosfist
07-05-2012, 10:33 AM
Is your friend running the 64 bit version, or the 32 bit one?

Genkaro
07-05-2012, 02:47 PM
64 bit. The very reason I mentioned this. It seems that overall game works fine for majority on 64-bit Win7. Some need to do things you mentioned, other don't. But there is some serious problem on my side. The problem I couldn't solve with ways I found while looking through forums. And after trying everything listed above... I can only do two things: wait for someone who solved similar problem or, ultimately, perform a hardcore manly reinstall of operation system with complete formating of system disk. Second choice would make me really sad, even though this games are great and totally worth trying.