PDA

View Full Version : Crashes after today's update


give all
07-30-2012, 04:35 AM
Just got 200 kb update and now the game crashes after launch.
Verifying doesn't help.

brighat
07-30-2012, 11:38 AM
In TotalBiscuit's Adventures Of Shuggy video, the game crashed a couple of times. This is nothing but a straight port of the Xbox 360 version. The game crashes if you try to play it in 1080p full screen or if you try to access the leaderboards.

His ranting was very funny, though. I didn't hear about this guy until a few days ago but he's apparently very popular with grown men who spend all day watching YouTube videos simply because there's nothing to watch on T.V. or they desperately need to say something about everything even if they know jack about it.

Just another reason to hate lazy developers who use a 7 year-old console as their lead platform.

Baskyn4a
07-30-2012, 12:37 PM
Game crashing randomly when you try see leaderboards. Full Screen is work fine for me, no crashes.

SmudgedCat
07-31-2012, 04:16 AM
There was a problem with yesterday's update which is hopefully resolved now.

Are people still seeing problems accessing the leaderboards?

give all
07-31-2012, 05:31 AM
Works for me.
Now, how can I change game's language? It seems it's the same as OS's language.

SmudgedCat
07-31-2012, 06:20 AM
There's currently no option in-game to change the language. You'll need to switch the OS language to English if that's what you want.

Don't you want the game in the same language as the OS?

sm00th
07-31-2012, 11:50 PM
There's currently no option in-game to change the language. You'll need to switch the OS language to English if that's what you want.

Don't you want the game in the same language as the OS?
I just can talk for Europe, OS is in englisch or local language, most games are in english. I think I don't need to put a big hammer out why that is mostly the case, so just some random words: english at school, bad translations, no translations at all, like original content.

I am german and I rarely play games in my language. I don't own the game but I would deeply hate you if you force me to play in a language not of my choice. And as a german nitpicker, the store tells me that the game is only available in English.

Changing the OS language is no option if you don't ment the IME keyboard changing option. For windows you can only switch languages if you own Ultimate or Enterprise version of it, most sold in europe is Home Premium.

give all
08-01-2012, 10:10 AM
There's currently no option in-game to change the language.
I just thought maybe there is some registry key or config file.

Don't you want the game in the same language as the OS?
Since russian localization have ugly arial instead of pretty in-game font, it's not the best idea. Anyway, it's not a big deal.

At The Gates
08-13-2012, 10:48 AM
Great game but I just crashed and restarted the game and lost all my progress(even though I hadnt gotten too far)

I'm hoping it doesnt happen again.

SmudgedCat
08-13-2012, 11:06 AM
Sorry you lost progress, can I ask what you were doing when the game crashed?

At The Gates
08-13-2012, 06:51 PM
Sorry you lost progress, can I ask what you were doing when the game crashed?

Sorry to reply so late. I minimized it to check something when it happened.

Eheufaucan
08-26-2012, 01:59 PM
Same here. I switched to the desktop (alt+tab) and the game crashed. After that I lost all of my progress (finished around 30 levels so far).

SmudgedCat
08-26-2012, 03:09 PM
I'll look into that, hopefully I'll have an update available soon.

freibooter
08-27-2012, 05:12 AM
There's currently no option in-game to change the language. You'll need to switch the OS language to English if that's what you want.

Don't you want the game in the same language as the OS?
Luckily there doesn't seem to be a German translation included, at least my game is English on my German Windows.

It doesn't matter too much for the kind of games you are making, but there are a lot of people, including myself, that really prefer to play games in their original language and that just hate being forced to play either the localized version or being forced to make system-wide changes in order to change a game's language.

Please, in your future games (and maybe even this one) add an in-game option or even better, use Steam's language setting feature:

http://imgur.com/sTFWq

freibooter
08-27-2012, 07:12 AM
Same here. I switched to the desktop (alt+tab) and the game crashed. After that I lost all of my progress (finished around 30 levels so far).
I just had my first crash as well, the game really doesn't like alt-tab as it seems. :(
Luckily I haven't lost any progress (as far as I can tell). :)

gizmomelb
08-27-2012, 07:26 AM
I'll look into that, hopefully I'll have an update available soon.

thank you to the Dev for being so responsive.. you just influenced me to buy this game, when I was going to pass on it.

if devs (especially console porters) listen to PC customers, then more customers are likely to buy your product (eg: Double Fine added a POV slider to the PC version of STACKING, because a few customers requested the feature).

cagermacleod
08-27-2012, 05:23 PM
My game keeps crashing as well. It is the only program I have running and it will crash within 5 minutes starting the game up.

SmudgedCat
08-28-2012, 04:10 AM
I have just uploaded a new update to the game. Can you check if the problem still occurs and that you are running v1.08 of the game.

Marcelloz
08-28-2012, 07:29 AM
The game doesn't run on Windows 8 Enterprise edition. I got version 1.08 on my system.

The Event viewer reports this :
Application: Shuggy.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeInitializationException
Stack:
at Microsoft.Xna.Framework.Graphics.GraphicsAdapter.g et_Adapters()
at Microsoft.Xna.Framework.GraphicsDeviceManager.AddD evices(Boolean, System.Collections.Generic.List`1<Microsoft.Xna.Framework.GraphicsDeviceInformation>)
at Microsoft.Xna.Framework.GraphicsDeviceManager.Find BestPlatformDevice(Boolean)
at Microsoft.Xna.Framework.GraphicsDeviceManager.Find BestDevice(Boolean)
at Microsoft.Xna.Framework.GraphicsDeviceManager.Chan geDevice(Boolean)
at Microsoft.Xna.Framework.GraphicsDeviceManager.Micr osoft.Xna.Framework.IGraphicsDeviceManager.CreateD evice()
at Microsoft.Xna.Framework.Game.RunGame(Boolean)
at Shuggy.Program.Main(System.String[])

With this signature:
Problem signature:
P1: shuggy.exe
P2: 1.8.0.0
P3: 503c9701
P4: Microsoft.Xna.Framework.Graphics
P5: 4.0.30901.0
P6: 4e6012cb
P7: 296
P8: 33
P9: System.AccessViolationException
P10:

.Net Framework 4 XNA is standard part of W8. Running the 64bit version. Could you look into this? Really want to play the game :)

CaspianRoach
08-28-2012, 08:12 AM
Don't you want the game in the same language as the OS?

No, I don't want that. I prefer the original version over the translation simply because any translation is inherently worse than the original. I want to be able to choose the language I want and I choose english.

I've scoured the registry and all my user preferences folders and couldn't find any locale settings for the game whatsoever. Even running the game through Microsoft AppLocale doesn't seem to fix this.

Please at least add an option to change it or default it to Steam preferences, not OS's.

SmudgedCat
08-29-2012, 01:51 AM
The game doesn't run on Windows 8 Enterprise edition. I got version 1.08 on my system.

.Net Framework 4 XNA is standard part of W8. Running the 64bit version. Could you look into this? Really want to play the game :)

Sounds like an error within XNA as the game is trying to start up. It might be worth trying to uninstall XNA and then selecting "Verify integrity of game cache..." from the Adventures of Shuggy properties menu. It should make sure the right things are installed.

SmudgedCat
08-29-2012, 01:52 AM
No, I don't want that. I prefer the original version over the translation simply because any translation is inherently worse than the original. I want to be able to choose the language I want and I choose english.

I've scoured the registry and all my user preferences folders and couldn't find any locale settings for the game whatsoever. Even running the game through Microsoft AppLocale doesn't seem to fix this.

Please at least add an option to change it or default it to Steam preferences, not OS's.

An update will be going live today which takes the language from the Steam settings so you should be able to play in English.

ASecondOpinion
08-29-2012, 02:22 AM
An update will be going live today which takes the language from the Steam settings so you should be able to play in English.

Hey, SmudgedCat. How come you're an awesome dev who listens and responds with not only answers but updates? It's beautiful to see!

For the record, I'm FrazerJC on Twitter. You're good with the whole response-thing there, too! Thanks!

SmudgedCat
08-29-2012, 02:40 AM
It would seem a bit silly to spend so long making a game and then not really care about it once it's launched. Thanks though, glad I'm making a good impression! :)

CaspianRoach
08-29-2012, 02:47 AM
An update will be going live today which takes the language from the Steam settings so you should be able to play in English.

Thank you! Very glad to see you answer so fast! (Too bad I already completed the game in russian, oh well :D). Thank you for a great game!

BlackMambo
08-29-2012, 07:42 AM
Hi SmudgedCat,
it's great to see a single person put so much efforts in this game, i mean people here write their problems and you both reply and fix them, very few dev teams do this, i'm happy to have given my money too to your project. As a side note i'd ike to know if the "change resolution option" update is in progress or not...tnx and keep up the good work!

SmudgedCat
08-29-2012, 08:58 AM
Yes, an option to change the resolution is in the works. It involves a bit more work so I thought I'd get the small changes that fix the bugs out there first.

BlackMambo
08-29-2012, 09:02 AM
no problem man,
take your time...i've asked just for information....

Marcelloz
08-30-2012, 11:47 AM
Sounds like an error within XNA as the game is trying to start up. It might be worth trying to uninstall XNA and then selecting "Verify integrity of game cache..." from the Adventures of Shuggy properties menu. It should make sure the right things are installed.

Tried this, but it didn't work.

SmudgedCat
08-30-2012, 12:16 PM
I'm not sure what else to suggest, it seems like XNA is failing to initialise for some reason. Unless you have a different graphics card or something you can try?

Marcelloz
08-31-2012, 05:34 AM
I'm not sure what else to suggest, it seems like XNA is failing to initialise for some reason. Unless you have a different graphics card or something you can try?

Not really, but I got it running on another computer, also Windows 8 so I guess it really is a local problem. If I can solve it, I will post the fix. And thanks for the suggestions.

Marcelloz
08-31-2012, 03:04 PM
I'm not sure what else to suggest, it seems like XNA is failing to initialise for some reason. Unless you have a different graphics card or something you can try?

[previous text deleted]
Ok, just uninstalled the official WHQL drivers (301.42)and installed beta drivers (306.02) and the game works! :-)

and now ... let's play!

kuroonehalf
09-03-2012, 12:34 PM
Not sure how helpful this is but I got the leaderboard crash bug just now and got a screenshot of the error screen. http://sadpanda.us/images/1190100-GHM1R7D.jpg

SmudgedCat
09-04-2012, 02:18 AM
Thanks for that picture! I'll have a fix for that in the next update.

cagermacleod
09-08-2012, 08:57 PM
I have just uploaded a new update to the game. Can you check if the problem still occurs and that you are running v1.08 of the game.

How do you tell what version of the game you are running?

Also, as others have said, it's great to see the dev actively talking with people and helping out :D

SmudgedCat
09-09-2012, 11:17 AM
How do you tell what version of the game you are running?

Also, as others have said, it's great to see the dev actively talking with people and helping out :D

It's written in the bottom-left of the screen when you're navigating the menus. The current version is 1.09.